Bug 41467 - No display with switcheroo
Summary: No display with switcheroo
Status: RESOLVED DUPLICATE of bug 37528
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-04 16:45 UTC by Mike Lothian
Modified: 2011-10-05 19:51 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
lspci -nn (1.76 KB, text/x-log)
2011-10-04 16:45 UTC, Mike Lothian
no flags Details
dmesg (44.30 KB, patch)
2011-10-04 16:46 UTC, Mike Lothian
no flags Details | Splinter Review
xorg.log.0 Intel (27.48 KB, text/x-log)
2011-10-04 16:47 UTC, Mike Lothian
no flags Details
xorg.log.0 Radeon (27.48 KB, text/x-log)
2011-10-04 16:47 UTC, Mike Lothian
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Lothian 2011-10-04 16:45:48 UTC
Created attachment 51984 [details]
lspci -nn

Hi

I've gotten a new laptop - HP Envy 14 2002ea

I've configured my kernel for the Intel and Radeon graphics and enabled the switcheroo option too

When booting the kms screen with Tux at the top shows for a split second before going blank - fortunately I can SSH in - also nomodeset works

I'm going to attach the lspci, dmesg and xorg.log for both set as the default

I've also changed the bios setting between Dynamic and Fixed but it's made no difference

If you need any more information please let me know
Comment 1 Mike Lothian 2011-10-04 16:46:27 UTC
Created attachment 51985 [details] [review]
dmesg
Comment 2 Mike Lothian 2011-10-04 16:47:03 UTC
Created attachment 51986 [details]
xorg.log.0 Intel
Comment 3 Mike Lothian 2011-10-04 16:47:35 UTC
Created attachment 51987 [details]
xorg.log.0 Radeon
Comment 4 Mike Lothian 2011-10-04 16:49:18 UTC
I should probably mention that I'm running git master from Linus' tree last updated 6 hours ago with your fixes (I've tried with and without those fixes)

Unfortunately as this is a new laptop I don't know if this is a regression or not
Comment 5 Alex Deucher 2011-10-04 17:01:26 UTC
You have a muxless laptop which means the discrete card is not connected to any displays.  You won't be able to use the discrete card until the xserver gets the ability to decouple rendering and display (i.e., rendering with one GPU, displaying with another).  It's a huge amount of work and won't be supported any time some.
Comment 6 Mike Lothian 2011-10-04 18:33:20 UTC
How do I use the Intel graphics as default?
Comment 7 Mike Lothian 2011-10-05 01:20:52 UTC
OK I've tried only compiling the intel drm on it's own and also the radeon drm on it's own, both with and without vgaswitcheroo and each of those were tested chaning the bios options between fixed and dynamic

Only when both are compiled in and vgaswitcheroo enable do I get a quick flash of a KMS screen before going blank

Intel only goes blank, looks like it is mode setting however

Radeon only doesn't modeset but segfaults unless nomodeset is passed

I'm now running X using the mesa driver :-(

I can live without the power of the Radeon card until xorg or wayland supports render and display on two GPUs, I just need to know how to force Intel to do modesetting
Comment 8 Cedric Sodhi 2011-10-05 01:36:13 UTC
Is this perhaps a duplicate of #41306 ?
Comment 9 Mike Lothian 2011-10-05 03:16:22 UTC
I'll try the lid tonight - is there any other way to force the backlight on if it is the issue?
Comment 10 Cedric Sodhi 2011-10-05 04:43:00 UTC
I know of no reliable way to bring the backlight on, particularly because the actual problem has not yet been determined. However, if you have an external monitor you may try to attach it to VGA on boot and see whether you can see the clone there. If so, you can at least experiment with xrandr, as I described in the bug. Read it carefully, it also is relevant how the laptop is currently supplied [1]. If it turns out to be the same bug as Bug #41306 , please close this one here as a duplicate so that efforts are concentrated and the number of affected users can clearly be seen.

[1] http://marc.info/?l=linux-acpi&m=131749369005052&w=2
Comment 11 Alex Deucher 2011-10-05 06:25:01 UTC
Please open a new bug for backlight problems otherwise things will get confused as this started out as a vgaswitcheroo bug.
Comment 12 Alex Deucher 2011-10-05 06:33:14 UTC

*** This bug has been marked as a duplicate of bug 37528 ***
Comment 13 Mike Lothian 2011-10-05 19:51:32 UTC
Yes it was the backlight - fortunately for me the buttons on my laptop work at increasing the brightness thanks to hp-wmi 

Now I just need to figure out how to make it always boot with the backlight on

Thanks for the help


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.