Bug 41569 - [r600 KMS] Asus A53T A4-3400
[r600 KMS] Asus A53T A4-3400
Status: RESOLVED FIXED
Product: DRI
Classification: Unclassified
Component: DRM/Radeon
XOrg git
x86-64 (AMD64) Linux (All)
: medium normal
Assigned To: Default DRI bug account
:
: 42004 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-07 11:25 UTC by Robert Nelson
Modified: 2012-02-11 07:51 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg (63.38 KB, patch)
2011-10-07 11:25 UTC, Robert Nelson
no flags Details | Splinter Review
Xorg log (38.17 KB, patch)
2011-10-07 11:26 UTC, Robert Nelson
no flags Details | Splinter Review
lspci (30.92 KB, patch)
2011-10-07 11:26 UTC, Robert Nelson
no flags Details | Splinter Review
possible fix (2.47 KB, patch)
2011-10-28 13:16 UTC, Alex Deucher
no flags Details | Splinter Review
possible fix (1.46 KB, patch)
2011-10-28 13:17 UTC, Alex Deucher
no flags Details | Splinter Review
dmesg/system log (62.71 KB, text/plain)
2012-01-10 13:32 UTC, lonefox
no flags Details
Xorg log (32.06 KB, patch)
2012-01-10 13:38 UTC, lonefox
no flags Details | Splinter Review
dmesg of asus a53t with dce fixes patchset (60.61 KB, text/plain)
2012-01-12 21:06 UTC, Robert Nelson
no flags Details
xorg log of asus a53t with dce fixes patchset (42.47 KB, text/plain)
2012-01-12 21:07 UTC, Robert Nelson
no flags Details
fix travis setup (1.76 KB, patch)
2012-02-01 08:50 UTC, Alex Deucher
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Nelson 2011-10-07 11:25:03 UTC
This laptop, has only one standard video connector (VGA) along with the lcd screen.  With 3.1-rc9+ plus airlied's drm-next on bootup bios init the screen, kernel boots in text mode fine, but when KMS takes over the screen goes blank. (the external VGA connector also goes blank). (running latest git of xorg-ati/mesa)

interesting from dmesg;

[   32.534186] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 104
[   32.534191] Raw EDID:
[   32.534194]  	08 08 08 08 08 08 08 08 08 08 08 08 08 08 08 08
[   32.534196]  	08 08 08 08 08 08 08 08 08 08 08 08 08 08 08 08
[   32.534198]  	08 08 08 08 08 08 08 08 08 08 08 08 08 08 08 08
[   32.534199]  	08 08 08 08 08 08 08 08 08 08 08 08 08 08 08 70
[   32.534201]  	08 08 08 08 08 08 08 08 08 08 08 08 08 08 08 08
[   32.534203]  	08 08 08 08 08 08 08 08 08 08 08 08 08 08 08 08
[   32.534205]  	08 08 08 08 08 08 08 08 08 08 08 08 08 08 08 08
[   32.534207]  	08 08 08 08 08 08 08 08 08 08 08 08 08 08 08 08
[   32.589038] [drm:radeon_dp_i2c_aux_ch] *ERROR* aux_ch invalid native reply 0x70

voodoo@a53t:~$ ls -lh /lib/firmware/radeon/TURKS_*
-rw-r--r-- 1 root root  24K 2011-10-06 22:26 /lib/firmware/radeon/TURKS_mc.bin
-rw-r--r-- 1 root root 5.4K 2011-10-06 22:26 /lib/firmware/radeon/TURKS_me.bin
-rw-r--r-- 1 root root 4.4K 2011-10-06 22:26 /lib/firmware/radeon/TURKS_pfp.bin

Regards,
Comment 1 Robert Nelson 2011-10-07 11:25:48 UTC
Created attachment 52095 [details] [review]
dmesg
Comment 2 Robert Nelson 2011-10-07 11:26:04 UTC
Created attachment 52096 [details] [review]
Xorg log
Comment 3 Robert Nelson 2011-10-07 11:26:21 UTC
Created attachment 52097 [details] [review]
lspci
Comment 4 Alex Deucher 2011-10-21 07:43:37 UTC
*** Bug 42004 has been marked as a duplicate of this bug. ***
Comment 5 Alex Deucher 2011-10-28 13:16:46 UTC
Created attachment 52865 [details] [review]
possible fix

patch 1/2
Comment 6 Alex Deucher 2011-10-28 13:17:15 UTC
Created attachment 52866 [details] [review]
possible fix

patch 2/2.  Do these patches help?
Comment 7 Robert Nelson 2011-10-28 22:41:01 UTC
Awesome! Thanks Alex.

KMS is now works perfectly on this laptop..
 
Using v3.1.0 + airlied's drm-next pull for (3.2)

Patch 2 was missing another change you had posted, so it didn't apply:
http://people.freedesktop.org/~agd5f/0009-drm-radeon-kms-rework-DP-bridge-checks.patch

and that patch missed one of the function conversions, so i'm posting a git-format patch dump of the 4 patches I used here:

http://rcn-ee.homeip.net:81/testing/asus-a53t/a4-kms/

Thanks,
Comment 8 Anisse Astier 2011-11-03 09:17:28 UTC
As I said to Alex on IRC, these patches also solves the issue on Toshiba laptops: C670D-10C (AMD E-240) and C670D-11K (AMD E-450).
(Old reference: https://bugzilla.kernel.org/show_bug.cgi?id=34822 )

Just putting that out there.
Comment 9 lonefox 2012-01-10 12:45:58 UTC
These patches may fix some systems, but they also cause a similar problem on my HP ProBook 6465b (A6-3410MX processor with built-in GPU). There is also someone else with the same issue on different ProBook model: http://forums.gentoo.org/viewtopic-t-908460.html
Reverting the patch from comment #6 fixes it at least for me. 

Either way, it is bad for Zathras. :-)
Comment 10 Alex Deucher 2012-01-10 12:51:52 UTC
(In reply to comment #9)
> These patches may fix some systems, but they also cause a similar problem on my
> HP ProBook 6465b (A6-3410MX processor with built-in GPU). There is also someone
> else with the same issue on different ProBook model:
> http://forums.gentoo.org/viewtopic-t-908460.html
> Reverting the patch from comment #6 fixes it at least for me. 

Please attach your xorg log and dmesg output.
Comment 11 lonefox 2012-01-10 13:32:37 UTC
Created attachment 55400 [details]
dmesg/system log

I deleted the buggy kernels already, but here is the system log from a boot with one. It should have full dmesg output in it.
Comment 12 lonefox 2012-01-10 13:38:34 UTC
Created attachment 55401 [details] [review]
Xorg log

I don't think Xorg log is relevant here, but since you asked one, I'm attaching it anyway. This is from working system. The bug happens when the console switches from text mode to graphics mode during boot, so I cannot startx or even log in except with ssh.
Comment 13 Alex Deucher 2012-01-11 14:16:14 UTC
Do these patches work for everyone?
http://people.freedesktop.org/~agd5f/dce_fixes/
They are against drm-next or Linus' tree.
Comment 14 lonefox 2012-01-12 08:48:06 UTC
(In reply to comment #13)
> Do these patches work for everyone?

They do work for me.
Comment 15 Robert Nelson 2012-01-12 21:06:07 UTC
Created attachment 55530 [details]
dmesg of asus a53t with dce fixes patchset
Comment 16 Robert Nelson 2012-01-12 21:07:00 UTC
Created attachment 55531 [details]
xorg log of asus a53t with dce fixes patchset
Comment 17 Robert Nelson 2012-01-12 21:10:18 UTC
Unfortunately those dce fixes regress my asus a53t laptop..

Using Linus's current top of tree with those 4 patches.. Attached dmesg/xorg.log

Is it too early to for qwerk table for these laptops? ;)

Regards,
Comment 18 Alexander Konotop 2012-01-19 04:17:14 UTC
HP 4535s - patches from comment#13 work perfectly. Kernel 3.2.
Comment 19 Florian Mickler 2012-01-21 08:53:40 UTC
A patch referencing this bug report has been merged in Linux v3.2-rc1:

commit cf2aff6eff251b6fbdaf8c253e65ff7c693de8cd
Author: Alex Deucher <alexander.deucher@amd.com>
Date:   Fri Oct 28 16:07:36 2011 -0400

    drm/radeon/kms: fix DP setup on TRAVIS bridges
Comment 20 Alexander Konotop 2012-01-23 05:49:49 UTC
Normal 3.2 kernel doesn't work for me. I tried Debian's 3.2rc7 and Aptosid's 3.2 kernels - they don't work. So seems like the patches haven't been merged into 3.2. Maybe not all of them have been merged, there are 4 patches. I have applied all 4 to my kernel and it works. And I don't think that Debian or Aptosid maintainers have deleted some patches from the original kernel - maybe they have added some but not deleted.
Comment 21 Nikoli 2012-01-28 09:00:21 UTC
I am the author of https://forums.gentoo.org/viewtopic-t-908460.html , do you need any additional info, logs?
Comment 22 Alex Deucher 2012-02-01 08:50:16 UTC
Created attachment 56457 [details] [review]
fix travis setup

Does this patch do the right thing for everyone's platform?  Patch should apply against Linus' master or Dave's drm-fixes branch.
Comment 23 Robert Nelson 2012-02-01 11:26:37 UTC
Alex,

The patch (in comment 22) on top of v3.2.2 works fine with kms on my Asus a53t..

Regards,
Comment 24 lonefox 2012-02-03 23:12:13 UTC
> The patch (in comment 22) on top of v3.2.2 works fine with kms on my Asus
> a53t..

Works on the ProBook too.
Comment 25 Florian Mickler 2012-02-11 07:51:40 UTC
A patch referencing this bug report has been merged in Linux v3.3-rc3:

commit 304a48400d9718f74ec35ae46f30868a5f4c4516
Author: Alex Deucher <alexander.deucher@amd.com>
Date:   Thu Feb 2 10:18:00 2012 -0500

    drm/radeon/kms: fix TRAVIS panel setup