Bug 46008 - Logitech wireless keyboard layout problem since kernel 3.2.1 update
Summary: Logitech wireless keyboard layout problem since kernel 3.2.1 update
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/Keyboard (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-13 12:11 UTC by hickop
Modified: 2016-04-25 20:43 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments
/etc/X11/xorg.conf.d/10-evdev.conf: How I set up my Layout (1.14 KB, application/octet-stream)
2012-02-13 12:11 UTC, hickop
no flags Details
My actual Xorg.0.log (18.47 KB, text/x-log)
2012-02-13 12:13 UTC, hickop
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description hickop 2012-02-13 12:11:48 UTC
Created attachment 56985 [details]
/etc/X11/xorg.conf.d/10-evdev.conf: How I set up my Layout

Since kernel 3.2.1 my Logitech Unifying devices seams to be identified differently.

I'm using an azerty keyboard and set up my layout with the attached 10-evdev.conf

When starting xorg-server with startx my layout is no more automatically set.

If I simply do a "setxkbmap" in a terminal or in .xinitrc then my layout is properly set.

Found this difference in xinput list output.

kernel 3.1.9 xinput list:
~ $ xinput list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                   	id=9	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Power Button                            	id=7	[slave  keyboard (3)]
    ↳ Logitech USB Receiver                   	id=8	[slave  keyboard (3)]

kernel 3.2.1 xinput list:
~ $ xinput list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Logitech Unifying Device. Wireless PID:101b	id=8	[slave  pointer  (2)]
⎜   ↳ Logitech Unifying Device. Wireless PID:2008	id=9	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Power Button                            	id=7	[slave  keyboard (3)]

Actually running with kernel 3.2.5 and the issue is still there.
Comment 1 hickop 2012-02-13 12:13:10 UTC
Created attachment 56986 [details]
My actual Xorg.0.log
Comment 2 laurentcgo 2012-12-22 13:35:13 UTC
The bug today still remains, also in my distro (kernel 3.2.32-1 x86_64) and using a Logitech K750 keyboard.

I did use the workaround by inserting "setxkbmap" in "/etc/X11/Xsession" which resolves the problem after login but not during login (slim).  

I noticed though that when I added a second keyboard (trust.com/16832) AND keyed in some letters, the login "switches" to azerty, also on my Logitech keyboard ...

In my "xinput list" the second keyboard has id=9, my Logitech keyboard appears to be recognised not as a "keyboard" but as a "pointer" under id=11:

~$ xinput list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ 2.4G Wireless Touchpad Keyboard         	id=10	[slave  pointer  (2)]
⎜   ↳ Logitech Unifying Device. Wireless PID:4002	id=11	[slave  pointer  (2)]
⎜   ↳ ImExPS/2 Logitech Explorer Mouse        	id=13	[slave  pointer  (2)]
⎜   ↳ MCE IR Keyboard/Mouse (saa7134)         	id=14	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ 2.4G Wireless Touchpad Keyboard         	id=9	[slave  keyboard (3)]
    ↳ saa7134 IR (ASUSTeK P7131 Hybri         	id=12	[slave  keyboard (3)]
    ↳ HP WMI hotkeys                          	id=15	[slave  keyboard (3)]

In anticipation of a possible solution, I would be please to find a workaround for the remaining erroneous keyboard mapping in the slim login screen.

Gr.
Cgo
Comment 3 Claudio Kozický 2012-12-28 14:48:02 UTC
The cause of this bug seems to be the same as the cause of https://bugs.freedesktop.org/show_bug.cgi?id=58829
Comment 4 laurentcgo 2016-04-25 20:43:47 UTC
Suddenly ... resolved when upgrading xserver-xorg:amd64(1:7.7+15) or xserver-xorg-input-all:amd64 (1:7.7+15) !


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.