Bug 58829 - Gigabyte KM7600 incorrectly identified
Summary: Gigabyte KM7600 incorrectly identified
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/Keyboard (show other bugs)
Version: 7.7 (2012.06)
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-28 14:40 UTC by Claudio Kozický
Modified: 2018-08-10 20:55 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
/var/log/Xorg.0.log (28.58 KB, text/plain)
2012-12-28 14:40 UTC, Claudio Kozický
no flags Details
/etc/X11/xorg.conf.d/10-keyboard.conf (184 bytes, text/plain)
2012-12-28 14:42 UTC, Claudio Kozický
no flags Details
/etc/X11/xorg.conf.d/10-evdev.conf (1.06 KB, text/plain)
2012-12-28 14:44 UTC, Claudio Kozický
no flags Details

Description Claudio Kozický 2012-12-28 14:40:39 UTC
Created attachment 72211 [details]
/var/log/Xorg.0.log

I have discovered that this keyboard (it's actually a keyboard and mouse with a single wireless receiver that connects into a USB slot) doesn't get correctly identified while I was trying to set the keyboard layout from /etc/X11/xorg.conf.d/. The layout from /etc/X11/xorg.conf.d/10-keyboard doesn't get set on the keyboard. But if I connect a different keyboard, the layout is set correctly. From the output of `xinput list` it seems that the keyboard is identified as a 'pointer' instead of 'keyboard' (the KM7600 is the SONiX USB Device):

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ ROCCAT ROCCAT Kova[+]                   	id=8	[slave  pointer  (2)]
⎜   ↳ SONiX USB Device                        	id=10	[slave  pointer  (2)]
⎜   ↳ SONiX USB Device                        	id=11	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Power Button                            	id=7	[slave  keyboard (3)]
    ↳ ROCCAT ROCCAT Kova[+]                   	id=9	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=12	[slave  keyboard (3)]

I am of the opinion that one of the 'SONiX USB Device'es should be in the keyboard section for the keyboard to be identified correctly and for the settings in /etc/X11/xorg.conf.d/10-keyboard to be applied successfully. Applying the settings automatically after login with `setxkbmap -layout "cz,us" -option "grp:alt_shift_toggle"` works as a temporarily workaround.

It seems to me that the cause of this bug is identical to the cause of https://bugs.freedesktop.org/show_bug.cgi?id=46008 and indicates that the bug might affect an even higher amount of keyboards.
Comment 1 Claudio Kozický 2012-12-28 14:42:50 UTC
Created attachment 72212 [details]
/etc/X11/xorg.conf.d/10-keyboard.conf

Keyboard settings.
Comment 2 Claudio Kozický 2012-12-28 14:44:23 UTC
Created attachment 72213 [details]
/etc/X11/xorg.conf.d/10-evdev.conf
Comment 3 laurentcgo 2016-04-25 20:53:20 UTC
This problem was resolved in a similar bug report regarding a.o. Logitech K750 keyboard (https://bugs.freedesktop.org/show_bug.cgi?id=46008), after upgrading  the xserver-xorg (1:7.7+15) package.

Please also check with your keyboard after upgrading the package.
Comment 4 GitLab Migration User 2018-08-10 20:55:26 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-input-keyboard/issues/11.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.