Bug 46205 - Horizontal scrolling on Apple Mighty Mouse reversed recently
Summary: Horizontal scrolling on Apple Mighty Mouse reversed recently
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/Input/Core (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords: regression
: 45614 (view as bug list)
Depends on:
Blocks: xserver-1.12
  Show dependency treegraph
 
Reported: 2012-02-16 19:35 UTC by Bryce Harrington
Modified: 2012-03-21 16:21 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
BootDmesg.txt (57.29 KB, text/plain)
2012-02-16 19:36 UTC, Bryce Harrington
no flags Details
CurrentDmesg.txt (2.64 KB, text/plain)
2012-02-16 19:36 UTC, Bryce Harrington
no flags Details
XorgLog.txt (28.74 KB, text/plain)
2012-02-16 19:36 UTC, Bryce Harrington
no flags Details
xinput.txt (880 bytes, text/plain)
2012-02-16 19:36 UTC, Bryce Harrington
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce Harrington 2012-02-16 19:35:58 UTC
Forwarding this bug from Ubuntu reporter Jason Warner:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/932439

[Problem]
After upgrading from the 1.11.3 to 1.11.99.902 input stack, the horizontal scroll for the Apple Mighty Mouse has reversed.

We tested having him downgrade the -evdev driver (as I noticed it has some recent work with scrolling) back to 2.6.99.901 but that made no difference.

During this timeframe he also upgraded from a v3.2.2 based kernel to v3.2.3.

Manually switching around the buttons worked around the problem locally:
  xinput set-button-map 11 1 2 3 4 5 7 6

[Original Description]
I use an Apple Might Mouse (http://fundapk.com/wp-content/uploads/2011/04/Mighty-Mouse-2005.jpg). The nub in the middle allows for both vertical and horizontal scrolling in the same wheel.

The mouse scroll wheel and/or track pad (my laptop is in the shop so I can't test that) direction changed recently. When I scroll to the right, expecting to move the window (nautilus, say) to the right, it doesn't, it goes left. I think this is called 'natural scrolling'.

Down still scrolls down, up still scrolls up, but left and right seem reversed.

0003:05AC

[    3.926287] input: Mitsumi Electric Apple Optical USB Mouse as /devices/pci0000:00/0000:00:06.0/usb4/4-4/4-4:1.0/input/input6
[    3.926392] apple 0003:05AC:0304.0004: input,hidraw3: USB HID v1.10 Mouse [Mitsumi Electric Apple Optical USB Mouse] on usb-0000:00:06.0-4/input0

Bus 004 Device 003: ID 05ac:0304 Apple, Inc. Optical USB Mouse [Mitsumi]

[     5.872] (II) config/udev: Adding input device Mitsumi Electric Apple Optical USB Mouse (/dev/input/event6)
[     5.872] (**) Mitsumi Electric Apple Optical USB Mouse: Applying InputClass "evdev pointer catchall"
[     5.872] (**) evdev: Mitsumi Electric Apple Optical USB Mouse: Device: "/dev/input/event6"
[     5.872] (--) evdev: Mitsumi Electric Apple Optical USB Mouse: Vendor 0x5ac Product 0x304
[     5.872] (--) evdev: Mitsumi Electric Apple Optical USB Mouse: Found 8 mouse buttons
[     5.872] (--) evdev: Mitsumi Electric Apple Optical USB Mouse: Found scroll wheel(s)
[     5.872] (--) evdev: Mitsumi Electric Apple Optical USB Mouse: Found relative axes
[     5.872] (--) evdev: Mitsumi Electric Apple Optical USB Mouse: Found x and y relative axes
[     5.872] (II) evdev: Mitsumi Electric Apple Optical USB Mouse: Configuring as mouse
[     5.872] (II) evdev: Mitsumi Electric Apple Optical USB Mouse: Adding scrollwheel support
[     5.872] (**) evdev: Mitsumi Electric Apple Optical USB Mouse: YAxisMapping: buttons 4 and 5
[     5.872] (**) evdev: Mitsumi Electric Apple Optical USB Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[     5.872] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:06.0/usb4/4-4/4-4:1.0/input/input6/event6"
[     5.872] (II) XINPUT: Adding extended input device "Mitsumi Electric Apple Optical USB Mouse" (type: MOUSE, id 11)
[     5.873] (II) config/udev: Adding input device Mitsumi Electric Apple Optical USB Mouse (/dev/input/mouse1)

 Virtual core pointer                    	id=2	[master pointer  (3)]
    Mitsumi Electric Apple Optical USB Mouse	id=11	[slave  pointer  (2)]

version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0~rc2-0ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0~rc2-0ubuntu5
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2
Comment 1 Bryce Harrington 2012-02-16 19:36:13 UTC
Created attachment 57182 [details]
BootDmesg.txt
Comment 2 Bryce Harrington 2012-02-16 19:36:27 UTC
Created attachment 57183 [details]
CurrentDmesg.txt
Comment 3 Bryce Harrington 2012-02-16 19:36:43 UTC
Created attachment 57184 [details]
XorgLog.txt
Comment 4 Bryce Harrington 2012-02-16 19:36:54 UTC
Created attachment 57185 [details]
xinput.txt
Comment 5 Bryce Harrington 2012-02-17 13:11:57 UTC
Bug #45614 may be related to or a dupe of this bug.
Comment 6 Timo Aaltonen 2012-02-21 14:29:41 UTC
*** Bug 45614 has been marked as a duplicate of this bug. ***
Comment 7 russianneuromancer 2012-03-03 16:32:46 UTC
Same here for Microsoft Intellimouse Explorer and Logitech Performance MX.
Comment 8 Peter Hutterer 2012-03-14 22:56:06 UTC
http://patchwork.freedesktop.org/patch/9554/
Comment 9 Peter Hutterer 2012-03-21 16:21:46 UTC
commit 99340147b9092a5aaec997eca407282a51e1f063
Author: Peter Hutterer <peter.hutterer@who-t.net>
Date:   Thu Mar 15 15:46:32 2012 +1000

    Fix inverted horizontal scroll (#46205)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.