Bug 5111 - Radeon + SMP + DRI = Crash
Radeon + SMP + DRI = Crash
Status: RESOLVED FIXED
Product: DRI
Classification: Unclassified
Component: DRM/other
XOrg git
x86 (IA32) Linux (All)
: high major
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-21 05:58 UTC by Kyle Robert
Modified: 2006-07-29 07:20 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
kernel log (11.17 KB, text/plain)
2005-11-21 06:07 UTC, Kyle Robert
no flags Details
xorg.conf (1.98 KB, text/plain)
2005-11-21 06:07 UTC, Kyle Robert
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle Robert 2005-11-21 05:58:40 UTC
With DRI enable in xorg.conf file the system Freazes and has to be rebooted. The
card is a ATI Radeon 7000 running with an SMP kernel. When not runnig DRI, xorg
works fine. Also when running a nonSMP kernel with DRI enabled it works fine. Is
there are problem with the radeon module so that it is not SMP safe? I have
similar results on another SMP system with an ATI Radeon 9250.
Comment 1 Kyle Robert 2005-11-21 06:07:09 UTC
Created attachment 3854 [details]
kernel log
Comment 2 Kyle Robert 2005-11-21 06:07:37 UTC
Created attachment 3855 [details]
xorg.conf
Comment 3 Sammy Umar 2005-12-01 04:25:36 UTC
I can confirm the same behavior on my SMP system. 
Comment 4 Sammy Umar 2005-12-01 12:47:30 UTC
Below are the messages right before freeze: 
======================================================== 
Nov 30 19:41:13 localhost kernel: [drm] Loading R300 Microcode 
Nov 30 19:41:13 localhost kernel: irq 11: nobody cared (try booting with the "irqpoll" option) 
Nov 30 19:41:13 localhost kernel:  [<c014a594>] __report_bad_irq+0x24/0x90 
Nov 30 19:41:13 localhost kernel:  [<c014a6a2>] note_interrupt+0x72/0xc0 
Nov 30 19:41:13 localhost kernel:  [<c0149fb9>] __do_IRQ+0xd9/0xf0 
Nov 30 19:41:13 localhost kernel:  [<c0104896>] do_IRQ+0x36/0x70 
Nov 30 19:41:13 localhost kernel:  [<c0103322>] common_interrupt+0x1a/0x20 
Nov 30 19:41:13 localhost kernel:  [<c01204de>] __do_softirq+0x2e/0xa0 
Nov 30 19:41:13 localhost kernel:  [<c0120577>] do_softirq+0x27/0x30 
Nov 30 19:41:13 localhost kernel:  [<c010489b>] do_IRQ+0x3b/0x70 
Nov 30 19:41:13 localhost kernel:  [<c0103322>] common_interrupt+0x1a/0x20 
Nov 30 19:41:13 localhost kernel:  [<c01e007b>] cond_read_bool+0xb/0x100 
Nov 30 19:41:13 localhost kernel:  [<f9bdb902>] radeon_driver_irq_preinstall+0x22/0x30 
[radeon] 
Nov 30 19:41:14 localhost kernel:  [<f9bc21d3>] drm_irq_install+0x133/0x210 [drm] 
Nov 30 19:41:14 localhost kernel:  [<f9bc23db>] drm_control+0x7b/0xa0 [drm] 
Nov 30 19:41:14 localhost kernel:  [<f9bc2360>] drm_control+0x0/0xa0 [drm] 
Nov 30 19:41:14 localhost kernel:  [<f9bc0a33>] drm_ioctl+0xa3/0x1fd [drm] 
Nov 30 19:41:15 localhost kernel:  [<c015c611>] __handle_mm_fault+0x1e1/0x1f0 
Nov 30 19:41:15 localhost kernel:  [<f9bc0990>] drm_ioctl+0x0/0x1fd [drm] 
Nov 30 19:41:15 localhost kernel:  [<c017e849>] do_ioctl+0x69/0x70 
Nov 30 19:41:15 localhost kernel:  [<c017e98c>] vfs_ioctl+0x5c/0x1e0 
Nov 30 19:41:15 localhost kernel:  [<c017eb82>] sys_ioctl+0x72/0x90 
Nov 30 19:41:15 localhost kernel:  [<c01030fb>] sysenter_past_esp+0x54/0x75 
Nov 30 19:41:15 localhost kernel: handlers: 
Nov 30 19:41:15 localhost kernel: [<c02bbdf0>] (yenta_interrupt+0x0/0xc0) 
======================================================= 
Comment 5 Joachim Frieben 2006-01-29 08:43:37 UTC
I have the same problem. My video card is a 7200 (R100) based PCI
board. The mainboard is a PR440FX dual CPU one. Works without DRI
or booting the UP kernel. Concerning comment #4, it is worth
pointing out, that R300 support in Xorg is still experimental.
The 7x00 boards have been around for years, and 3D acceleration
worked already stably about 18 months ago. The regression set in
with the release of Xorg 6.8.2 as far as I remember.
Comment 6 Erik Andren 2006-07-28 10:17:27 UTC
Is this still an issue?
Comment 7 Joachim Frieben 2006-07-29 03:22:54 UTC
In my case, the issue was due to a Red Hat patch (backported from upstream) to
stabilize hardware rendering on Radeon 7xxx hardware. See this link:

  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=180150

and in particular comments #5 and #14 where I had reported that a certain vendor
specific patch was the culprit. There was a later update upstream by M. Dänzer
documented at:

  https://bugs.freedesktop.org/show_bug.cgi?id=4324

which fixed the issue for me (dropping the patch as a whole also worked).
Comment 8 Jerome Glisse 2006-07-29 07:20:33 UTC
Ok thus i close this bug. If original reporter still
have this bug please reopen.