Bug 5149 - Wrong letters displayed in rendered PDF
Summary: Wrong letters displayed in rendered PDF
Status: RESOLVED FIXED
Alias: None
Product: poppler
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
Keywords:
: 4764 5073 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-11-24 21:54 UTC by Jan "Yenya" Kasprzak
Modified: 2007-12-05 18:19 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan "Yenya" Kasprzak 2005-11-24 21:54:21 UTC
When rendering the PDF from http://info.muni.cz/images/pdfmuni/muni07.pdf,
evince displays incorrect letters (even instead of pure US-ASCII characters).
The letters are in the correct font, but not the right letters. I have
originally reported this as an evince bug at
http://bugzilla.gnome.org/show_bug.cgi?id=322118 - but I was asked to report
this as a possible poppler bug. Xpdf renders the above PDF correctly
(screenshots of both xpdf and evince rendering this document are attached to the
above bug in the GNOME bugzilla - I may reattach them here as well if there is
an interest).

This is with evince-0.4.0, poppler 0.4.1, system is Fedora Core 4 Linux (tested
on AMD64 and i386 versions).
Comment 1 Kristian Høgsberg 2005-12-04 12:49:45 UTC
Fixed in CVS HEAD.
Comment 2 Kristian Høgsberg 2005-12-04 15:45:07 UTC
*** Bug 4764 has been marked as a duplicate of this bug. ***
Comment 3 Kristian Høgsberg 2005-12-04 16:13:43 UTC
*** Bug 3975 has been marked as a duplicate of this bug. ***
Comment 4 Bas Zoetekouw 2005-12-10 01:11:36 UTC
I can still reproduce this bug with current (2005-12-08) CVS of evince and
libpoppler.  The pdf from the first comment is shown ok now, but <a
href="http://www.library.cornell.edu/nr/bookcpdf/c5-7.pdf">this document</a> for
example still show the problem.

Reopening the bug.
Comment 5 Kristian Høgsberg 2005-12-10 07:06:56 UTC
What version of freetype are you using and which distro?
Comment 6 Kristian Høgsberg 2005-12-10 07:12:24 UTC
Also, could you try out cvs head, there's different fix for the bug there.
Comment 7 Bas Zoetekouw 2005-12-10 07:15:37 UTC
I'm using libfreetype6 version 2.1.10 on Debian unstable.
Comment 8 Bas Zoetekouw 2005-12-10 07:16:21 UTC
I tested it with CVS head.  Or do you mean libfreetype cvs?
Comment 9 Kristian Høgsberg 2005-12-10 08:03:35 UTC
(In reply to comment #8)
> I tested it with CVS head.  Or do you mean libfreetype cvs?

I meant poppler cvs head, specifically a version that has this change:

2005-12-04  Albert Astals Cid  <aacid@kde.org>

	* poppler/CairoFontEngine.cc: Correct fix for #5149, i broke it when
	merging xpdf 3.01 patches.
Comment 10 Bas Zoetekouw 2005-12-10 08:11:17 UTC
Yes, I used a checkout of this morning, which has your commit:

File: CairoFontEngine.cc        Status: Up-to-date

   Working revision:    1.19
   Repository revision: 1.19    /cvs/poppler/poppler/poppler/CairoFontEngine.cc,v
   Commit Identifier:   59e04394a7154567
Comment 11 Christian Kirbach 2005-12-10 08:34:54 UTC
*** Bug 5073 has been marked as a duplicate of this bug. ***
Comment 12 Christian Kirbach 2005-12-10 09:28:08 UTC
I am using freetype 2.1.7 on Debian testing and can confirm the garbled text.

When opening a file in question the terminal reads

Error: Couldn't find a font for 'Times Roman'
some font thing failed
Error: Couldn't find a font for 'Times Bold'
...

jhbuild checks out like this
 cvs -z3 -q -d :pserver:anoncvs@cvs.freedesktop.org:/cvs/poppler update -dP -A .

I hope it is cvs HEAD.

Now, I had to upgrade to freetype 2.1.10 because of undefined references.
It is still reproducable :(
Comment 13 Christian Kirbach 2005-12-10 09:31:39 UTC
seems so - the enty appears in the Changelog.
Comment 14 Christian Kirbach 2005-12-14 01:49:11 UTC
I have dicovered that latex documents converted to pdf using dvipdf are 
displayed with garbled characters *if the "Times" font is used*. If I switch to 
other fonts (e.g. bookman,newcent, or the default latex font) I cannot see that 
behaviour.

Hope this may be of any help.
freetype 2.1.10
Comment 15 Brad Hards 2007-12-04 01:56:08 UTC
Is this still a problem? The link in comment #4 is broken.
Comment 16 Bas Zoetekouw 2007-12-04 15:18:19 UTC
An alternate download location for the link in comment #4 is http://www.fizyka.umk.pl/nrbook/c5-7.pdf

It displays perfectly with evince 0.9.0 and poppler 0.5.4 (Debian sid)
Comment 17 Brad Hards 2007-12-05 18:19:29 UTC
Original reporter confirmed now OK.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.