Bug 5245 - After loading a Xserver with the glx module the network stops working
After loading a Xserver with the glx module the network stops working
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/r300
unspecified
x86 (IA32) Linux (All)
: high major
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-05 06:50 UTC by Diego
Modified: 2008-01-11 11:43 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
X server log (19.64 KB, text/plain)
2005-12-06 01:11 UTC, Diego
Details
X server config file (3.07 KB, text/plain)
2005-12-06 01:11 UTC, Diego
Details
Cpuinfo file (436 bytes, text/plain)
2005-12-06 02:08 UTC, Diego
Details
Interrupts (this is with the network working and glx extension not loaded) (616 bytes, text/plain)
2005-12-06 02:09 UTC, Diego
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego 2005-12-05 06:50:57 UTC
I don't really know were to report this problem. Mesa, kernel or Xserver.

Any way, whenever i load a Xserver with the glx extension, the network doesn't
work any more, if i modify the xorg.conf file so that the X server doesn't load
this extension everything works ok.

This is what i get:

on the console: 
  calisto kernel: Disabling IRQ #169

This is what i get on kern.log:
Dec  4 20:42:11 calisto kernel: irq 169: nobody cared (try booting with the
"irqpoll" option)
Dec  4 20:42:11 calisto kernel:  [__report_bad_irq+36/144]
__report_bad_irq+0x24/0x90
Dec  4 20:42:11 calisto kernel:  [note_interrupt+114/192] note_interrupt+0x72/0xc0
Dec  4 20:42:11 calisto kernel:  [__do_IRQ+226/272] __do_IRQ+0xe2/0x110
Dec  4 20:42:11 calisto kernel:  [do_IRQ+25/48] do_IRQ+0x19/0x30
Dec  4 20:42:11 calisto kernel:  [common_interrupt+26/32] common_interrupt+0x1a/0x20
Dec  4 20:42:11 calisto kernel:  [pg0+947469200/1069540352]
acpi_processor_idle+0x1a1/0x27a [processor]
Dec  4 20:42:11 calisto kernel:  [cpu_idle+65/96] cpu_idle+0x41/0x60
Dec  4 20:42:11 calisto kernel:  [start_kernel+351/384] start_kernel+0x15f/0x180
Dec  4 20:42:11 calisto kernel:  [unknown_bootoption+0/480]
unknown_bootoption+0x0/0x1e0
Dec  4 20:42:11 calisto kernel: handlers:
Dec  4 20:42:11 calisto kernel: [usb_hcd_irq+0/96] (usb_hcd_irq+0x0/0x60)
Dec  4 20:42:11 calisto kernel: [usb_hcd_irq+0/96] (usb_hcd_irq+0x0/0x60)
Dec  4 20:42:11 calisto kernel: [pg0+947845136/1069540352]
(snd_intel8x0_interrupt+0x0/0x250 [snd_intel8x0])
Dec  4 20:42:11 calisto kernel: [pg0+947704960/1069540352]
(tg3_interrupt_tagged+0x0/0x110 [tg3])
Dec  4 20:42:11 calisto kernel: Disabling IRQ #169

I'm sorry if this is not the right place to report the problem. In such a case
should i file the bug in the kernel bugzilla?

Thank you very much
Comment 1 Michel Dänzer 2005-12-06 00:44:47 UTC
If this is with SMP, it's probably a duplicate of bug 5111. Otherwise, please
attach the X server config and log files.
Comment 2 Diego 2005-12-06 01:09:17 UTC
No, it is an uniprocessor system.
Comment 3 Diego 2005-12-06 01:11:07 UTC
Created attachment 4001 [details]
X server log
Comment 4 Diego 2005-12-06 01:11:53 UTC
Created attachment 4002 [details]
X server config file
Comment 5 Michel Dänzer 2005-12-06 01:40:53 UTC
Please also attach /proc/cpuinfo and /proc/interrupts.

Does it also happen if you comment out options "AGPMode" and "DynamicClocks" in
xorg.conf?

What if you disable CONFIG_PREEMPT in the kernel configuration?
Comment 6 Diego 2005-12-06 02:08:21 UTC
Created attachment 4004 [details]
Cpuinfo file
Comment 7 Diego 2005-12-06 02:09:06 UTC
Created attachment 4005 [details]
Interrupts (this is with the network working and glx extension not loaded)
Comment 8 Diego 2005-12-06 02:10:16 UTC
I'll post the result of the other things you suggested in some hours, right now
i'm working and can't reboot with a new kernel or be without network.
Comment 9 Diego 2005-12-07 13:51:21 UTC
> Does it also happen if you comment out options "AGPMode" and "DynamicClocks" in
> xorg.conf?

This doesn't change anything, i still loose network connection with those disabled



Comment 10 Diego 2006-01-30 11:23:26 UTC
I recompiled everything today, DRM, kernel, Mesa and X.Org server. This time i
took the time to try a standard desktop configuration and the one you suggested:

CONFIG_PREEMPT_NONE=y
# CONFIG_PREEMPT_VOLUNTARY is not set
# CONFIG_PREEMPT is not set

The result is the same, no network when the glx, dri and drm modules are loaded
into the Xserver. The trace that i get in kern.log is this:

Jan 30 01:17:59 calisto kernel: irq 169: nobody cared (try booting with the
"irqpoll" option)
Jan 30 01:17:59 calisto kernel:  [__report_bad_irq+43/105]
__report_bad_irq+0x2b/0x69
Jan 30 01:17:59 calisto kernel:  [note_interrupt+107/143] note_interrupt+0x6b/0x8f
Jan 30 01:17:59 calisto kernel:  [__do_IRQ+104/143] __do_IRQ+0x68/0x8f
Jan 30 01:17:59 calisto kernel:  [do_IRQ+29/40] do_IRQ+0x1d/0x28
Jan 30 01:17:59 calisto kernel:  [common_interrupt+26/32] common_interrupt+0x1a/0x20
Jan 30 01:17:59 calisto kernel:  [pg0+949345105/1069827072]
acpi_processor_idle+0x153/0x2bd [processor]
Jan 30 01:17:59 calisto kernel:  [cpu_idle+63/87] cpu_idle+0x3f/0x57
Jan 30 01:17:59 calisto kernel:  [start_kernel+315/317] start_kernel+0x13b/0x13d
Jan 30 01:17:59 calisto kernel: handlers:
Jan 30 01:17:59 calisto kernel: [usb_hcd_irq+0/79] (usb_hcd_irq+0x0/0x4f)
Jan 30 01:17:59 calisto kernel: [usb_hcd_irq+0/79] (usb_hcd_irq+0x0/0x4f)
Jan 30 01:17:59 calisto kernel: [pg0+947762531/1069827072]
(snd_intel8x0_interrupt+0x0/0x1b7 [snd_intel8x0])
Jan 30 01:17:59 calisto kernel: [pg0+944433224/1069827072]
(tg3_interrupt_tagged+0x0/0xba [tg3])
Jan 30 01:17:59 calisto kernel: Disabling IRQ #169

I'm using linux 2.6.15.1

This time it seems that the wireless is working, but not the wired network, i
have a tg3 network card.
Comment 11 Benjamin Close 2008-01-11 02:36:40 UTC
Bugzilla Upgrade Mass Bug Change

NEEDSINFO state was removed in Bugzilla 3.x, reopening any bugs previously listed as NEEDSINFO.

  - benjsc
    fd.o Wrangler
Comment 12 Alex Deucher 2008-01-11 11:43:45 UTC
If you are still having the same problem with a more recent xserver, ati driver, and drm, please re-open.