Bug 55951 - [regression] Torchlight exits with BadDrawable (invalid Pixmap or Window parameter)
Summary: [regression] Torchlight exits with BadDrawable (invalid Pixmap or Window para...
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: mesa-dev
QA Contact:
Depends on:
Reported: 2012-10-13 14:27 UTC by Sven Arvidsson
Modified: 2018-03-07 20:03 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:

backtrace (1.21 KB, text/plain)
2012-10-13 14:27 UTC, Sven Arvidsson

Description Sven Arvidsson 2012-10-13 14:27:28 UTC
Created attachment 68521 [details]

The latest build of the game Torchlight segfaults on start with Mesa 9.0 or git master. The crash happens in  BlitNtoNCopyAlpha () in SDL2, but only if the game is set to launch full-screen.

Bisecting finds this commit:

0671400dcc72553b5f9719639e86069a1734dbe5 is the first bad commit
commit 0671400dcc72553b5f9719639e86069a1734dbe5
Author: Marek Olšák <maraeo@gmail.com>
Date:   Mon Jan 30 08:54:01 2012 +0100

    r600g: remove more dead code

:040000 040000 58df98411f4a2cf7dc210e8f1cd62007e6c1e498 9cb5194b10e5ff5dd0d1e0eb5da6cd834528beab M	src

I tried reverting this on master but it seems dependent on other changes, so it doesn't build. OTOH, the commit immediately prior to this one, 74027a9ba250f07a77ee40e105c50c27e4fc3bc0 is working so it's probably the right one.

I'm not sure if this is a driver problem or a bug in SDL, considering that earlier builds of the game worked fine with Mesa 9.0.

System environment:
-- system architecture: 32-bit
-- Linux distribution: Debian unstable
-- Model: XFX Radeon HD 5670 1GB
-- Display connector: DVI
-- xf86-video-ati: 6.14.4
-- xserver: 1.12.4
-- mesa: 8.0.2
-- drm: 2.4.39
-- kernel: 3.5.2
Comment 1 Sven Arvidsson 2013-09-20 19:57:16 UTC
This is still a problem with Mesa 9.2 and the game build from 2013-05-21, but something has changed, now I get a BadDrawable error and the game exits so there's no crash or backtrace to get:

X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request:  137 (DRI2)
  Minor opcode of failed request:  3 (DRI2CreateDrawable)
  Resource id in failed request:  0x3800002
  Serial number of failed request:  23
  Current serial number in output stream:  25
Comment 2 Sven Arvidsson 2013-09-29 16:13:19 UTC
Reassigning to mesa core as this has also been reported on i965.
Comment 3 scrawl 2013-10-18 15:04:37 UTC
I've created a test case to reproduce this issue (or at least a similar one) here:
Comment 4 Sven Arvidsson 2018-03-07 20:03:12 UTC
The testcase bug was closed: #70621 and the game seems fine too using Mesa 17 on radeonsi.

Launched five times in a row without crashes or errors.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.