Bug 56042 - [865G] BadAlloc (insufficient resources for operation)
[865G] BadAlloc (insufficient resources for operation)
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
9.0
x86 (IA32) Linux (All)
: high normal
Assigned To: Matwey V. Kornilov
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 18:03 UTC by Götz
Modified: 2013-10-17 14:49 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg (40.21 KB, text/plain)
2012-10-16 18:03 UTC, Götz
Details
Xorg.0.log (27.28 KB, text/plain)
2012-10-16 18:04 UTC, Götz
Details
The patch to fix this issue (1.01 KB, patch)
2013-10-17 14:49 UTC, Matwey V. Kornilov
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Götz 2012-10-16 18:03:24 UTC
Created attachment 68637 [details]
dmesg

When I run glxinfo, or any 3D application, the app doesn't start, and I only get this error. With Mesa 8.0.4 there was no problem.

$ glxinfo 
name of display: :0
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  153 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Serial number of failed request:  22
  Current serial number in output stream:  25

-----------

Linux 3.6.2
X Server 1.13.0
libdrm 2.4.39
xf86-video-intel 2.20.10

00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
        Subsystem: ASRock Incorporation Device 2572
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx+
        Latency: 0
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at f0000000 (32-bit, prefetchable) [size=128M]
        Region 1: Memory at ff280000 (32-bit, non-prefetchable) [size=512K]
        Region 2: I/O ports at ec00 [size=8]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [d0] Power Management version 1
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Kernel driver in use: i915

I don't know what information should I provide.
Comment 1 Götz 2012-10-16 18:04:57 UTC
Created attachment 68638 [details]
Xorg.0.log
Comment 2 Yunrui Hu 2012-11-03 15:03:09 UTC
I got the same problem with mesa 9.0.1
Comment 3 Hallose Roman 2012-11-07 14:26:52 UTC
I have the same problem here with the new mesa 9.0

Additional Info:

(tested with extra/xf86-video-intel 2.20.12  under mesa 9.0)
Dell Dimension 4600i or similar.
Intel Corporation 82865G Integrated Graphics Controller (rev 02)
archlinux

I downgraded my mesa to 8.0.4. and libgl too.

Waiting for a bug fix. Thank you.
Comment 4 René Herman 2012-11-17 01:22:04 UTC
Just another "me too"; mesa-9.0 breaks any all DRI on 865G, with only the here mentioned error message as a result from running any 3D application.

I also downgraded to 8.0.4, which works very well on this hardware -- which actually surprised me a bit when testing, since the xorg intel driver was problematic on older hardware for a long time. I therefore quite hope that this is just a bug and not an abandonment?
Comment 5 René Herman 2012-11-18 02:55:08 UTC
(still current for mesa-9.0.1)
Comment 6 Ian Romanick 2012-11-20 16:57:41 UTC
Is there any chance that you're all using Arch?  We've recently seen some other similar weirdness that we could only reproduce on Arch.
Comment 7 Götz 2012-11-20 23:53:10 UTC
As many users have reported, this problem also happens in the Ubuntu packages: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1071530
I see this problem in my machine using Arch and Ubuntu.
Comment 8 René Herman 2012-11-24 02:18:31 UTC
@ Ian:

Sorry, I didn't get email when you replied so missed it (have now added myself to the CC list). I am in fact on Arch, but, yes, the problem is shared with Ubuntu at least.

It's interesting though. The Arch bug report is here (it's just me up to now):

https://bugs.archlinux.org/task/32666

If you know of something that Arch could do different in order to avoid this or that other earlier problem that you speak of, I'm very sure the Arch X maintainers would be interested in hearing about it.

(posting to that bug report will get it noticed; I could also relay it, if need be).
Comment 9 René Herman 2012-12-05 20:13:37 UTC
This is marked as "NEEDINFO". Is there anything I can provide?
Comment 10 Hallose Roman 2012-12-06 16:46:27 UTC
As example:

$ etracer #extreem tuxracer (an opengl programm)

X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  153 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Serial number of failed request:  25
  Current serial number in output stream:  26

This happens to all opengl application.

Installed on my Archlinux:

extra/intel-dri 9.0.1-1
extra/xf86-video-intel 2.20.14-1
extra/xorg-server 1.13.0-4
extra/libgl 9.0.1-1

Intel Corporation 82865G Integrated Graphics Controller (rev 02)

Its nearly 2 Months, no one will fix it. Its took too much time.
Please give more Support for the old cards like this, they're many out there using them.

Thanks.
Comment 11 György Balló 2012-12-14 15:20:37 UTC
Same here on my 845G system with mesa 9.0 on Arch Linux:
Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)

Downgrading to mesa 8.0.4 solves the problem.
Comment 12 Hallose Roman 2012-12-25 20:23:02 UTC
PUSH
Please Fix. Another month ago...

If you can't fix it, so clear the supported Status:

http://dri.freedesktop.org/wiki/Intel
Comment 13 René Herman 2013-01-15 17:24:47 UTC
Ping.
Comment 14 Russ Hay 2013-01-30 12:33:35 UTC
Same problem on opensuse 12.3 (Beta 1) with Mesa-9.0.1-31.1.i586

Intel 845G Chipset
Comment 15 Hallose Roman 2013-02-11 10:35:50 UTC
On an updated ArchLinux:

intel-dri-9.0.2
libegl-9.0.2
libdrm-2.4.42
(mesa-9.0.2)

glxinfo(and other 3D application) crashes:

BadAlloc (insufficient resources for operation)
Comment 16 René Herman 2013-02-25 02:26:21 UTC
This specific issue has been fixed (for me, Intel 865G on arch linux) in mesa-9.1-2 which is at the time of writing in the testing repository.

9.1 does regress with respect to 8.0 (ie, "Speed Dreams" just crashed on me, which it didn't use to) but that sort of thing is just business as usual for older intel. In two releases time, nothing will work anymore again, so let's count our blessings for now.

Or rather, I guess from the reply one above,  let's count the number of opensuse users -- and prey to god it stays above 1000 so that the pack of drug-crazed baboons that have been fucking up 3D on older intel on basically each and every release for multiple years now keeps getting told so by en entity with a cool corporate presence.

Or something. Go Wayland go.
Comment 17 René Herman 2013-02-25 02:39:55 UTC
Ouch, that's painful. I just found out that Wayland also uses mesa...
Comment 18 Götz 2013-03-16 22:56:12 UTC
As René said, although many programs break with Mesa 9.1, this specific issue has been fixed (865G).
Comment 19 Javi Barroso 2013-03-28 23:46:58 UTC
Is it possible to backport this fixes to Ubuntu version available in raring ?
Comment 20 Matwey V. Kornilov 2013-10-17 14:49:43 UTC
Created attachment 87794 [details] [review]
The patch to fix this issue

Attached here is a patch (tested) to fix this issue for Mesa 9.0.

You are also welcome to pull the commit from my github: https://github.com/matwey/mesa branch fix_i830_context