Bug 5628 - man3/XParseColor.3x points to "man3x/XQueryColor.3x.gz"
man3/XParseColor.3x points to "man3x/XQueryColor.3x.gz"
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Documentation
unspecified
x86 (IA32) Linux (All)
: high normal
Assigned To: Alan Coopersmith
:
: 5841 5947 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-17 07:09 UTC by Bill Crawford
Modified: 2006-05-08 12:47 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bill Crawford 2006-01-17 07:09:33 UTC
Naturally this is leading to error messages like this one:

[bill@pikachu ~]$ man XParseColor
fopen: No such file or directory
Cannot open man page /usr/share/man/man3x/XQueryColor.3x.gz
No manual entry for XParseColor
Comment 1 Alan Coopersmith 2006-01-28 12:09:41 UTC
Oops, missed this when I provided for LIB_MAN_DIR to be different than
LIB_MAN_SUFFIX - will fix.
Comment 2 Alan Coopersmith 2006-02-09 02:11:52 UTC
*** Bug 5841 has been marked as a duplicate of this bug. ***
Comment 3 Alan Coopersmith 2006-02-13 05:29:23 UTC
Fix checked in to CVS head to put LIB_MAN_DIR_SUFFIX in .so links
and to try to figure out LIB_MAN_DIR_SUFFIX from the LIB_MAN_DIR
value.   May need tweaking for unusual environments (if LIB_MAN_DIR
is not in the form $mandir/man$LIB_MAN_DIR_SUFFIX it will fail).

CVSROOT:	/cvs/xorg
Module name:	lib
Changes by:	alanc@gabe.freedesktop.org	06/02/12 10:19:23

Log message:
  2006-02-12  Alan Coopersmith  <alan.coopersmith@sun.com>
  
  	* man/Makefile.am:
  	Bug #5628 <https://bugs.freedesktop.org/show_bug.cgi?id=5628>
  	Shadow pages not created correctly when MANDIR & MANSUFFIX don't match.

Modified files:
      lib/X11/:
        ChangeLog 
      lib/X11/man/:
        Makefile.am 
      lib/XRes/:
        ChangeLog 
      lib/XRes/man/:
        Makefile.am 
      lib/XScrnSaver/:
        ChangeLog 
      lib/XScrnSaver/man/:
        Makefile.am 
      lib/Xevie/:
        ChangeLog 
      lib/Xevie/man/:
        Makefile.am 
      lib/Xext/:
        ChangeLog 
      lib/Xext/man/:
        Makefile.am 
      lib/Xfontcache/:
        ChangeLog 
      lib/Xfontcache/man/:
        Makefile.am 
      lib/Xi/:
        ChangeLog 
      lib/Xi/man/:
        Makefile.am 
      lib/Xrandr/:
        ChangeLog 
      lib/Xrandr/man/:
        Makefile.am 
      lib/Xt/:
        ChangeLog 
      lib/Xt/man/:
        Makefile.am 
      lib/Xxf86dga/:
        ChangeLog 
      lib/Xxf86dga/man/:
        Makefile.am 
      lib/Xxf86misc/:
        ChangeLog 
      lib/Xxf86misc/man/:
        Makefile.am 
      lib/Xxf86vm/:
        ChangeLog 
      lib/Xxf86vm/man/:
        Makefile.am 
  
  Revision      Changes    Path
  1.45          +6 -0      lib/X11/ChangeLog
  http://cvs.freedesktop.org/xorg/lib/X11/ChangeLog
  1.14          +144 -141  lib/X11/man/Makefile.am
  http://cvs.freedesktop.org/xorg/lib/X11/man/Makefile.am
  1.13          +6 -0      lib/XRes/ChangeLog
  http://cvs.freedesktop.org/xorg/lib/XRes/ChangeLog
  1.7           +4 -2      lib/XRes/man/Makefile.am
  http://cvs.freedesktop.org/xorg/lib/XRes/man/Makefile.am
  1.14          +6 -0      lib/XScrnSaver/ChangeLog
  http://cvs.freedesktop.org/xorg/lib/XScrnSaver/ChangeLog
  1.8           +4 -2      lib/XScrnSaver/man/Makefile.am
  http://cvs.freedesktop.org/xorg/lib/XScrnSaver/man/Makefile.am
  1.10          +6 -0      lib/Xevie/ChangeLog
  http://cvs.freedesktop.org/xorg/lib/Xevie/ChangeLog
  1.6           +4 -2      lib/Xevie/man/Makefile.am
  http://cvs.freedesktop.org/xorg/lib/Xevie/man/Makefile.am
  1.15          +6 -0      lib/Xext/ChangeLog
  http://cvs.freedesktop.org/xorg/lib/Xext/ChangeLog
  1.10          +5 -3      lib/Xext/man/Makefile.am
  http://cvs.freedesktop.org/xorg/lib/Xext/man/Makefile.am
  1.13          +6 -0      lib/Xfontcache/ChangeLog
  http://cvs.freedesktop.org/xorg/lib/Xfontcache/ChangeLog
  1.6           +4 -2      lib/Xfontcache/man/Makefile.am
  http://cvs.freedesktop.org/xorg/lib/Xfontcache/man/Makefile.am
  1.11          +6 -0      lib/Xi/ChangeLog
  http://cvs.freedesktop.org/xorg/lib/Xi/ChangeLog
  1.7           +17 -15    lib/Xi/man/Makefile.am
  http://cvs.freedesktop.org/xorg/lib/Xi/man/Makefile.am
  1.14          +6 -0      lib/Xrandr/ChangeLog
  http://cvs.freedesktop.org/xorg/lib/Xrandr/ChangeLog
  1.8           +4 -2      lib/Xrandr/man/Makefile.am
  http://cvs.freedesktop.org/xorg/lib/Xrandr/man/Makefile.am
  1.26          +6 -0      lib/Xt/ChangeLog
  http://cvs.freedesktop.org/xorg/lib/Xt/ChangeLog
  1.8           +74 -72    lib/Xt/man/Makefile.am
  http://cvs.freedesktop.org/xorg/lib/Xt/man/Makefile.am
  1.10          +6 -0      lib/Xxf86dga/ChangeLog
  http://cvs.freedesktop.org/xorg/lib/Xxf86dga/ChangeLog
  1.7           +4 -2      lib/Xxf86dga/man/Makefile.am
  http://cvs.freedesktop.org/xorg/lib/Xxf86dga/man/Makefile.am
  1.9           +6 -0      lib/Xxf86misc/ChangeLog
  http://cvs.freedesktop.org/xorg/lib/Xxf86misc/ChangeLog
  1.7           +4 -2      lib/Xxf86misc/man/Makefile.am
  http://cvs.freedesktop.org/xorg/lib/Xxf86misc/man/Makefile.am
  1.9           +6 -0      lib/Xxf86vm/ChangeLog
  http://cvs.freedesktop.org/xorg/lib/Xxf86vm/ChangeLog
  1.7           +4 -2      lib/Xxf86vm/man/Makefile.am
  http://cvs.freedesktop.org/xorg/lib/Xxf86vm/man/Makefile.am
Comment 4 Joshua Baergen 2006-02-19 15:53:54 UTC
*** Bug 5947 has been marked as a duplicate of this bug. ***
Comment 5 Kevin E. Martin 2006-05-09 05:47:13 UTC
FYI, libXau also had this problem.
I just checked in a fix for this in CVS.