Bug 5947 - libX11 shadow man pages reference wrong section
Summary: libX11 shadow man pages reference wrong section
Status: CLOSED DUPLICATE of bug 5628
Alias: None
Product: xorg
Classification: Unclassified
Component: Lib/Xlib (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Jim Gettys
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-19 13:17 UTC by Philip Kovacs
Modified: 2011-10-15 17:23 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philip Kovacs 2006-02-19 13:17:49 UTC
On linux, LIB_MAN_SUFFIX is set to 3x, but LIB_MAN_DIR is set to $(mandir)/man3,
causing the man pages to be installed in section man3, but with shadow man page
references of the form:

.so man3x/<main page>

This causes all requests for shadow pages to generate an error of the form:

man <shadow page>
../../man3x/<main page>.3x.gz not found

Examples;

man XConfigureWindow (works as its a main page, but)
man XMoveWindow (fails with a bad reference to ./man3x/XConfigureWindow.3x.gz)

Another Example:

man XGrabPointer (works -- main page)
man XUngrabPointer (fails -- shadow to ./man3x/XGrabPointer.3x.gz)

On Gentoo, I proposed a distro patch moving all the main and shadow pages to 
section 3.  

Ref: http://bugs.gentoo.org/show_bug.cgi?id=123328
Comment 1 Joshua Baergen 2006-02-19 15:45:16 UTC
I don't think this is the proper solution.  The man pages are ending up in the
right place with the right suffix.

In fact, it would appear that there is a bug in libX11's Makefile.am.  Patch
coming shortly...
Comment 2 Joshua Baergen 2006-02-19 15:53:54 UTC
Ahah, upon searching around this is a duplicate of bug #5628.

*** This bug has been marked as a duplicate of 5628 ***
Comment 3 Philip Kovacs 2006-02-19 16:01:40 UTC
The other way to fix it, as I see it, would be to change the shadows.DONE
section of man/Makefile.am so that LIB_MAN_SUFFIX is man3, not man3x, but only
in that section of the Makefile.am.

That will cause the man pages to retain the 3x suffix, while correcting the
contents of the shadow files to:

.so man3/<main page>.3x.gz

instead if

.so man3x/<main page>.3x.gz

Either way works.  

Phil


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.