Bug 57777 - lcd screen of a laptop does not wake up after sleep
Summary: lcd screen of a laptop does not wake up after sleep
Status: RESOLVED DUPLICATE of bug 59057
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: 7.6 (2010.12)
Hardware: Other All
: medium normal
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-01 15:59 UTC by Alin M Elena
Modified: 2013-02-21 11:23 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg log (95.90 KB, text/plain)
2012-12-01 15:59 UTC, Alin M Elena
no flags Details
log for 3.8rc2 with debug activated (909.45 KB, text/plain)
2013-01-07 20:15 UTC, Alin M Elena
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alin M Elena 2012-12-01 15:59:56 UTC
Created attachment 70883 [details]
dmesg log

the lcd screen of the laptop remains off after resume... the external display comes on as expected...
Linux abbaton.ucd.ie 3.7.0-rc6-5-desktop #1 SMP PREEMPT Tue Nov 27 14:10:39 UTC 2012 (f8c5dde) x86_64 x86_64 x86_64 GNU/Linux


I have attached the dmesg log.


other funny things...
*if I start only with the lcd... kde would not start just freeze before plasma being loaded ( probably another bug to be reported.)
* I have a last good commit and first bad commit from an older version of the nouveau git
last good http://cgit.freedesktop.org/nouveau/linux-2.6/commit/?id=f4a75d2eb7b1e2206094b901be09adb31ba63681
first bad http://cgit.freedesktop.org/nouveau/linux-2.6/commit/?id=9677f3d63de8f87d8e18a5509c8b18eed468e379

I was trying to bisect but because of the 3.7 rebase I am lost... sorry
Comment 1 Alin M Elena 2013-01-07 19:16:09 UTC
I have tested with 3.8rc2 both default driver and 3.8rc2 with the nouveau master compiled... both show the same behaviour as described above.
The 3.7.1 kernel with the driver that comes works...but fills my log with trapped read and write errors.

Alin
Comment 2 Marcin Slusarz 2013-01-07 19:29:46 UTC
Probably connected: bug 59057, bug 58729.
Comment 3 Alin M Elena 2013-01-07 20:14:02 UTC
I have tried the patch suggested in bug 59057 but the same situation...
I have attached the log for it with the debug activated.

Alin
Comment 4 Alin M Elena 2013-01-07 20:15:08 UTC
Created attachment 72649 [details]
log for 3.8rc2 with debug activated
Comment 5 Marcin Slusarz 2013-01-07 21:41:02 UTC
Please verify 186ecad21 is the first bad commit (boot 186ecad21 and 4a230fa618).
Comment 6 Alin M Elena 2013-01-07 21:46:54 UTC
Hi Marcin,

I will give it a try sometime tomorrow.

Alin
Comment 7 Alin M Elena 2013-01-08 13:06:41 UTC
Hi Marcin,

unless I do something very silly I did not manage to compile the two commits indicated against 3.8rc2
Here what I have done

git clone --depth 0 git://anongit.freedesktop.org/nouveau/linux-2.6 nouveau
cd nouveau
git checkout 186ecad21

extracted the needed folders and compiled... 
got the error...
[   37s] /home/abuild/rpmbuild/BUILD/drm-nouveau-1357654062/master/obj/desktop/drivers/gpu/drm/nouveau/nouveau_bo.c: In function 'nouveau_bo_validate':
[   37s] /home/abuild/rpmbuild/BUILD/drm-nouveau-1357654062/master/obj/desktop/drivers/gpu/drm/nouveau/nouveau_bo.c:400:10: error: too many arguments to function 'ttm_bo_validate'
[   37s] In file included from /home/abuild/rpmbuild/BUILD/drm-nouveau-1357654062/master/obj/desktop/drivers/gpu/drm/nouveau/nouveau_drm.h:22:0,
[   37s]                  from /home/abuild/rpmbuild/BUILD/drm-nouveau-1357654062/master/obj/desktop/drivers/gpu/drm/nouveau/nouveau_bo.c:36:
[   37s] /usr/src/linux-3.8.0-rc2-2/include/drm/ttm/ttm_bo_api.h:350:12: note: declared here
[   37s] /home/abuild/rpmbuild/BUILD/drm-nouveau-1357654062/master/obj/desktop/drivers/gpu/drm/nouveau/nouveau_bo.c: In function 'nouveau_bo_move_accel_cleanup':
[   37s] /home/abuild/rpmbuild/BUILD/drm-nouveau-1357654062/master/obj/desktop/drivers/gpu/drm/nouveau/nouveau_bo.c:570:6: error: incompatible type for argument 5 of 'ttm_bo_move_accel_cleanup'
[   37s] In file included from /home/abuild/rpmbuild/BUILD/drm-nouveau-1357654062/master/obj/desktop/drivers/gpu/drm/nouveau/nouveau_drm.h:23:0,
[   37s]                  from /home/abuild/rpmbuild/BUILD/drm-nouveau-1357654062/master/obj/desktop/drivers/gpu/drm/nouveau/nouveau_bo.c:36:
[   37s] /usr/src/linux-3.8.0-rc2-2/include/drm/ttm/ttm_bo_driver.h:968:12: note: expected 'struct ttm_mem_reg *' but argument is of type 'bool'
[   37s] /home/abuild/rpmbuild/BUILD/drm-nouveau-1357654062/master/obj/desktop/drivers/gpu/drm/nouveau/nouveau_bo.c:570:6: error: too many arguments to function 'ttm_bo_move_accel_cleanup'


I am blocked..

Alin
Comment 8 Alin M Elena 2013-02-21 11:23:13 UTC
I will mark is as duplicate of 59057 as it seems to have more comments

*** This bug has been marked as a duplicate of bug 59057 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.