Bug 58729 - [bisected] Display fails to turn on after suspend/resume (NV86)
Summary: [bisected] Display fails to turn on after suspend/resume (NV86)
Status: RESOLVED DUPLICATE of bug 59057
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/nouveau (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Nouveau Project
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-24 21:25 UTC by J Binder
Modified: 2013-01-19 22:58 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg for boot and one suspen/resume cycle (68.08 KB, text/plain)
2012-12-24 21:25 UTC, J Binder
Details
fix (4.32 KB, patch)
2013-01-03 19:01 UTC, Marcin Slusarz
Details | Splinter Review
dmesg for boot and one suspend/resume cycle with 3.8.0-rc2 form today's git master (65.55 KB, text/plain)
2013-01-07 16:02 UTC, J Binder
Details
correct dmesg for boot and one suspend/resume cycle with 3.8.0-rc2 form today's git master (66.10 KB, text/plain)
2013-01-07 16:23 UTC, J Binder
Details
dmesg for boot and one suspend/resume cycle with 3.8.0-rc2 form today's git master with mask patch from bug 59057 (65.07 KB, text/plain)
2013-01-07 19:23 UTC, J Binder
Details

Note You need to log in before you can comment on or make changes to this bug.
Description J Binder 2012-12-24 21:25:16 UTC
Created attachment 72083 [details]
dmesg for boot and one suspen/resume cycle

Since 3.7-rc7 from the nouveau git, the screen of my laptop will not turn on after resuming from suspend to RAM.

I have bisected the problem to the commit

bb49f2c0dbff280c20830a1b303844fc604a611c is the first bad commit
commit bb49f2c0dbff280c20830a1b303844fc604a611c
Author: Ben Skeggs <bskeggs@redhat.com>
Date:   Fri Nov 9 12:09:48 2012 +1000

    drm/nv50/disp: move remaining interrupt handling into core
    
    Signed-off-by: Ben Skeggs <bskeggs@redhat.com>

In the current nouveau kernel git the problem still occurs, the bad commit is 14464b8cd643467cb97335eb75ea676260dd0ad8 and applies after 3.7.0.

Dmesg attached, the relevant error is probably:

[   66.285584] nouveau E[    PBUS][0000:01:00.0] MMIO write of 0x00000000 FAULT at 0x400724
[   66.285597] nouveau E[  PTHERM][0000:01:00.0] unhandled intr 0x000001e1
Comment 1 J Binder 2012-12-24 21:32:47 UTC
Versions of other components:

libdrm-nouveau: 2.4.33
mesa:           8.0.5
xserver-xorg:   1.12.4
xserver-xorg-video-nouveau: 1.0.1
Comment 2 Marcin Slusarz 2013-01-03 19:01:21 UTC
Created attachment 72473 [details] [review]
fix
Comment 3 J Binder 2013-01-07 16:02:50 UTC
Created attachment 72634 [details]
dmesg for boot and one suspend/resume cycle with 3.8.0-rc2 form today's git master

Suspicious error messages are now gone, display still does not turn on after resume on my machine.

What information would be helpful for further debugging?
Comment 4 J Binder 2013-01-07 16:23:59 UTC
Created attachment 72636 [details]
correct dmesg for boot and one suspend/resume cycle with 3.8.0-rc2 form today's git master

Attached incorrectly collected dmesg. Correct dmesg appended.
Comment 5 Marcin Slusarz 2013-01-07 17:06:20 UTC
You can try the patch from bug 59057, comment 15.
Comment 6 J Binder 2013-01-07 19:23:49 UTC
Created attachment 72647 [details]
dmesg for boot and one suspend/resume cycle with 3.8.0-rc2 form today's git master with mask patch from bug 59057

Patch from comment 15, bug 59057 does not make a difference.

Looking more closely, I probably have the same machine as Pontus Fuchs.
Comment 7 Marcin Slusarz 2013-01-07 21:38:23 UTC
Ok. Bug 59057 seems to have more informations, so let's close this one as duplicate.

*** This bug has been marked as a duplicate of bug 59057 ***
Comment 8 Florian Mickler 2013-01-19 22:58:29 UTC
A patch referencing this bug report has been merged in Linux v3.8-rc4:

commit c684cef795cb5356ae7f6a7ad613946eef14265f
Author: Marcin Slusarz <marcin.slusarz@gmail.com>
Date:   Thu Jan 3 19:38:45 2013 +0100

    drm/nv50/disp: fix selection of bios script for analog outputs


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.