Bug 58660 - CAYMAN broken with HyperZ on
CAYMAN broken with HyperZ on
Status: RESOLVED WORKSFORME
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600
unspecified
Other All
: medium normal
Assigned To: Default DRI bug account
:
Depends on:
Blocks: 75112
  Show dependency treegraph
 
Reported: 2012-12-22 20:28 UTC by Thomas Rohloff
Modified: 2014-09-01 21:05 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
BIOS 0 (locked shaders) (128.00 KB, application/octet-stream)
2012-12-23 00:22 UTC, Thomas Rohloff
Details
BIOS 1 (unlocked shaders) (128.00 KB, application/octet-stream)
2012-12-23 00:23 UTC, Thomas Rohloff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Rohloff 2012-12-22 20:28:12 UTC
I own a Sapphire Radeon HD 6950. This card has a dual-bios where one of them has unlocked shaders (Radeon HD 6970). This is not a modded BIOS, it's made by Sapphire and fully supported by them.
Now my problem is that with the Radeon HD 6950 BIOS (locked shaders) the GPU seems to hang as soon as compiz starts. With the unlocked BIOS it starts just fine.
Comment 1 Thomas Rohloff 2012-12-22 20:28:48 UTC
Forget to say: This is on newest mesa from git with kernel 3.8-rc1 (+ this patch: http://cgit.freedesktop.org/~agd5f/linux/commit/?h=drm-fixes-3.8&id=668bbc81baf0f34df832d8aca5c7d5e19a493c68 )
Comment 2 Alex Deucher 2012-12-22 23:49:21 UTC
Please attach the dmesg output when booting with both video bioses.  Also, please attach both video bioses.  To dump the video bios:
(as root)
(use lspci to get the bus id)
cd /sys/bus/pci/devices/<pci bus id>
echo 1 > rom
cat rom > /tmp/vbios.rom
echo 0 > rom
Comment 3 Thomas Rohloff 2012-12-23 00:21:59 UTC
The thing is that I can't access dmesg after the crash. Not even SysMagRQ works.

See my dmesg with the other BIOS here: https://bugs.freedesktop.org/attachment.cgi?id=72006

I have the BIOSes still lying around somewhere. Let me search real quick.
Comment 4 Thomas Rohloff 2012-12-23 00:22:46 UTC
Created attachment 72008 [details]
BIOS 0 (locked shaders)
Comment 5 Thomas Rohloff 2012-12-23 00:23:12 UTC
Created attachment 72009 [details]
BIOS 1 (unlocked shaders)
Comment 6 Thomas Rohloff 2012-12-23 19:24:08 UTC
Whoever changed the report title: It is broken on the locked BIOS, not on the unlocked.
Comment 7 Thomas Rohloff 2012-12-23 21:44:35 UTC
Bisected mesa.

This is a mesa bug caused by http://cgit.freedesktop.org/mesa/mesa/commit/?id=6532eb17baff6e61b427f29e076883f8941ae664

Can anybody move this to the right place or do I have to re-create the report (and if so: Where) ?

I also think this is a duplication of https://bugs.freedesktop.org/show_bug.cgi?id=58667 - The crashes just occur way more often (right after starting compiz) with the locked BIOS.
Comment 8 Marek Olšák 2014-08-24 13:38:25 UTC
Is this still an issue with current Mesa git?
Comment 9 Marek Olšák 2014-09-01 21:05:05 UTC
I'm closing this 2-years-old bug.

The report says that a patch which adds HTILE support causes a crash when compiz starts, but compiz doesn't even use a zbuffer, so we are not really using Hyper-Z here. I believe this is just a bug caused by incorrect register programming in the initial HTILE patch and must have been fixed since then.

Feel free to reopen if you see this crash with current Mesa git.