Bug 75112 - Meta Bug for HyperZ issues on r600g and radeonsi
Summary: Meta Bug for HyperZ issues on r600g and radeonsi
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: All All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on: 58660 64471 66352 68799 72685 73088 73785 74428 74784 74803 74863 74892 83205 83418
Blocks: 75011
  Show dependency treegraph
 
Reported: 2014-02-17 18:52 UTC by Andreas Boll
Modified: 2019-09-18 19:15 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
gpulockup rhd3200 (72.39 KB, text/plain)
2014-02-27 14:26 UTC, commiethebeastie
Details
xorg rhd3200 (1.77 KB, text/plain)
2014-02-27 14:26 UTC, commiethebeastie
Details
lspci rhd3200 (2.88 KB, text/plain)
2014-02-27 14:27 UTC, commiethebeastie
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Boll 2014-02-17 18:52:08 UTC
This bug is for tracking all the outstanding HyperZ issues on r600g and radeonsi.
Comment 1 funkydude 2014-02-22 15:40:19 UTC
Is there some form of attack plan for fixing these issues?
Comment 2 commiethebeastie 2014-02-23 13:31:17 UTC
How to set R600_HYPERZ=1 by default in Unity 7?
Comment 3 Marek Olšák 2014-02-23 14:03:50 UTC
The variable is called R600_DEBUG. Type: "R600_DEBUG=help glxgears"
Comment 4 Alex Deucher 2014-02-24 14:40:02 UTC
(In reply to comment #1)
> Is there some form of attack plan for fixing these issues?

We need to figure out what combination(s) of GL state cause a problem with hyperZ, then either disable hyperZ in those cases, or adjust the hyperZ-specific state to avoid the hang in those specific cases.  Ideally we'd be able to find a small test case where we can reproduce the issue(s).
Comment 5 funkydude 2014-02-24 16:01:34 UTC
Is that something us users can help with? :p
Comment 6 commiethebeastie 2014-02-27 09:12:59 UTC
No any regressions with R600_DEBUG=hyperz on Asus DirectCU RHD6850.

Tested on Serious Sam III, Unigine, Portal 2, Compiz, Lightsmark 2008, Europe Universalis IV, Fallout New Vegas :) 

Are you need in more info?
Comment 7 commiethebeastie 2014-02-27 09:17:35 UTC
echo $R600_DEBUG
hyperz
Comment 8 Grigori Goronzy 2014-02-27 12:20:58 UTC
Please check the bugs this one depends on. There are various well known applications and games that have problems (GPU hangs and/or image corruption) with HyperZ enabled. The geometry shader refactoring also introduced a regression.
Comment 9 commiethebeastie 2014-02-27 14:26:29 UTC
Created attachment 94823 [details]
gpulockup rhd3200
Comment 10 commiethebeastie 2014-02-27 14:26:51 UTC
Created attachment 94824 [details]
xorg rhd3200
Comment 11 commiethebeastie 2014-02-27 14:27:06 UTC
Created attachment 94825 [details]
lspci rhd3200
Comment 12 commiethebeastie 2014-02-27 14:28:20 UTC
lockup with rhd3200 in Lightsmark 2008.

[ 1506.221260] radeon 0000:01:05.0: GPU lockup CP stall for more than 10000msec
[ 1506.221275] radeon 0000:01:05.0: GPU lockup (waiting for 0x0000000000011a82 last fence id 0x0000000000011a71 on ring 0)
[ 1506.221283] [drm:r600_ib_test] *ERROR* radeon: fence wait failed (-35).
[ 1506.221293] [drm:radeon_ib_ring_tests] *ERROR* radeon: failed testing IB on GFX ring (-35).
[ 1506.221299] radeon 0000:01:05.0: ib ring test failed (-35).
[ 1506.221305] [drm] Disabling audio 0 support
[ 1506.222343] radeon 0000:01:05.0: GPU softreset: 0x00000009
[ 1506.222349] radeon 0000:01:05.0:   R_008010_GRBM_STATUS      = 0xE6733030
[ 1506.222355] radeon 0000:01:05.0:   R_008014_GRBM_STATUS2     = 0x00110103
[ 1506.222360] radeon 0000:01:05.0:   R_000E50_SRBM_STATUS      = 0x20000040
[ 1506.222365] radeon 0000:01:05.0:   R_008674_CP_STALLED_STAT1 = 0x00000000
[ 1506.222371] radeon 0000:01:05.0:   R_008678_CP_STALLED_STAT2 = 0x00008002
[ 1506.222376] radeon 0000:01:05.0:   R_00867C_CP_BUSY_STAT     = 0x00008086
[ 1506.222382] radeon 0000:01:05.0:   R_008680_CP_STAT          = 0x80018645
[ 1506.222387] radeon 0000:01:05.0:   R_00D034_DMA_STATUS_REG   = 0x44C83D57
[ 1506.272140] radeon 0000:01:05.0: R_008020_GRBM_SOFT_RESET=0x00007FEF
[ 1506.272196] radeon 0000:01:05.0: SRBM_SOFT_RESET=0x00000100
[ 1506.274289] radeon 0000:01:05.0:   R_008010_GRBM_STATUS      = 0xA0003030
[ 1506.274295] radeon 0000:01:05.0:   R_008014_GRBM_STATUS2     = 0x00000003
[ 1506.274300] radeon 0000:01:05.0:   R_000E50_SRBM_STATUS      = 0x20008040
[ 1506.274305] radeon 0000:01:05.0:   R_008674_CP_STALLED_STAT1 = 0x00000000
[ 1506.274311] radeon 0000:01:05.0:   R_008678_CP_STALLED_STAT2 = 0x00000000
[ 1506.274316] radeon 0000:01:05.0:   R_00867C_CP_BUSY_STAT     = 0x00000000
[ 1506.274321] radeon 0000:01:05.0:   R_008680_CP_STAT          = 0x80100000
[ 1506.274326] radeon 0000:01:05.0:   R_00D034_DMA_STATUS_REG   = 0x44C83D57
[ 1506.274333] radeon 0000:01:05.0: GPU reset succeeded, trying to resume
Comment 13 commiethebeastie 2014-02-27 16:38:59 UTC
Also it hangs without hyperz :( (rhd3200)
Comment 14 funkydude 2014-02-27 17:12:32 UTC
I honestly don't know why you thought spamming this ticket (and the people CC'd to it) was a good idea with something that has nothing to do with the issue. Maybe someone can purge it?

Please make a separate ticket for issues.
Comment 15 Marek Olšák 2014-02-27 23:12:32 UTC
Please file separate bug reports for your issues. This is only a meta bug aggregating all HyperZ bugs.
Comment 16 David Heidelberg (okias) 2014-05-09 21:15:00 UTC
Could be done some kind of white-list?

For example it seems work very well on 6550D APU and without HyperZ performance really suffer even for old games. There is not much reasons to not enable it here. I browsed bug reports and non of them is APU related, so maybe give a shot for these?

I did test on 3.12.18 kernel, with DPM on, GL_VERSION: 3.0 Mesa 10.3.0-devel (git-23e9f06). Tested SW: KWin with composite, Counter Strike 1.6 (improved performance), 0AD (also improved speed), glmark2 2014.03 (515 points -> 717).

Thank you
Comment 17 Michel Dänzer 2014-05-12 03:28:54 UTC
(In reply to comment #16)
> I browsed bug reports and non of them is APU related, so maybe give a shot for
> these?

Did you test the games referenced in those bug reports?
Comment 18 David Heidelberg (okias) 2014-05-17 14:13:07 UTC
At this moment only Unigine Sanctuary (it work as expected), now downloading Unigine Heaven.

Some of games I'm not able to test, but I tested piglit quick set and no regression showed up.
Comment 19 David Heidelberg (okias) 2014-10-12 08:17:48 UTC
After Marek fixed some HyperZ issues, older issues are FIXED or waiting to confirm. As usual, I tested it and didn't noticed any problems.

Is there possibility enable HyperZ soon as possible, to be able get enough feedback until 10.4 release?
Comment 20 Andreas Boll 2014-10-24 07:34:25 UTC
Hyper-Z has been re-enabled by default with

commit 14bdcc6ff98664552216acfdb7e35d0b128003ef
Author: Andreas Boll <andreas.boll.dev@gmail.com>
Date:   Thu Oct 23 14:52:55 2014 +0200

    radeon: enable Hyper-Z on r600g and radeonsi by default
    
    This reverts commit 01e637114914453451becc0dc8afe60faff48d84.
    Since then many Hyper-Z issues have been fixed or worked around.
    
    Enable Hyper-Z by default so that we get enough feedback for the upcoming
    mesa 10.4 release.
    
    If you have issues with Hyper-Z try to disable Hyper-Z using the enviroment
    variable R600_DEBUG=nohyperz and please report the issue on the bugtracker.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=75011
    See also: https://bugs.freedesktop.org/show_bug.cgi?id=75112
    
    Signed-off-by: Andreas Boll <andreas.boll.dev@gmail.com>
    Reviewed-by: Marek Olšák <marek.olsak@amd.com>


Please help testing.
Comment 21 GitLab Migration User 2019-09-18 19:15:20 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/496.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.