Bug 59991 - Text Boxes Replaced with Black Boxes using pdftoppm
Summary: Text Boxes Replaced with Black Boxes using pdftoppm
Status: RESOLVED FIXED
Alias: None
Product: poppler
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
: 94052 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-28 21:50 UTC by Cory
Modified: 2016-02-10 15:46 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
introduce the option thinlinemode for pdftoppm (2.98 KB, patch)
2013-08-13 08:49 UTC, Thomas Freitag
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Cory 2013-01-28 21:50:34 UTC

    
Comment 1 Cory 2013-01-28 21:57:46 UTC
Poppler version 0.22.0. 
Mac OS X and Ubuntu. 

There are some text boxes in the document, which when run through pdftoppm get turned into solid black boxes. Not all of the text boxes do this, only some of them. 

Unfortunately, our documents are too sensitive to put on a public forum. 
I can send it to a developer in an e-mail, however. 

Thank you so much for your help.
Comment 2 Albert Astals Cid 2013-01-28 22:50:01 UTC
I'm interested in the file
Comment 3 Albert Astals Cid 2013-08-08 20:23:21 UTC
Ok, so it's one of the files that improves with the Thin line mode support Thomas did.

Thomas are you reading this? I guess I convinced you not to add support for that to pdftoppm, but unless we can make the perfect choice all the time i guess we'll have to add that option.

Comments?
Comment 4 Thomas Freitag 2013-08-09 07:19:16 UTC
No problem, Albert. It's quite easy to add an option to pdftoppm. Any suggestions for the name of such an option? -thinlinemode is too long in my opinion, but I don't have any other good idea.
Comment 5 Albert Astals Cid 2013-08-12 19:11:01 UTC
-thinlinemode works i guess
Comment 6 Thomas Freitag 2013-08-13 08:49:01 UTC
Created attachment 83999 [details] [review]
introduce the option thinlinemode for pdftoppm
Comment 7 Albert Astals Cid 2013-08-13 17:41:31 UTC
Patch commited.

Cory, unfortunately your pdf file is one of those that "we can't decided how to render right", since there's basically various ways to render a 1pixel line when zoomed out a lot, so we have this thin line mode thing that let's the user choose between various ways to render it. It is unfortunate we can't do that automagically, but that's how it is.
Comment 8 Cory 2013-08-13 21:05:04 UTC
Hi Guys, I definitely understand. I'll play around with the options and hopefully find something that works for me, or at least a best practice when issues come up. Thanks!
Comment 9 Thomas Freitag 2016-02-10 15:46:57 UTC
*** Bug 94052 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.