Bug 94052 - pdftoppm rendering inset image as black box
Summary: pdftoppm rendering inset image as black box
Status: RESOLVED DUPLICATE of bug 59991
Alias: None
Product: poppler
Classification: Unclassified
Component: utils (show other bugs)
Version: unspecified
Hardware: All All
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-08 22:18 UTC by Micah Chambers
Modified: 2016-02-17 09:54 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Short documentation about thinlinemodes (76.76 KB, application/pdf)
2016-02-17 09:54 UTC, Thomas Freitag
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Micah Chambers 2016-02-08 22:18:38 UTC
When I use pdftoppm on a slightly transparent grey region the output comes out completely black. It is customer data so I can't post it online, but I can email you directly (email me at micah@plangrid.com) if you are looking at the bug. It seems like it may be related to https://bugs.freedesktop.org/show_bug.cgi?id=91415, although that is in pdftocairo.

The problem appears in older versions on Ubuntu and is still there in version 0.4, from archlinux.
Comment 1 Thomas Freitag 2016-02-10 15:46:07 UTC
It is once again the problem of a lot of CAD programs, s. also bug 59991:
The "slightly transparent grey region" is created with a grid of over 2400(!!!) thin lines with color black.
If You call pdftoppm with -thinlinemode shape or render it with a higher resolution, i.e. -r 300 or better -r 600, You will see that the problem is gone!
Comment 2 Thomas Freitag 2016-02-10 15:46:57 UTC

*** This bug has been marked as a duplicate of bug 59991 ***
Comment 3 Micah Chambers 2016-02-16 17:22:11 UTC
Awesome. Thanks for the help Thomas. We'll start using using `-thinlinemode shape`. What are the drawbacks to using `-thinlinemode shape` for other parts of the PDF? I'm assuming some lines that at normal scale would normally look black would be aliased and made super lighty?
Comment 4 Thomas Freitag 2016-02-17 09:54:28 UTC
Created attachment 121801 [details]
Short documentation about thinlinemodes

No, Micah. Thin lines should never vanish, at least not when Your render it with at least 72 dpi. I attach the short documentation I wrote when I implemented the thinlinemode's. Or better, look at "PDF with thin grid lines" from bug 37347, and try that PDF with and without thinlinemode option and different resolutions. That PDF was the motivation for my implementation.

That the grey background disappears in the PDF of this bug when You use "-thinlinemode shape" is a bug in the implementation: it doesn't distinguish in this case if it is a stroke or a fill operation, so even in case of a fill operation it draws the line with a shape corresponding to the line width set by the document. But the document doesn't set the line width, so it's 0 and therefore the line is drawn white.
The patch for bug 94152 repairs that.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.