Bug 6072 - r300 + stepmania == crash
r300 + stepmania == crash
Product: Mesa
Classification: Unclassified
Component: Mesa core
x86 (IA32) Linux (All)
: high normal
Assigned To: Default DRI bug account
: 6086 (view as bug list)
Depends on:
  Show dependency treegraph
Reported: 2006-03-01 08:22 UTC by Andrew Fuller
Modified: 2009-08-24 12:23 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Fuller 2006-03-01 08:22:49 UTC
I'm not exactly sure where the problem lies, so if this does not appear to be 
the r300 driver, please correct me and I'll file a bug where it belongs.  
I've been running stepmania for a while now with ATI's fglrx drivers, but am 
trying to get away from that.  So I've got Xorg 7.0, Mesa 6.4.2, and DRM from 
CVS (a day or so ago) as instructed on the Gentoo forums.  Unfortunately before 
getting to the main menu, when using r300, it crashes with an assert in Mesa.  
main/texenvprogram.c:622 Assertion failure: get_source: !is_undef(p->s 
I'm hoping that this is just caused by a missing (texture?) function in the 
r300 driver, and perhaps I can hope to see it fixed in the not-too-distant 
future.  If it's something else, then it's a good thing stepmania is FOSS and I 
can debug it further if someone can indicate what I'd be looking for. 
System: Gentoo amd64, 2.6.15-ck3 preempt kernel.
Comment 1 Aapo Tahkola 2006-03-02 11:41:13 UTC
*** Bug 6086 has been marked as a duplicate of this bug. ***
Comment 2 Andrew Fuller 2006-03-06 08:18:14 UTC
I tried upgrading to Mesa CVS, but it didn't help this bug.  On #dri-devel I   
was told to reassign this to Mesa.  So I've reassigned it.  If any other  
information would be helpful, please tell me what and I'll post it here.  
Comment 3 Aapo Tahkola 2006-03-28 20:28:21 UTC
Fixed. Happy gaming.
Comment 4 ajax at nwnk dot net 2009-08-24 12:23:43 UTC
Mass version move, cvs -> git