Bug 61199 - mapi/glapi/glprocs.h:2573:5: error: ‘glDiscardFramebufferEXT’ undeclared here (not in a function)
Summary: mapi/glapi/glprocs.h:2573:5: error: ‘glDiscardFramebufferEXT’ undeclared here...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium blocker
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords: regression
: 61282 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-21 02:34 UTC by Vinson Lee
Modified: 2013-02-23 02:28 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
fix to the build (1.24 KB, patch)
2013-02-21 07:53 UTC, Tapani Pälli
Details | Splinter Review
fix without typos included (1.24 KB, patch)
2013-02-21 07:57 UTC, Tapani Pälli
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2013-02-21 02:34:58 UTC
mesa: 54d9c8a04a3d79da9a73f4b30d1c30874e05dc58 (master)

$ scons
[...]
  Compiling src/mapi/glapi/glapi_getproc.c ...
In file included from src/mapi/glapi/glapi_getproc.c:48:0:
build/linux-x86_64-debug/mapi/glapi/glprocs.h:2573:5: error: ‘glDiscardFramebufferEXT’ undeclared here (not in a function)
scons: *** [build/linux-x86_64-debug/mapi/glapi/glapi_getproc.os] Error 1

413941e1a3155b29a190ab7ecfd844b1a5c2e460 is the first bad commit
commit 413941e1a3155b29a190ab7ecfd844b1a5c2e460
Author: Tapani Pälli <tapani.palli@intel.com>
Date:   Mon Feb 18 09:12:27 2013 +0200

    gles2: a stub implementation for GL_EXT_discard_framebuffer

    This patch implements a stub for GL_EXT_discard_framebuffer with
    required checks listed by the extension specification. This extension
    is required by GLBenchmark 2.5 when compiled with OpenGL ES 2.0
    as the rendering backend.

    Signed-off-by: Tapani Pälli <tapani.palli@intel.com>
    Reviewed-by: Brian Paul <brianp@vmware.com>
    Reviewed-and-tested-by: Chad Versace <chad.versace@linux.intel.com>

:040000 040000 64d7ddf0d1ed196500fc5e66a2bd7f5b4c28867a 6d191998124450cc5cd16aac8c767d254dc74688 M      src
bisect run success
Comment 1 Tapani Pälli 2013-02-21 06:24:38 UTC
Sorry for the regression, I don't know much about scons but I'm able to reproduce the error and will try to fix this.
Comment 2 Tapani Pälli 2013-02-21 07:53:18 UTC
Created attachment 75232 [details] [review]
fix to the build
Comment 3 Tapani Pälli 2013-02-21 07:57:43 UTC
Created attachment 75234 [details] [review]
fix without typos included
Comment 4 Vinson Lee 2013-02-22 01:33:16 UTC
Comment on attachment 75234 [details] [review]
fix without typos included

Review of attachment 75234 [details] [review]:
-----------------------------------------------------------------

Tested-by: Vinson Lee <vlee@freedesktop.org>
Comment 5 Tapani Pälli 2013-02-22 20:29:11 UTC
*** Bug 61282 has been marked as a duplicate of this bug. ***
Comment 6 Brad King 2013-02-22 21:21:52 UTC
Comment on attachment 75234 [details] [review]
fix without typos included

Review of attachment 75234 [details] [review]:
-----------------------------------------------------------------

Tested-by: Brad King <brad.king@kitware.com>
Comment 7 Tapani Pälli 2013-02-23 02:25:21 UTC
someone please commit the fix
Comment 8 Vinson Lee 2013-02-23 02:28:43 UTC
Fixed with commit b4dba5bba2146d8dd06e6e62b5fb2485123b8586.

commit b4dba5bba2146d8dd06e6e62b5fb2485123b8586
Author: Tapani Pälli <tapani.palli@intel.com>
Date:   Thu Feb 21 09:51:40 2013 +0200

    glapi: mark static_dispatch false for DiscardFramebufferEXT
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=61199
    Signed-off-by: Tapani Pälli <tapani.palli@intel.com>
    Tested-by: Vinson Lee <vlee@freedesktop.org>
    Tested-by: Brad King <brad.king@kitware.com>
    Signed-off-by: Vinson Lee <vlee@freedesktop.org>


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.