Bug 61282 - build failure since 413941e1, glDiscardFramebufferEXT undeclared
Summary: build failure since 413941e1, glDiscardFramebufferEXT undeclared
Status: RESOLVED DUPLICATE of bug 61199
Alias: None
Product: Mesa
Classification: Unclassified
Component: Other (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Tapani Pälli
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-22 14:16 UTC by Brad King
Modified: 2013-02-22 20:29 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brad King 2013-02-22 14:16:39 UTC
Since commit 413941e1 (gles2: a stub implementation for GL_EXT_discard_framebuffer, 2013-02-18) Mesa fails to build as follows:

$ ./autogen.sh --disable-dri \
               --disable-egl \
               --disable-shared-glapi \
               --enable-xlib-glx \
               --enable-osmesa \
               --without-gallium-drivers
$ make
...
Making all in mapi/glapi
make[2]: Entering directory `.../src/mapi/glapi'
  CC     glapi_getproc.lo
In file included from glapi_getproc.c:48:0:
../../../src/mapi/glapi/glprocs.h:2573:5: error: 'glDiscardFramebufferEXT' undeclared here (not in a function)
Comment 1 Jon Turney 2013-02-22 20:10:55 UTC
also seen in x.org tinderbox 
http://tinderbox.freedesktop.org/builds/2013-02-21-0010/logs/libGL/#build
Comment 2 Tapani Pälli 2013-02-22 20:29:11 UTC

*** This bug has been marked as a duplicate of bug 61199 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.