Bug 6212 - nv driver broken for 6800GS
nv driver broken for 6800GS
Status: RESOLVED WONTFIX
Product: xorg
Classification: Unclassified
Component: Driver/nVidia (open)
7.0.0
x86 (IA32) Linux (All)
: high normal
Assigned To: Aaron Plattner
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-10 17:52 UTC by alex
Modified: 2011-09-14 12:49 UTC (History)
4 users (show)

See Also:


Attachments
lspci -v output (7.44 KB, text/plain)
2006-03-10 17:54 UTC, alex
no flags Details
DVI output (91.02 KB, image/jpeg)
2006-06-22 12:45 UTC, Marek Kassur
no flags Details
D-SUB output (100.38 KB, image/jpeg)
2006-06-22 12:47 UTC, Marek Kassur
no flags Details
Xorg.log from working Ubuntu 6.06 LTS (43.16 KB, text/plain)
2006-09-17 15:51 UTC, Marek Kassur
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description alex 2006-03-10 17:52:31 UTC
System details:

  CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
  Motherboard: Abit AN8 SLI (nForce4 chipset)
  RAM: 1GB PC3200 dual-channel
  Video Card: PNY Verto GeForce 6800 GS (PCI Express 16X) 256MB
  Video BIOS version: 05.41.02.48.03
  OS: Fedora Core 5, x86_64 version (with latest updates)

I recently installed Fedora Core 5 on my nifty new system and discovered to my
dismay that it appears that the open source nv driver does not work properly
with my new GeForce 6800GS video card.  When I attempt to load X using this
driver, I get a screen full of vertical bars and some flashing blocks instead of
a working X display (and if I then shut down the X server or switch to another
virtual console, it apparently doesn't set the text mode back quite right either
because scrolling doesn't work and I have no cursor).

The vesa driver works fine for this card, but obviously is not ideal.  The
proprietary binary Nvidia driver (with patches to build under FC5) also appears
to work nicely, only the open source nv driver does not.  I did notice, however,
that if I started the X server with the proprietary driver, then shut it down,
and then started it up using the nv driver, it would then work, so this suggests
there is simply something missing in the initialization done by the nv driver.

There are no error messages displayed when running with the nv driver (the
output from the X server looks basically identical regardless of whether I'm
using the nv, nvidia, or vesa drivers), and it appears to start up normally
aside from displaying garbage all over the screen.
Comment 1 alex 2006-03-10 17:54:05 UTC
Created attachment 4886 [details]
lspci -v output
Comment 2 Rich Webb 2006-03-26 09:46:43 UTC
Same problem here, running the released Fedora Core 5 kernel (2.6.15-1.2054_FC5)
using an NVidia 6600GT/AGP vid card. The vesa driver works (well enough to
startx) but the nv driver produces just the screen full of colored vertical
bars. As well, no apparent errors in the Xorg.0.log file and a broken display
after Ctl-Alt-BS to a text screen.
Comment 3 Marek Kassur 2006-04-07 07:43:20 UTC
Same here, and my friend's 6600 (also Gigabyte)

01:00.0 VGA compatible controller: nVidia Corporation NV40 [GeForce 6800] (rev
a1) (prog-if 00 [VGA])
        Subsystem: Giga-byte Technology: Unknown device 310f
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 248 (1250ns min, 250ns max)
        Interrupt: pin A routed to IRQ 20
        Region 0: Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
        Region 1: Memory at e8000000 (32-bit, prefetchable) [size=128M]
        Region 2: Memory at f9000000 (32-bit, non-prefetchable) [size=16M]
        Expansion ROM at fbee0000 [disabled] [size=128K]
        Capabilities: [60] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [44] AGP version 3.0
                Status: RQ=256 Iso- ArqSz=0 Cal=3 SBA+ ITACoh- GART64- HTrans-
64bit- FW+ AGP3+ Rate=x4,x8
                Command: RQ=32 ArqSz=2 Cal=0 SBA+ AGP+ GART64- 64bit- FW+ Rate=x8
Comment 4 Aaron Plattner 2006-04-13 17:59:23 UTC
Which version of the nv driver were you using?  Please try the
xf86-video-nv-1.0.2.0 release if you haven't already.
Comment 5 R. Steven Rainwater 2006-04-24 01:14:49 UTC
I'm experiencing problems with the nv driver too. I'm running xorg 7.0 (fedora
Core 5) on my Dell Inspiron 8600 laptop with Nvidia GeForce FX Go5200. It worked
great on previous versions of Fedora/X. The problems always occur during the
initialization sequence as the X desktop loads. See bug 6455 for more details.
I'm using the latest nv driver available from the Fedora folks:
 Module nv: vendor="X.Org Foundation"
 compiled for 7.0.0, module version = 1.0.1
 ABI class: X.Org Video Driver, version 0.8
Comment 6 Marek Kassur 2006-04-30 09:38:18 UTC
I'm not sure how to compile xf86-video-nv-1.0.2.0 on my enviroment, still using
Xorg 6.8.2 on a FC4 here. BTW, this problem seems to be rather common I've seen
repeatedly mention of it on mailing lists and forums.
Comment 7 Marek Kassur 2006-06-22 12:44:37 UTC
Just tested xorg-x11-drv-nv-1.1.1-5 from FC6 Test1, still broken.
Comment 8 Marek Kassur 2006-06-22 12:45:45 UTC
Created attachment 6020 [details]
DVI output
Comment 9 Marek Kassur 2006-06-22 12:47:03 UTC
Created attachment 6021 [details]
D-SUB output
Comment 10 Marek Kassur 2006-08-09 08:45:48 UTC
xorg-x11-drv-nv-1.2.0-3.fc6 (i386) from FC6 test 2 is unusable for me just like
earlier versions. It's time to get used to closed source propertiary NVIDIA driver.
Comment 11 R. Steven Rainwater 2006-08-09 09:23:19 UTC
xorg-x11-drv-nv-1.2.0-3.fc5 (i386) is still broken for me on Fedora Core 5 as
well. Same symptoms, it crashes on startup 3 out 4 times. If it manages to fully
initialize with crashing, however, it works pretty well until shutdown at which
time my laptop display explodes into a burst of scrambled colors resembling a
1970s TV set with bad horizontal and vertical sync.  Maybe the free nouveau
driver will be able to serve as a replacement for nv and finally provide 3D
acceleration on nvidia cards as well? http://nouveau.freedesktop.org/wiki/
Comment 12 Marek Kassur 2006-09-17 15:48:13 UTC
In the meantime I've tested FC6 Test3 with identical results (screen full of
trash). I've decided to give Ubuntu a try and surprisely, it works !!!

What should be done from here, reassign bug ?
It seems to be specific to some distributions, Fedora in my case.
Comment 13 Marek Kassur 2006-09-17 15:51:40 UTC
Created attachment 7032 [details]
Xorg.log from working Ubuntu 6.06 LTS
Comment 14 Daniel Stone 2007-02-27 01:30:49 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 15 Brice Goglin 2007-08-10 10:42:43 UTC
This bug is still present in driver 2.0.2 according to Andrew Vaughan
  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=400189

01:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600 GS] (rev a2) (prog-if 00 [VGA])

He's seeing vertical lines with various colors or so, look at the above URL For detail, everything is explained there for both 1.2.0 and 2.0.2.

nVidia binary works fine. Starting nVidia before switching to nv works fine. So, as explained above, something seems to be missing in the nv init.
Comment 16 Aaron Plattner 2007-08-11 18:19:21 UTC
Please try the most recent driver (currently 2.1.2).
Comment 17 R. Steven Rainwater 2007-08-12 07:21:21 UTC
I haven't experienced this bug since upgrading to Fedora 7
Comment 18 Andrew Vaughan 2007-08-14 17:17:42 UTC
I had a quick try with 2.1.2.  Still not working.  Symptoms appear to be the same.
Andrew V.
Comment 19 Benjamin Close 2008-01-11 02:35:52 UTC
Bugzilla Upgrade Mass Bug Change

NEEDSINFO state was removed in Bugzilla 3.x, reopening any bugs previously listed as NEEDSINFO.

  - benjsc
    fd.o Wrangler
Comment 20 Corbin Simpson 2011-09-14 12:49:30 UTC
xf86-video-nv has been officially unmaintained for a bit now, and we are closing all -nv bugs. If your problem was not addressed, and -nv is still broken, please try xf86-video-nouveau. Thank you.