Bug 62644 - Enhancement on tests/enroll.c, add support to enroll all fingers, other than hard-coded right-index-finger
Summary: Enhancement on tests/enroll.c, add support to enroll all fingers, other than ...
Status: RESOLVED FIXED
Alias: None
Product: libfprint
Classification: Unclassified
Component: fprintd (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium enhancement
Assignee: libfprint-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
: 66199 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-03-22 14:59 UTC by Brock.Zheng
Modified: 2013-06-26 11:12 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
created by `git format-patch V_0_5_0` (8.14 KB, text/plain)
2013-03-22 14:59 UTC, Brock.Zheng
Details
created by `git format-patch V0_5_0`, tar.bz2 format (8.14 KB, application/octet-stream)
2013-03-22 15:02 UTC, Brock.Zheng
Details
0001-tests-support-f-finger-option-for-enroll.patch (3.11 KB, text/plain)
2013-05-07 17:23 UTC, Peter
Details
0001-tests-support-f-finger-option-for-enroll.patch (3.10 KB, patch)
2013-05-08 05:20 UTC, Peter
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Brock.Zheng 2013-03-22 14:59:19 UTC
Created attachment 76917 [details]
created by `git format-patch V_0_5_0`

(1) add -f command line option to fprintd-enroll, let it can enroll all the    fingers. obselete the hard-coded solution.

(2) update document occordingly

(3) remove data/fprintd.1, because that file is created by build process. It should not be maintained by git.
Comment 1 Brock.Zheng 2013-03-22 15:02:25 UTC
Created attachment 76918 [details]
created by `git format-patch V0_5_0`, tar.bz2 format
Comment 2 Bastien Nocera 2013-03-26 11:51:10 UTC
(In reply to comment #0)
> Created attachment 76917 [details]
> created by `git format-patch V_0_5_0`
> 
> (1) add -f command line option to fprintd-enroll, let it can enroll all the 
> fingers. obselete the hard-coded solution.
> 
> (2) update document occordingly
> 
> (3) remove data/fprintd.1, because that file is created by build process. It
> should not be maintained by git.

Could you please try to use git-bz to upload your patches?

I can't review your patch with the builtin tools if they're not separate and plain text.

It's a single script[1], and there's the documentation for it:
http://git.fishsoup.net/cgit/git-bz/tree/git-bz.txt

git bz attach https://bugs.freedesktop.org/show_bug.cgi?id=62644 V_0_5_0
should do the right thing.

[1]: http://git.fishsoup.net/cgit/git-bz/plain/git-bz
Comment 3 Brock.Zheng 2013-03-26 14:07:20 UTC
Sorry, git bz did not work fine on my machine, I need some time to learn howto use it.....
Comment 4 Peter 2013-05-07 17:23:56 UTC
Created attachment 78991 [details]
0001-tests-support-f-finger-option-for-enroll.patch

Hm, just created similar patch :) I should search before code.

Bastien, actually man page alredy documents that fprintd-enroll support -f option so I think this patch worth to apply this or similar patch in any case. Man page states:

       -f finger
               For fprintd-enroll, the finger to enroll. Possible values are:


Brock.Zheng as for your patches, you do not need to learn how to use git-bz. You can just checkout master and manually copy _final_ changes in files and provide one for one change. Proplem with current patchset is that it provides some changes, then fixes bugs in this changes then updates changes... developers need only final result. Thanks anyway for your work - I've noticed that I need to update data/fprintd.pod from there :)
Comment 5 Peter 2013-05-07 17:24:24 UTC
Please, review updated patch.
Comment 6 Peter 2013-05-08 05:20:35 UTC
Created attachment 79011 [details] [review]
0001-tests-support-f-finger-option-for-enroll.patch

I just realized that it's possible to make patch two strings shorter :)
Comment 7 Bastien Nocera 2013-06-26 10:58:33 UTC
*** Bug 66199 has been marked as a duplicate of this bug. ***
Comment 8 Bastien Nocera 2013-06-26 11:12:47 UTC
Pushed after fixing the indentation and simplify the username selection a bit more.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.