Bug 6349 - characters disappear on applications.
Summary: characters disappear on applications.
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nVidia (proprietary) (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Aaron Plattner
QA Contact:
URL:
Whiteboard:
Keywords:
: 6581 6791 7056 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-03-22 22:13 UTC by sangu
Modified: 2006-08-25 08:27 UTC (History)
7 users (show)

See Also:
i915 platform:
i915 features:


Attachments
nvidia-bug-repot.log in 8756 (93.46 KB, text/plain)
2006-04-08 04:31 UTC, sangu
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description sangu 2006-03-22 22:13:36 UTC
font rendering is strange in xorg-x11-1.0.99.1.
< http://xorg.freedesktop.org/snapshots/individual/xserver/ >

OS: Fedora Core 5 rawhide.
kernel : kernel-smp-2.6.16-1.2074_FC6
cpu : amd x2 3800+  dual core
vga : 6800 GS  PCIe

characters disappear on applications.

Fedora Bug : https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=186212

screenshot : https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=126458
/var/log/Xorg.0.log : https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=126459
/etc/X11/xorg.conf : https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=126460
Comment 1 Valdis Kletnieks 2006-03-23 19:47:06 UTC
I've confirmed this is a NVidia driver issue.  Using the Fedora Core 5
xorg-x11-server-Xorg-1.0.1-9.i386.rpm, things work fine.  However, once the
Fedora Rawhide xorg-x11-server-Xorg-1.0.99.1-1.i386.rpm is installed,
the open-source nv driver works, but the NVidia 8178 drivers have the issue.

I'm guessing some subtle API change is giving 8178 indigestion.

As another data point - the missing characters aren't lost entirely - quite
often, moving the cursor over them to force the widget to focus and redraw
causes the text to appear (although it may spontaneously re-poof out a few
seconds later).

(System is a Dell Latitude C840, Linus 2.6.16 kernel, FC5 Rawhide userspace,
GeForce 440 card).
Comment 2 sangu 2006-04-08 04:31:47 UTC
Created attachment 5228 [details]
nvidia-bug-repot.log in 8756

This problem still happens in nvidia-1.0-8756.
Comment 3 sangu 2006-04-08 04:33:40 UTC
And xorg-x11-server-Xorg version is 1.0.99.2-2.
Comment 4 sangu 2006-04-09 20:32:00 UTC
AA is off or using bitmap font and font with sbit, this problem happens.
Comment 5 Aaron Plattner 2006-04-10 17:52:56 UTC
You're right, the change to the glyph ABI is responsible for this breakage.  We
hope to support the new driver ABI (version 1.0) in a future release.
Comment 6 Aaron Plattner 2006-04-13 17:06:18 UTC
*** Bug 6581 has been marked as a duplicate of this bug. ***
Comment 7 Ioannis 2006-05-03 06:13:11 UTC
*** Bug 6791 has been marked as a duplicate of this bug. ***
Comment 8 Victor Trac 2006-06-01 00:54:16 UTC
*** Bug 7056 has been marked as a duplicate of this bug. ***
Comment 9 Aaron Plattner 2006-08-25 08:27:45 UTC
This should be fixed in the 1.0-8774 driver which was released yesterday.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.