Bug 63674 - [IVB]frozen at the first frame when run Unigine-heaven 4.0
[IVB]frozen at the first frame when run Unigine-heaven 4.0
Status: RESOLVED NOTOURBUG
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
unspecified
All Linux (All)
: medium major
Assigned To: Ian Romanick
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-18 08:50 UTC by libo
Modified: 2013-06-08 00:43 UTC (History)
2 users (show)

See Also:


Attachments
scrot (2.53 MB, image/png)
2013-04-18 08:50 UTC, libo
Details
heaven.log (7.70 KB, text/plain)
2013-05-10 06:43 UTC, meng
Details

Note You need to log in before you can comment on or make changes to this bug.
Description libo 2013-04-18 08:50:04 UTC
Created attachment 78172 [details]
scrot

System Environment:
--------------------------
 Platform: IVB
 Libdrm: (master)libdrm-2.4.43-8-ge5d8a9c1d6375feb74feb52f419a025f1abf94d1
 Xserver:(master)xorg-server-1.14.0-53-g6ca03b9161d33b1d2b55a3a1a913cf88deb2343f
 Xf86_video_intel:(master)2.21.6-16-gddd3cc4ed6ac9b69f178147b49628b7a7f3f3104
 Kernel:	(drm-intel-nightly) a925dd6966bbbb3bfb5395ad593792ec55bb3402

Bug detailed description:
-------------------------
Unigine-heaven 4.0 will "hang" at the beginning picture,which attached in this report.
However, the blue flag in this picture is floating.

Reproduce steps:
----------------------------
1. xinit&
2. export MESA_GL_VERSION_OVERRIDE=3.2
   export MESA_GLSL_VERSION_OVERRIDE=150
3  ../bin/heaven_x64 -video_app opengl -data_path ../ -sound_app null -engine_config ../data/heaven_4.0.cfg -system_script heaven/unigine.cpp -video_mode -1 -video_fullscreen 1 -extern_define PHORONIX -video_width 1920 -video_height 1680
Comment 1 libo 2013-04-19 00:27:47 UTC
add Mesa commit:(master)b3f1f665b0fef178ae193e6b111f14c9a5ad3b25
Comment 2 meng 2013-04-23 01:33:10 UTC
It seems that unigine-heaven 4.0 will be frozen at the first frame forever.

Ian, can you reproduce it ?
Comment 3 Kenneth Graunke 2013-04-29 05:37:49 UTC
Can you try this on nVidia or AMD?  Running it normally seems to work, but running it with -extern_define PHORONIX doesn't.  I'm wondering if it's broken in general or if it's really a driver problem.
Comment 4 meng 2013-05-10 06:39:32 UTC
(In reply to comment #3)

The problem also exists with NVIDIA (GTX 550 Ti) on IVB.
Comment 5 meng 2013-05-10 06:41:05 UTC
Retest it wiht Mesa, output:
-------------------------
Loading Mesa 9.2.0 implementation error: Failed to compile fragment shader: FS compile failed: no register to spill.
GLShader::compile(): can't link program
FS compile failed: no register to spill

Reproduce steps:
--------------------------------
 export MESA_GL_VERSION_OVERRIDE=3.2
 export MESA_GLSL_VERSION_OVERRIDE=150
 export LD_LIBRARY_PATH=bin/:$LD_LIBRARY_PATH
 export force_glsl_extensions_warn=true
  
vblank_mode=0  ./bin/heaven_x64 -video_app opengl -data_path ../ -sound_app null -engine_config ../data/heaven_4.0.cfg -system_script heaven/unigine.cpp -video_mode -1 -video_fullscreen 1 -extern_define PHORONIX -video_width 800-video_height 600
Comment 6 meng 2013-05-10 06:43:00 UTC
Created attachment 79074 [details]
heaven.log
Comment 7 Gordon Jin 2013-05-24 05:03:01 UTC
Ken/Ian, any idea?
Comment 8 Kenneth Graunke 2013-05-24 07:30:43 UTC
In certain quality settings, a few FS compiles fail.  That looks like a bug, but I haven't had time to look into it.  Setting shader_precompile=false tends to work around it in the meantime...

I don't know what to do about your freezing issue...it might be a window focus problem...
Comment 9 meng 2013-05-27 01:07:37 UTC
The game should be "X Error of failed request:  GLXBadFBConfig" on Mesa master branch: bug 64938.
Comment 10 Eric Anholt 2013-06-08 00:43:28 UTC
Given that the original reported problem (the app not doing a benchmark sequence with those CLI arguments) isn't related to the graphics driver, I'm closing the report.  The later separate bug about compile failure already has an associated bug report, and a fix is on the list.