Bug 64913 - [r600g] KSP 0.20 crashes when entering settings / starting new game.
[r600g] KSP 0.20 crashes when entering settings / starting new game.
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600
git
x86-64 (AMD64) Linux (All)
: medium normal
Assigned To: Default DRI bug account
:
: 65803 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 12:32 UTC by Knut Andre Tidemann
Modified: 2013-08-19 08:36 UTC (History)
2 users (show)

See Also:


Attachments
Backtrace of crash from gdb (3.33 KB, text/plain)
2013-05-23 12:32 UTC, Knut Andre Tidemann
Details
Way to big patch to "fix" this small problem (70.83 KB, text/plain)
2013-06-09 20:08 UTC, Krzysztof A. Sobiecki
Details
Less broken patch (70.84 KB, patch)
2013-06-09 20:48 UTC, Krzysztof A. Sobiecki
Details | Splinter Review
Nope (620 bytes, text/plain)
2013-06-09 21:37 UTC, Krzysztof A. Sobiecki
Details
Another Patch (70.58 KB, patch)
2013-06-11 21:44 UTC, Krzysztof A. Sobiecki
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Knut Andre Tidemann 2013-05-23 12:32:28 UTC
Created attachment 79702 [details]
Backtrace of crash from gdb

I tested Kerbal Space Program today (after the new 0.20 updated) and it crashes when entering 'Settings' or starting the actual game from the menu.

I've attached a backtrace, and the crash seems to be the same in both cases. Atleast the same function is involved.

I was running mesa from git. Last commit was: 7bfb4bea6562b2e69d0376f15224c3811da42167

Running kernel 3.8.8.

The last version of the game (0.19.1) works without problems.
Comment 1 Knut Andre Tidemann 2013-05-23 12:46:45 UTC
I can also add that I have a Radeon HD 5670.
Comment 3 Krzysztof A. Sobiecki 2013-06-09 20:08:29 UTC
Created attachment 80585 [details]
Way to big patch to "fix" this small problem

I was too lazy to fix all pipe_sampler_view_reference so in the meantime I introduced pipe_sampler_view_reference_old.
It's not a fix.

/**
 * Similar to pipe_sampler_view_reference() but always set the pointer to
 * NULL and pass in an explicit context.  Passing an explicit context is a
 * work-around for fixing a dangling context pointer problem when textures
 * are shared by multiple contexts.  XXX fix this someday.
 */
static INLINE void
pipe_sampler_view_release

It does the same thing and I think It might have a same problem.
Comment 4 Krzysztof A. Sobiecki 2013-06-09 20:48:43 UTC
Created attachment 80588 [details] [review]
Less broken patch
Comment 5 Krzysztof A. Sobiecki 2013-06-09 21:37:04 UTC
Created attachment 80590 [details]
Nope

Not tested yet.
Comment 6 Krzysztof A. Sobiecki 2013-06-11 21:44:53 UTC
Created attachment 80709 [details] [review]
Another Patch

Need more testing.
Comment 7 Alex Deucher 2013-06-16 19:50:03 UTC
*** Bug 65803 has been marked as a duplicate of this bug. ***
Comment 8 Corey Richardson 2013-06-16 21:45:13 UTC
Seems I didn't use the correct keywords when searching for duplicates. Anything I can do to help test? (I have HD6850)
Comment 9 Krzysztof A. Sobiecki 2013-06-17 01:14:20 UTC
Compile mesa, make it usable in a system, run piglit, apply the patch, compile mesa,run KSP to check out if it fixes the problem, run piglit again and report regressions. 
That should be good enough. I hope.
Comment 10 Knut Andre Tidemann 2013-06-17 09:15:44 UTC
I've tested the attached patch, and it fixes the crash in kerbal space program.

I've also run the piglit r600.tests before and after patching, but it seems the results are somewhat mixed. I ran piglit once before patching and a few times afterwards and the results differed each time I ran the tests. One time the test even zombied.
Comment 11 Krzysztof A. Sobiecki 2013-06-17 09:40:39 UTC
Does this behavior also occurred before patching?
Comment 12 Knut Andre Tidemann 2013-06-17 10:24:55 UTC
Yeah, I ran the piglit tests multiple times again without the patch applied, and the same result can be observed.
Comment 13 Krzysztof A. Sobiecki 2013-06-19 02:28:06 UTC
Is someone interested in this patch?
Comment 14 Alex Deucher 2013-06-19 17:12:04 UTC
I'd suggest sending it to the mailing list (mesa-dev@lists.freedesktop.org).
Comment 15 Alex Deucher 2013-06-19 17:13:28 UTC
Please use git to format the patch and include a description of what the patch does and how it fixes the issue.
Comment 16 Krzysztof A. Sobiecki 2013-07-17 12:33:06 UTC
I have done that and no one cared.
Comment 17 Alex Deucher 2013-07-17 13:11:41 UTC
(In reply to comment #16)
> I have done that and no one cared.

Are you sure it went through?  I don't don't see the patch in the archives: http://lists.freedesktop.org/archives/mesa-dev/
Comment 18 Krzysztof A. Sobiecki 2013-07-17 13:16:10 UTC
(In reply to comment #17)
> (In reply to comment #16)
> > I have done that and no one cared.
> 
> Are you sure it went through?  I don't don't see the patch in the archives:
> http://lists.freedesktop.org/archives/mesa-dev/
Here it is...
http://lists.freedesktop.org/archives/mesa-dev/2013-July/041799.html
Comment 19 Knut Andre Tidemann 2013-08-19 08:30:32 UTC
This issue seems to have gone away in the later git versions, without the requirement of the attached patch.
Comment 20 Krzysztof A. Sobiecki 2013-08-19 08:35:10 UTC
Then I will close the bug.
If there is still a problem please reopen it.