Bug 65803 - r600g: segfault with Kerbal Space Program
Summary: r600g: segfault with Kerbal Space Program
Status: RESOLVED DUPLICATE of bug 64913
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-15 21:27 UTC by Corey Richardson
Modified: 2013-06-16 19:50 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Corey Richardson 2013-06-15 21:27:23 UTC
Unfortunately the game is closed source and stripped, so I don't have more information, but the backtrace I get is: 

(gdb) where
#0  0x0000000000000000 in ?? ()
#1  0x00007ffff30052ae in pipe_sampler_view_reference (view=0x85d19b0, ptr=0x768b410) at ../../../../src/gallium/auxiliary/util/u_inlines.h:151
#2  r600_set_sampler_views (pipe=0x7689c90, shader=<optimized out>, count=<optimized out>, views=0x37395e0, start=<optimized out>) at r600_state_common.c:626
#3  0x00007ffff2e21a1b in update_textures (st=0x4b2dd80, shader_stage=1, prog=0x8562a20, max_units=16, sampler_views=0x4b2e710, num_textures=0x4b2e894) at ../../src/mesa/state_tracker/st_atom_texture.c:316
#4  0x00007ffff2e1d907 in st_validate_state (st=st@entry=0x4b2dd80) at ../../src/mesa/state_tracker/st_atom.c:221
#5  0x00007ffff2e2463a in st_Clear (ctx=0x411f8e0, mask=50) at ../../src/mesa/state_tracker/st_cb_clear.c:396
#6  0x00000000005759c1 in ?? ()
#7  0x000000000057dfa3 in ?? ()
#8  0x00000000005b4ead in ?? ()
#9  0x000000000087db9c in ?? ()
#10 0x0000000000b4d303 in ?? ()
#11 0x00007ffff62dea15 in __libc_start_main () from /usr/lib/libc.so.6
#12 0x0000000000456669 in ?? ()
#13 0x00007fffffffd438 in ?? ()
#14 0x00000000ffffffff in ?? ()
#15 0x0000000000000001 in ?? ()
#16 0x00007fffffffd832 in ?? ()
#17 0x0000000000000000 in ?? ()

I have a trace but it's very large (>500MB) and it doesn't reproduce the crash. I haven't seen anyone else report the crash. The crash happens on stable mesa too.

I can reliably reproduce by selecting the first two menu options in the game launch (Start Game and Settings). The previous versions of the game worked.
Comment 1 Alex Deucher 2013-06-16 19:50:03 UTC

*** This bug has been marked as a duplicate of bug 64913 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.