Bug 65254 - opengl flicker in xbmc / glxgears
Summary: opengl flicker in xbmc / glxgears
Status: RESOLVED DUPLICATE of bug 63997
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-02 02:48 UTC by Vladi
Modified: 2013-10-07 15:23 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg (24.79 KB, text/plain)
2013-06-02 18:37 UTC, Vladi
Details
xorg.log (43.88 KB, text/plain)
2013-06-02 18:40 UTC, Vladi
Details
glxinfo (53.07 KB, text/plain)
2013-06-03 18:51 UTC, Vladi
Details
xbmc log (5.18 KB, text/plain)
2013-06-06 02:33 UTC, Vladi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladi 2013-06-02 02:48:36 UTC
Screen flickers while navigation the xbmc gui.. Running AMD APU ATI ARUBA


Portage 2.1.11.62 (default/linux/amd64/13.0/desktop, gcc-4.6.3, glibc-2.15-r3, 3.10.0-rc3 x86_64)
=================================================================
System uname: Linux-3.10.0-rc3-x86_64-AMD_A6-5400K_APU_with_Radeon-tm-_HD_Graphics-with-gentoo-2.2
KiB Mem:     7563212 total,   2396028 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Sat, 01 Jun 2013 06:15:01 +0000
ld GNU ld (GNU Binutils) 2.22
distcc 3.1 x86_64-pc-linux-gnu [enabled]
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo x11 x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=k8 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/mnt/das1/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distcc distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LC_ALL="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/mnt/das1/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/cache/gentoo"
PORTDIR="/mnt/das1/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 64bit X a52 aac acpi adns alsa amd64 async bash-completion berkdb branding bzip2 cairo cdda cdr cgi chroot ck-server cli command-args consolekit cracklib crypt ctype curl cxx dbus dedicated dri dts dvdr dynamicplugin emboss enca encode enscript epoll exif extensions faac faad fasttrack ffmpeg firefox flac fontconfig fuse gbm gd gdbm geoip gif glamor glibc-omitfp gnutella gnutls hardcoded-tables hash hpn iconv imap inline inotify iproute2 ithreads jpeg kerberos lcms libnotify logrotate lzo mad magic matroska mmx mmxext mng modules mp3 mp4 mpeg mpm-worker mudflap multilib mysql nagios-dns nagios-ping nagios-ssh ncurses network nfsv3 no-old-linux nonfsv4 nptl odbc offensive ogg ogm opencl opengl openmp openvg optimization pam pango pcre pdf perl php pic png policykit ppds python python3 qt3support readline rpc rrdtool rtmp samba sdl session shared-dricore silvercity slang smi smtp snmp snortsam sockets spell sqlite sqlite3 sse sse2 sse3 ssl ssse3 subversion svg sysfs syslog theora threads tidy tiff truetype udev udisks unicode upower urandom userlocales v4l vdpau vim-syntax vorbis vpx wifi x264 xa xcb xml xrandr xv xvid xvmc zero-penalty-hit zip zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="alias auth_basic authz_host authz_user authn_file autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config mime mime_magic negotiation proxy proxy_http rewrite setenvif so status unique_id userdir usertrack vhost_alias cgid" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="btrfs" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en bg" LIRC_DEVICES="userspace" NGINX_MODULES_HTTP="access auth_basic autoindex browser charset empty_gif fastcgi geo gzip limit_req limit_zone map referer rewrite scgi split_clients ssi upstream_ip_hash userid uwsgi dav gzip_static proxy mp4" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="radeon r600" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Alex Deucher 2013-06-02 14:14:45 UTC
Please attach your xorg log and dmesg output.  Also, what version of mesa are you using?
Comment 2 Vladi 2013-06-02 18:37:34 UTC
Created attachment 80161 [details]
dmesg
Comment 3 Vladi 2013-06-02 18:40:39 UTC
Created attachment 80162 [details]
xorg.log
Comment 4 Vladi 2013-06-02 18:43:18 UTC
mesa is git from yesturday, gentoo mesa-9999 ebuild. Also when I add radeon.audio=1 to kernel parameters I get an purple line on the left side of the screen from top to bottom. I have tried with xorg 1.13 + mesa 9.2_pre20130528 and git same results..
Comment 5 Vladi 2013-06-02 18:44:46 UTC
forgot to mention my firmware files: linux-firwmare ebuild 20130421

59375dccb37f974c045575cd9428009a  radeon/ARUBA_me.bin
b3072fac01a6eab4711c18148c8bc305  radeon/ARUBA_pfp.bin
246d1c75a5946829f6864dbd5f71d850  radeon/ARUBA_rlc.bin
201877fa59f2fe4d896d5e6b6c1d2e1c  radeon/TAHITI_uvd.bin
Comment 6 Michel Dänzer 2013-06-03 14:51:29 UTC
Can you also attach the output of glxinfo and xbmc (in particular anything related to its use of OpenGL)?
Comment 7 Vladi 2013-06-03 18:51:36 UTC
Created attachment 80242 [details]
glxinfo
Comment 8 Vladi 2013-06-04 17:13:49 UTC
updated last night to 3.10.0-rc4 + mesa git + xf86-video-ati git and I am now seeing lockups during playback / navigating the UI in xbmc.. will try and track it down further.
Comment 9 Vladi 2013-06-06 02:33:05 UTC
Created attachment 80378 [details]
xbmc log
Comment 10 adam 2013-06-09 06:25:56 UTC
I can confirm this:

OpenGL renderer string: Gallium 0.4 on AMD ARUBA
OpenGL version string: 2.1 Mesa 9.2.0-devel (git-0aca2c6)
OpenGL shading language version string: 1.30
Comment 11 adam 2013-06-10 03:59:35 UTC
This is probably same as bug #60389
Comment 12 Vladi 2013-06-10 17:50:04 UTC
should I rma my cpu then?
Comment 13 adam 2013-06-10 18:14:54 UTC
I think the CPU/GPU si working as intended but it is not supported well by anything but closed drivers or Windows.  I hope this will be resolved soon.
Comment 14 Vladi 2013-08-15 22:04:43 UTC
I am now seeing random lockup then reboot's when watching videos with xbmc. I have latest 3.11-rc5 + mesa and ati driver from git. Any update on this? Thanks!
Comment 15 Alex Deucher 2013-08-15 22:08:38 UTC
Does setting env var R600_DEBUG=nodma help?
Comment 16 Vladi 2013-08-16 02:17:04 UTC
nope, tried that and R600_DEBUG=sb as well I also just tried latest patches from http://cgit.freedesktop.org/~agd5f/linux/log/?h=drm-fixes-3.11 with no luck
Comment 17 Vladi 2013-08-21 18:06:31 UTC
so far after disabling radeon.dpm I dont see the reboots. but my screen is still seeing the artifacts/flicker
Comment 18 Vladi 2013-09-18 08:35:05 UTC
http://gypsyops.aresgate.net/~vladi/dummy.mp4
video of the flicker in xbmc
Comment 19 Vladi 2013-09-21 17:22:49 UTC
no change with latest 3.12-rc2 kernel + mesa-9999
Comment 20 dennisridder 2013-10-05 20:48:36 UTC
I was about to file a new bug report, but this is exactly the same bug I'm suffering (A4-5300 APU).

Still unsolved in kernel 3.12 RC3.
Comment 21 bgunteriv 2013-10-07 00:17:29 UTC
I am also seeing the same thing

AMD A6-6400
Radeon HD 8470D

Here my logs:
http://paste.ubuntu.com/6192150/
http://paste.ubuntu.com/6192153/
http://paste.ubuntu.com/6192155/
http://paste.ubuntu.com/6192158/
http://paste.ubuntu.com/6192162/
Comment 22 bgunteriv 2013-10-07 00:27:27 UTC
setting:
"NoAccel" "true"

solves the problem, but the menu is super slow, and with the dual processor, they both peak at 90-100%

not a solid option.
Comment 23 Alex Deucher 2013-10-07 15:23:39 UTC

*** This bug has been marked as a duplicate of bug 63997 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.