Bug 63997 - Artifacts using a HD7480D on a A4-5300 APU
Summary: Artifacts using a HD7480D on a A4-5300 APU
Status: RESOLVED DUPLICATE of bug 60389
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: highest normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
: 65254 70769 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-04-27 13:47 UTC by Mirko
Modified: 2013-12-04 16:15 UTC (History)
9 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Artefacts video (2.36 MB, video/ogg)
2013-04-27 23:47 UTC, Mirko
no flags Details
Xorg log (39.22 KB, text/plain)
2013-04-27 23:48 UTC, Mirko
no flags Details
dmesg (51.93 KB, text/plain)
2013-04-27 23:48 UTC, Mirko
no flags Details
Artefacts video (1.49 MB, video/ogg)
2013-04-28 11:38 UTC, Mirko
no flags Details
Xorg log (39.22 KB, text/plain)
2013-04-28 11:39 UTC, Mirko
no flags Details
dmesg (50.04 KB, text/plain)
2013-04-28 11:39 UTC, Mirko
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mirko 2013-04-27 13:47:11 UTC
I'm trying to use a HD7480D on a cpu A4-5300 APU but I get many artifacts on the screen and I get poor performance (with glxgears using the fglrx driver I get at least 7k fps with the radeon driver fps 1k).
I've tried using various kernels starting from 3.4.41 to 3.9 rc8, the radeon driver 7.0 7.1 and git and mesa 9.1 and 9.2_20130404.
I also tried the following options:

Section "Device"
     Identifier "Radeon"
         Driver "radeon"
         Option "EXAPixmaps" "off"
         Option "AccelDFS" "off"
         Option "SwapbuffersWait" "off"
         Option "ColorTiling2D" "off"
         Option "ColorTiling" "off"
EndSection

Plus I've done tests ​from various live distributions to be sure that nothing is wrong on my system (getting the same artifacts).

Using nomodeset I get no artifacts on the screen but very low performance (glxgear get about 4 fps).

Glamor is disabled.
Comment 1 Alex Deucher 2013-04-27 22:03:17 UTC
Please attach your xorg log and dmesg output and a picture of the corruption.
Comment 2 Mirko 2013-04-27 23:47:55 UTC
Created attachment 78561 [details]
Artefacts video

This is the video with glxgears running
Comment 3 Mirko 2013-04-27 23:48:32 UTC
Created attachment 78562 [details]
Xorg log
Comment 4 Mirko 2013-04-27 23:48:53 UTC
Created attachment 78563 [details]
dmesg
Comment 5 James Cloos 2013-04-28 09:33:09 UTC
Just a quick note:

The dmesg shows that the fglrx kernel module was loaded.

Perhaps that interferes with the Xorg radeon driver?
Comment 6 Christian König 2013-04-28 09:55:13 UTC
(In reply to comment #5)
> Just a quick note:
> 
> The dmesg shows that the fglrx kernel module was loaded.
> 
> Perhaps that interferes with the Xorg radeon driver?

Yes that might indeed cause some problems, please remove the fglrx driver completely before trying the oss driver.

Christian.
Comment 7 Mirko 2013-04-28 10:42:32 UTC
I've installed the fglrx driver later, is the only way to run X in a decent way.
 
Without I have the same problem.
Comment 8 Mirko 2013-04-28 10:46:56 UTC
First tests were on xorg 1:14 which is not compatible with fglrx
Comment 9 Mirko 2013-04-28 11:38:39 UTC
Created attachment 78577 [details]
Artefacts video

Video of the corruption w/o Ati Drivers
Comment 10 Mirko 2013-04-28 11:39:25 UTC
Created attachment 78578 [details]
Xorg log

Xorg log w/o ati drivers
Comment 11 Mirko 2013-04-28 11:39:58 UTC
Created attachment 78579 [details]
dmesg

Dmesg w/o ati drivers
Comment 12 Mirko 2013-04-28 11:43:23 UTC
Ati driver completely removed, /lib/modules/* clean and kernel reinstall

New logs/video attached.
Comment 13 Mirko 2013-04-28 11:44:14 UTC
(obviously the problem persists)
Comment 14 stevenvandenbrandenstift 2013-06-16 08:44:33 UTC
i report the exact same problem an the same apu,
if you need any extra logs let me know, or any pointers to where to start debugging
Comment 15 Alex Deucher 2013-10-07 15:23:39 UTC
*** Bug 65254 has been marked as a duplicate of this bug. ***
Comment 16 bgunteriv 2013-10-07 16:28:03 UTC
I am also seeing the same thing

AMD A6-6400
Radeon HD 8470D

Here my logs:
http://paste.ubuntu.com/6192150/
http://paste.ubuntu.com/6192153/
http://paste.ubuntu.com/6192155/
http://paste.ubuntu.com/6192158/
http://paste.ubuntu.com/6192162/

setting:
"NoAccel" "true"

solves the problem, but the menu is super slow, and with the dual processor, they both peak at 90-100%

not a solid option.
Comment 17 bgunteriv 2013-10-07 17:05:34 UTC
there's also work being done with the OSS AMD drivers done on the XBMC website.

check here for some info -- http://forum.xbmc.org/showthread.php?tid=174854
Comment 18 bgunteriv 2013-10-08 03:51:25 UTC
please look at these logs...

i think the earlier ones are from an incomplete install of the drivers:
http://paste.ubuntu.com/6192150/
http://paste.ubuntu.com/6192153/
http://paste.ubuntu.com/6192155/
http://paste.ubuntu.com/6192158/
http://paste.ubuntu.com/6192162/
Comment 19 bgunteriv 2013-10-09 03:18:31 UTC
what other information do you need???
Comment 20 Alex Deucher 2013-10-09 13:12:11 UTC
Does attachment 86939 [details] [review] from bug 57919 help?
Comment 21 stevenvandenbrandenstift 2013-10-09 14:05:17 UTC
im sorry to ask but the patch is for the kernel or for this ati-dri (in archlinux) driver?
Comment 22 Alex Deucher 2013-10-09 14:07:15 UTC
kernel.
Comment 23 Mirko 2013-10-09 16:22:00 UTC
(In reply to comment #20)
> Does attachment 86939 [details] [review] [review] from bug 57919 help?

I'll try it tonight. Patch it's for a specific kernel version?
Comment 24 Alex Deucher 2013-10-09 16:47:47 UTC
It was against my drm-fixes tree, but it should apply pretty easily to most kernels.
Comment 25 Mirko 2013-10-10 21:14:14 UTC
(In reply to comment #24)
> It was against my drm-fixes tree, but it should apply pretty easily to most
> kernels.

Unfortunately the problem seems to be the same. 
Patched linux kernel 3.11.1
Xorg server 1.14
Mesa 9.2.0
Radeon 7.2.0

Tell me if I have to do other tests. At your disposal.

Thanks for help.
Comment 26 bgunteriv 2013-10-15 00:21:48 UTC
i can concur... still getting the artifacts; for me in XBMC GUI.

what else can we do to help?
Logs? etc...
Comment 27 bgunteriv 2013-10-15 00:27:02 UTC
I will say, as I'm going through the menus, the artifacts are not as bad as they've been. so there is improvement!

a lot of stuff that was completely unreadable i'm now able to read.

close! i look forward to hearing from you, and testing whatever is needed.
Comment 28 wazzubrad 2013-10-19 01:58:21 UTC
My XBMC system is useless until there is a fix. Thank you to whoever figures this out.

$ lspci
00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Richland [Radeon HD 8370D]

dmesg - http://paste.ubuntu.com/6260473/
xbmc.log - http://paste.ubuntu.com/6260482/
Xorg.0.log - http://paste.ubuntu.com/6260486/
vdpauinfo - http://paste.ubuntu.com/6260488/
dpkg -l |grep mesa - http://paste.ubuntu.com/6260490/
Comment 29 Alex Deucher 2013-10-22 16:13:43 UTC
*** Bug 70769 has been marked as a duplicate of this bug. ***
Comment 30 bgunteriv 2013-10-28 14:33:38 UTC
this is another person with the same issue, he posted on the XBMC forum.
so i'm quoting him here -- http://forum.xbmc.org/showthread.php?tid=174854&pid=1535631#pid1535631

========================================
Hey,

I have installed Ubuntu with XBMC on my machine with an AMD A6-6400K CPU, but my display is flickering on and on.
Here are my logs:
http://paste.ubuntu.com/6296156/
http://paste.ubuntu.com/6296157/
http://paste.ubuntu.com/6296159/
http://paste.ubuntu.com/6296161/
http://paste.ubuntu.com/6296168/

Thank you fritsch for your help.
Greetz, Chris
Comment 31 bgunteriv 2013-10-28 14:34:23 UTC
any updates on this?
any ideas???

is it because the technology is so new?
Comment 32 bgunteriv 2013-11-05 13:35:06 UTC
can you give us an update on this issue?
Comment 33 Jan Schröter 2013-11-07 10:54:02 UTC
The Status of this bug is still NEEDINFO. I am encountering the same problems here . So wich information can i provide to get closer to find the reason for this problem?
Comment 34 bgunteriv 2013-11-08 18:45:25 UTC
this is what one person had to say about this issue.
-------------------------------------------------------
http://forum.xbmc.org/showthread.php?tid=174854&pid=1545994#pid1545994

That looks like gles rendering where the triangles of a fan are submitted one by one. gles does not define GL_QUADS which is used by OpenGL. Maybe a problem with wayland support compiled into mesa.
Comment 35 Tony Ducrocq 2013-11-09 11:27:33 UTC
I confirm this bug with Radeon HD 7480D on AMD A4-4000 APU.
Comment 36 Tony Ducrocq 2013-11-09 12:23:28 UTC
I would like to test this patch : https://bugs.freedesktop.org/attachment.cgi?id=86939

but before I would like to know if my device is one of the one matching the condition (eg. 4hw contexts). How can I know my value for rdev->pdev->device ?
Comment 37 david 2013-11-10 18:30:24 UTC
you have the same graphic card than me (ati hd 7480D, but my cpu is the 5300)

I have tested the patch, but it doesnt fix our problem :(
Comment 38 Andreas Galauner 2013-11-24 21:45:33 UTC
I'm affected on this bug, too. glxgears looks the same like in the video and XBMC is unusable.

I'm on the gentoo kernel 3.12.0 with mesa 9.2.3 and libdrm 2.4.48.
Comment 39 Alex Deucher 2013-12-04 16:15:06 UTC

*** This bug has been marked as a duplicate of bug 60389 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.