Bug 66948 - [SNB]Piglit glx_glx-multithread-shader-compile randomly Aborted
Summary: [SNB]Piglit glx_glx-multithread-shader-compile randomly Aborted
Status: VERIFIED DUPLICATE of bug 65534
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-16 05:31 UTC by lu hua
Modified: 2015-02-06 03:36 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
output (8.52 KB, text/plain)
2013-07-16 05:31 UTC, lu hua
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lu hua 2013-07-16 05:31:56 UTC
Created attachment 82469 [details]
output

System Environment:
--------------------------
Arch:           i386
Platform:       Sandybridge
Libdrm:		(master)libdrm-2.4.46-1-gf8f1f6e37ae2c3eb4a9c045ba3294b3ccf926c07
Mesa:		(master)b616d0166158872a135153e27c391424fe655117
Xserver:	(master)xorg-server-1.14.99.1-133-g59a6d3f1eb03010ab831b32b03706a1d6143c732
Xf86_video_intel:(master)2.21.12
Cairo:		(master)2cc353c3dbe01b4d8f65d6de800f2b1d6004a1c2
Libva:		(staging)d68c9fb7eebe195d96e113abbf654f782a1450d8
Libva_intel_driver:(staging)1caf179b1425b13cacaa421c688c6df8369668c6
Kernel:	(drm-intel-nightly) 8adc236fef2538a8722dcfa92ff388babb475cc7

Bug detailed description:
-----------------------------
It randomly aborted on sandybridge with mesa master branch. It doesn't happen on mesa 9.1 branch.
It happens 1 in 10 runs.

(gdb) bt
#0  0xb7fff424 in __kernel_vsyscall ()
#1  0x4dcd894f in raise () from /lib/libc.so.6
#2  0x4dcda2a3 in abort () from /lib/libc.so.6
#3  0x4dd17ed5 in __libc_message () from /lib/libc.so.6
#4  0x4dd1f8c9 in _int_free () from /lib/libc.so.6
#5  0xb7b5c921 in xcb_get_maximum_request_length (c=0xb6a00ed0)
    at xcb_out.c:147
#6  0xb7d74e2e in XOpenDisplay (display=0x0) at OpenDis.c:498
#7  0xb7f2ebe2 in piglit_get_glx_display ()
    at /GFX/Test/Piglit/piglit/tests/util/piglit-glx-util.c:43
#8  0x08048abf in thread_func (arg=0x0)
    at /GFX/Test/Piglit/piglit/tests/glx/glx-multithread-shader-compile.c:59
#9  0x4de6badf in start_thread () from /lib/libpthread.so.0
#10 0x4dd9e44e in clone () from /lib/libc.so.6

Reproduce steps:
----------------------------
1. xinit
2. ./glx-multithread-shader-compile -auto -fbo
Comment 1 Eric Anholt 2014-02-05 18:01:26 UTC

*** This bug has been marked as a duplicate of bug 65534 ***
Comment 2 lu hua 2015-02-06 03:36:00 UTC
Verified.Fixed.
root@x-sgb4:/GFX/Test/Piglit/piglit/bin# ./glx-multithread-shader-compile -auto -fbo
libGL: OpenDriver: trying /opt/X11R7/lib/dri/tls/i965_dri.so
libGL: OpenDriver: trying /opt/X11R7/lib/dri/i965_dri.so
libGL: OpenDriver: trying /opt/X11R7/lib/dri/tls/i965_dri.so
libGL: OpenDriver: trying /opt/X11R7/lib/dri/i965_dri.so
PIGLIT: {"result": "pass" }


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.