Bug 70704 - Password required on document that opens without using Acrobat
Summary: Password required on document that opens without using Acrobat
Status: RESOLVED FIXED
Alias: None
Product: poppler
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 70705
  Show dependency treegraph
 
Reported: 2013-10-20 21:16 UTC by Robinson Tryon (qubit)
Modified: 2018-01-11 08:11 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Slides from LibreOffice2013 presentation (882.35 KB, application/pdf)
2013-10-20 21:16 UTC, Robinson Tryon (qubit)
Details
Slides from LibreOffice2013 presentation - cleaned with MuPDF (893.12 KB, application/pdf)
2013-10-23 14:35 UTC, Robinson Tryon (qubit)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robinson Tryon (qubit) 2013-10-20 21:16:21 UTC
Created attachment 87897 [details]
Slides from LibreOffice2013 presentation

Hi,

LibreOffice is in the process of assembling slides from our last conference and one of our presenters gave us a PDF export [see attachment] of PowerPoint slides which opens in Adobe Acrobat on Windows without a password, but gives a "Password required" prompt on Evince 3.4.0 on Ubuntu 12.04.3.

Testing with pdf2ps 9.05, gives the following error:
"   **** This file uses an unknown standard security handler revision: 6"

...which looks like this bug:
http://bugs.ghostscript.com/show_bug.cgi?id=693305

(I stole the title from bug 3498, but I believe this is a separate issue :-)
Comment 1 Albert Astals Cid 2013-10-20 22:04:43 UTC
FWIW Adobe Acrobat on Linux doesn't open the file here either.
Comment 2 James Cloos 2013-10-21 05:06:36 UTC
Interesting.

GhostScript also is unable to open it, but mupdf can do so.

The mupdf src has this comment about /R 6:

/*
 * Compute an encryption key (PDF 1.7 ExtensionLevel 8 algorithm)
 *
 * Adobe has not yet released the details, so the algorithm reference is:
 * http://esec-lab.sogeti.com/post/The-undocumented-password-validation-algorithm-of-Adobe-Reader-X
 */

That will be needed to handle this document.

-JimC
Comment 3 Robinson Tryon (qubit) 2013-10-23 14:35:27 UTC
Created attachment 88038 [details]
Slides from LibreOffice2013 presentation - cleaned with MuPDF

(In reply to comment #2)
> Interesting.
> 
> GhostScript also is unable to open it, but mupdf can do so.

Excellent. Looks like we can mupdf to convert the PDF files.

WORKAROUND:

Build MuPDF from source (3379bea "Remove duplicated line.") and use mutool to massage a (seemingly) encrypted PDF into something more standard.

For example:
qubit@loopbackoffice:~/src/mupdf/build/debug/mutool clean LibO\ Conf\ 2013\ as\ presented.pdf LibO-Conf-2013_cleaned-with-mupdf.pdf

Evince can open the output PDF properly.
Comment 4 Michael Weghorn 2018-01-11 08:10:42 UTC
This is no longer reproducible since support has been added to poppler a while ago. This is also documented in the referenced LibreOffice bug report.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.