Bug 731 - Making KB Layout switch similar to (horror) Win
Summary: Making KB Layout switch similar to (horror) Win
Status: RESOLVED DUPLICATE of bug 865
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/Keyboard (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high enhancement
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-06-08 00:12 UTC by Meni Taub
Modified: 2004-07-24 20:56 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Meni Taub 2004-06-08 00:12:00 UTC
When setting the layout-switching key combo to Alt+Shift (like in windows), the
switching occurs on key down event of the shift key. That conflicts with key
combos that start with Alt+shift (e.g Alt+Shift+N). They cause a erroneous
layout switch. IMHO only when the user releases the Shift key layout switch
should occur.

Also in Win there is a difference between left and right Alt+Shift. When one has
more then 2 layouts, left Alt+shift rotate them one way while the right
Alt+Shift rotate them the other.

Thanks, and God bless all those who toil on OSS ;-)
Comment 1 Kristian Høgsberg 2004-07-25 13:56:14 UTC

*** This bug has been marked as a duplicate of 865 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.