Bug 73431 - [snb] GPU hang in blorp HiZ resolve for google maps
Summary: [snb] GPU hang in blorp HiZ resolve for google maps
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 73879 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-01-09 12:39 UTC by philipp
Modified: 2019-02-15 18:33 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
/sys/class/drm/card0/error (2.18 MB, text/plain)
2014-01-09 12:39 UTC, philipp
Details
dmesg (65.07 KB, text/plain)
2014-01-09 12:39 UTC, philipp
Details
/sys/class/drm/card0/error with mesa trunk commit 9036887, kernel 3.13-rc8 (2.17 MB, text/plain)
2014-01-14 14:28 UTC, philipp
Details
/sys/class/drm/card0/error - Mesa 10.0.2, libdrm 2.4.51 (2.15 MB, text/plain)
2014-01-26 21:13 UTC, Pawel Drewniak
Details
i915_error_state (2.31 MB, text/plain)
2014-02-17 14:58 UTC, Jan Alexander Steffens (heftig)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description philipp 2014-01-09 12:39:05 UTC
Created attachment 91744 [details]
/sys/class/drm/card0/error

I'm seeing this error when using the google maps preview:

[drm] stuck on render ring
[drm] GPU crash dump saved to /sys/class/drm/card0/error
[drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0xbd31000 ctx 1) at 0xbd32750
Comment 1 philipp 2014-01-09 12:39:45 UTC
Created attachment 91745 [details]
dmesg
Comment 2 Daniel Vetter 2014-01-10 07:54:03 UTC
Chad recently pushed a bunch of HiZ fixes to mesa git master, so retesting with that should be useful.
Comment 3 Chad Versace 2014-01-10 16:20:58 UTC
(In reply to comment #2)
> Chad recently pushed a bunch of HiZ fixes to mesa git master, so retesting
> with that should be useful.

All my HiZ hang fixes exist in master 90368875e733171350c64c8dda52f81bd0705dd0. Please retest with a git revision no older than that. And when you report back, please provide the Mesa git hash that you tested with.
Comment 4 philipp 2014-01-14 14:28:04 UTC
Created attachment 92043 [details]
/sys/class/drm/card0/error with mesa trunk commit 9036887, kernel 3.13-rc8

I tested it with commit 9036887. Google maps does not only hang but shows a black screen it recovered.

If someone else would like to inspect or test the packages I used, have a look at http://koji.fedoraproject.org/koji/taskinfo?taskID=6403151 .
Comment 5 philipp 2014-01-14 14:53:05 UTC
New seems to be the message

[drm:i915_context_is_banned] *ERROR* context hanging too fast, declaring banned!
Comment 6 Chad Versace 2014-01-16 18:19:51 UTC
From your latest error dump:

render command stream:
  HEAD: 0x00e1bbe0
    head = 0x0001bbe0, wraps = 7
  TAIL: 0x0001c780
  CTL: 0x0001f001
  ACTHD: 0x05980c38
  IPEIR: 0x00000000
  IPEHR: 0x7a000002
  INSTDONE: 0xfffffffb
    busy: HIZ

Even on Mesa master-9036887, the hang is still HiZ's fault :(

Hangs are always difficult to diagnose, so I apologize beforehand for how much turnaround it may take to solve this.

I have some actions and questions for you:

  - Is your Mesa build unpatched? Or does it include patches from the RPM? This is critical, because some Fedora Mesa SRPMS contain already contain a HiZ workaround patch that may intefere with upstream. If your RPM contains patches, please provide the full SRPM. (I can pull from git://pkgs.fedoraproject.org/mesa if that makes it easier).

  - Which version of xf86-video-intel? Can you point to a SRPM?

  - Please try to reproduce with Mesa master-6a5c86f. The commit immediately after that removes a "redundant" HiZ workaround. Maybe it wasn't redundant after all.

  - If you can still reproduce with Mesa master-6a5c86f, then please also try with tag mesa-10.0.2.

  - What is the mean time to failure after a reboot?

  - How exactly are you reproducing the hang? By zooming and out on New York City for 4 hours? By rotating the earth left continuously for 30 minutes near the equator?
Comment 7 Chris Wilson 2014-01-21 17:23:15 UTC
*** Bug 73879 has been marked as a duplicate of this bug. ***
Comment 8 Pawel Drewniak 2014-01-22 01:03:53 UTC
Hi,

Since my Bug 73879 was marked as duplicate of this one, I'll try to answer Chad's questions (at least partially)

  - media-libs/mesa-9.2.5 on Gentoo. These are the patches that are applied:
 * 0000-llvm-3_4-noframepointerelimnonleaf.patch
 * 0001-llvm-3_4-targetoptions_realignstack.patch
 * 0002-llvm3_4-createinternalizepass.patch
 * 0003-llvm-3_4-disableprettystacktrace.patch
 * mesa-9.2-dont-require-llvm-for-r300.patch
 * glx_ro_text_segm.patch

  - x11-drivers/xf86-video-intel-2.99.907. No patches.

  - I will try to reproduce with the two Mesa builds and report back.

  - In my case it is sufficient to use the new ("preview") Google Maps for a while - dragging around, zooming in and out leads to a reproducible hang usually within half a minute or so.

The card error dump was attached to Bug 73879
Comment 9 Pawel Drewniak 2014-01-26 21:11:42 UTC
Still occurs with Mesa 10.0.2/libdrm 2.4.51

[156644.157901] Watchdog[5834]: segfault at 0 ip 00007f1b813a862e sp 00007f1b6cb8b7e0 error 6 in chrome[7f1b7da97000+5b82000]
[156646.180028] [drm] stuck on render ring
[156646.180069] [drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0x4bc3d000 ctx 4) at 0x4bc3f4b0
Comment 10 Pawel Drewniak 2014-01-26 21:13:19 UTC
Created attachment 92824 [details]
/sys/class/drm/card0/error - Mesa 10.0.2, libdrm 2.4.51
Comment 11 Jan Alexander Steffens (heftig) 2014-02-17 14:58:10 UTC
Created attachment 94212 [details]
i915_error_state

Also seeing hangs caused by using Google Maps (WebGL) in Firefox in GNOME Shell, IPEHR 0x7a000002.

Arch Linux x86_64, Thinkpad X220T (SNB)
Linux 3.13.3
xf86-video-intel master eb7d2b1, TearFree enabled
mesa 10.0.3
libdrm 2.4.52

[17003.919105] [drm] stuck on render ring
[17003.922179] [drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0xeaeb000 ctx 4) at 0xeaecacc

[17366.400732] [drm] stuck on render ring
[17366.400968] [drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0x1cf5000 ctx 11) at 0x1cf860c
Comment 12 Leo Wolf 2014-07-22 13:10:09 UTC
>   - Please try to reproduce with Mesa master-6a5c86f. The commit immediately
> after that removes a "redundant" HiZ workaround. Maybe it wasn't redundant
> after all.

The hang occurs on master, on master without 9036887, on master-6a5c86f, and on 10.0.2.

>   - How exactly are you reproducing the hang? By zooming and out on New York
> City for 4 hours? By rotating the earth left continuously for 30 minutes
> near the equator?

Just wiggling the map (https://www.google.com/maps/preview/?force=webgl) is enough in chromium.  Having the FPS counter enabled delays the hang in chromium.  I can't consistently reproduce it in firefox.
Comment 13 Chad Versace 2014-08-13 17:47:12 UTC
Reassigning to default assignee. I moved to a different Intel team and do not have the bandwith to solve this.
Comment 14 Matt Turner 2017-03-22 02:39:40 UTC
Please reopen if you can still reproduce with Mesa 17.0.
Comment 15 Denis 2019-02-15 11:58:44 UTC
Hi, I think that this issue also can be closed, same with https://bugs.freedesktop.org/show_bug.cgi?id=73840

They look similar. Also, I checked it again with current mesa/kernel, and with downgraded to 4.9 kernel and 10 mesa. Issue also wasn't reproduced.

According to ticket, there was 3.* kernel version, which is too old for now.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.