Bug 74171 - [xorg-edgers] Texture artifacts in League of Legends GUI windows
Summary: [xorg-edgers] Texture artifacts in League of Legends GUI windows
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium minor
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 74170 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-01-29 07:00 UTC by ng.godwin.4
Modified: 2019-09-25 18:50 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Opening the settings menu creates polygonal artifacts (853.06 KB, image/png)
2014-01-29 07:01 UTC, ng.godwin.4
Details
History.log excerpt (2.88 KB, text/plain)
2014-01-29 07:02 UTC, ng.godwin.4
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ng.godwin.4 2014-01-29 07:00:28 UTC
Reproduce:
Running League of Legends in Wine 1.7.10, create a new game and open the settings menu or any GUI window.

Description
Polygonal artifacts appear when opening GUI windows. Unit and map textures are OK.
Screenshots at http://imgur.com/a/aGuPH

Purging the xorg-edgers PPA and returning to Trusty builds resolved the problem. I attached the logs from the purge.

Other information
Vaio VPCEH24FX
Intel® Core™ i3-2330M CPU @ 2.20GHz × 4
Intel HD Graphics 3000
Ubuntu 14.04
Comment 1 ng.godwin.4 2014-01-29 07:01:12 UTC
Created attachment 92968 [details]
Opening the settings menu creates polygonal artifacts
Comment 2 ng.godwin.4 2014-01-29 07:02:50 UTC
Created attachment 92969 [details]
History.log excerpt

Logs detailing packages that were purged (problem only occured with these packages)
Comment 3 Chris Wilson 2014-02-13 10:44:32 UTC
*** Bug 74170 has been marked as a duplicate of this bug. ***
Comment 4 Elizabeth 2017-10-27 21:52:01 UTC
Hello, is this still valid with latest SW? Otherwise closing soon. Thank you.
Comment 5 GitLab Migration User 2019-09-25 18:50:04 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1406.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.