Bug 74892 - HyperZ GPU lockup with radeonsi 7970M PITCAIRN and Distance Alpha game
Summary: HyperZ GPU lockup with radeonsi 7970M PITCAIRN and Distance Alpha game
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 75112
  Show dependency treegraph
 
Reported: 2014-02-12 15:20 UTC by Christoph Haag
Modified: 2014-09-01 21:48 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
please ignore (448.29 KB, application/octet-stream)
2014-02-14 18:50 UTC, Christoph Haag
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Haag 2014-02-12 15:20:43 UTC
The kernel people at https://bugzilla.kernel.org/show_bug.cgi?id=70411 told me this needs to be fixed in mesa, so here it is.

The interesting part:

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wimbledon XT [Radeon HD 7970M]

Latest mesa git, but has probably been happening since HyperZ was enabled by default.

dmesg is attached there: https://bugzilla.kernel.org/attachment.cgi?id=125651

It's reproducible every time so I can later get more detail. For now there's the dmesg: Starting the game and showing some intro works, but shortly before displaying the menu X freezes for a few seconds and after it is usable again, I see the stuff starting at 82688.801309 in dmesg.

HyperZ seems to work fine for everything else I have tried so far. It only happens in the Distance Alpha that's only (officially) available to kickstarter backers.
Comment 1 Christoph Haag 2014-02-14 18:50:13 UTC
Created attachment 94093 [details]
please ignore

(In reply to comment #8)
> Created attachment 94078 [details]
> Patch to test
> 
> Can you test this patch and post the output of R600_DEBUG=cs

It's crashing again with

0x7f76ed4687c0: i32 = ExternalSymbol'__muldi3'

For some reason the output seems to be doubled in my log.

I hope it's not a problem that llvm was built from a newer revision than clang.
Comment 2 Christoph Haag 2014-02-14 18:54:13 UTC
Comment on attachment 94093 [details]
please ignore

Sorry to whoever got mails now, didn't mean to post this here.
Comment 3 Marek Olšák 2014-09-01 20:34:40 UTC
Is this fixed with current Mesa git?

If not, could you please make and upload a trace file using apitrace:

https://github.com/apitrace/apitrace

Thanks.
Comment 4 Christoph Haag 2014-09-01 21:04:35 UTC
Yes, seems to work now after a few short tests. No hangs.

Thanks!
Comment 5 Marek Olšák 2014-09-01 21:29:28 UTC
Did you set this environment variable before testing?

R600_DEBUG=hyperz
Comment 6 Christoph Haag 2014-09-01 21:42:00 UTC
(In reply to comment #5)
> Did you set this environment variable before testing?
> 
> R600_DEBUG=hyperz

There are times when I don't know what I'm doing but this time I used this in steam:

DRI_PRIME=1 GALLIUM_HUD="fps,VRAM-usage+GTT-usage" R600_DEBUG=hyperz %command%
Comment 7 Marek Olšák 2014-09-01 21:48:52 UTC
Ok, that looks good. Thanks.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.