Bug 75011 - [hyperz] Performance drop since git-01e6371 (disable hyperz by default) with radeonsi
Summary: [hyperz] Performance drop since git-01e6371 (disable hyperz by default) with ...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on: 75112
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-15 08:39 UTC by Tom Guder
Modified: 2014-10-24 07:30 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Results from gputest (6.57 KB, text/plain)
2014-02-15 08:39 UTC, Tom Guder
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Guder 2014-02-15 08:39:27 UTC
Created attachment 94113 [details]
Results from gputest

Hello.

I noticed a performancedrop since git-6d1cecb on radeonsi using arch with mesa from the following repo:

[mesa-git]
SigLevel = Optional TrustAll
Server = http://pkgbuild.com/~lcarlier/$repo/$arch

I attach the results of:
start_furmark_benchmark_fullscreen_1920x1080.sh

Furthermore the unigine-valley performance decrease is from 26 to 22 fps.


Tom
Comment 1 Andreas Boll 2014-02-15 11:11:41 UTC
I think the performance drop is caused by:

radeon: reverse DBG_NO_HYPERZ logic [1]

You can explicitly enable hyperz with setting the environment variable R600_DEBUG=hyperz


[1] http://cgit.freedesktop.org/mesa/mesa/commit/?id=01e637114914453451becc0dc8afe60faff48d84
Comment 2 Tom Guder 2014-02-16 18:22:56 UTC
I confirm this. Thanks.
Comment 3 Andreas Boll 2014-02-17 18:24:32 UTC
We keep this bug open until hyperz gets re-enabled by default.
Comment 4 Benjamin Bellec 2014-02-17 19:11:52 UTC
Yes I confirm too. HyperZ gives a serious boost.
In the Counter Strike: Source Video Stress Test I was at 46,65 FPS with a RV770, and now at 37,90 FPS without HyperZ.
Comment 5 Andreas Boll 2014-10-24 07:30:01 UTC
Fixed with

commit 14bdcc6ff98664552216acfdb7e35d0b128003ef
Author: Andreas Boll <andreas.boll.dev@gmail.com>
Date:   Thu Oct 23 14:52:55 2014 +0200

    radeon: enable Hyper-Z on r600g and radeonsi by default
    
    This reverts commit 01e637114914453451becc0dc8afe60faff48d84.
    Since then many Hyper-Z issues have been fixed or worked around.
    
    Enable Hyper-Z by default so that we get enough feedback for the upcoming
    mesa 10.4 release.
    
    If you have issues with Hyper-Z try to disable Hyper-Z using the enviroment
    variable R600_DEBUG=nohyperz and please report the issue on the bugtracker.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=75011
    See also: https://bugs.freedesktop.org/show_bug.cgi?id=75112
    
    Signed-off-by: Andreas Boll <andreas.boll.dev@gmail.com>
    Reviewed-by: Marek Olšák <marek.olsak@amd.com>


bug/show.html.tmpl processed on Feb 26, 2017 at 07:46:00.
(provided by the Example extension).