Bug 76435 - Lenovo T440s with Ultra Dock detects 2 Monitors as one with resolution 3840x1080
Summary: Lenovo T440s with Ultra Dock detects 2 Monitors as one with resolution 3840x1080
Status: RESOLVED DUPLICATE of bug 72795
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Chris Wilson
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-21 10:03 UTC by Peter Löffler
Modified: 2014-03-21 10:18 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Löffler 2014-03-21 10:03:51 UTC
I have a Lenovo T440s with an Ultra Dock and 2 Samsung S27C450 monitors.
OS is Fedora 20 x86_64

[captain@HBDLAP7420 ~]$ uname -a
Linux HBDLAP7420.herold.intra 3.13.6-200.fc20.x86_64 #1 SMP Fri Mar 7 17:02:28 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

When i connect one monitor over DVI and one over Display Port they seams to be detected as on big monitor.

[captain@HBDLAP7420 ~]$ xrandr 
Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 8192 x 8192
eDP1 connected (normal left inverted right x axis y axis)
   1920x1080      60.0 +
   1400x1050      60.0  
   1280x1024      60.0  
   1280x960       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP2 connected primary 3840x1080+0+0 (normal left inverted right x axis y axis) 598mm x 336mm
   1920x1080      60.0 +
   3840x1080      60.0* 
   2560x1024      60.0  
   1680x1050      60.0  
   1600x900       60.0  
   1280x1024      75.0     60.0  
   1440x900       59.9  
   1280x800       59.8  
   1152x864       75.0  
   1280x720       60.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        75.0     72.8     66.7     60.0  
   720x400        70.1  
HDMI2 disconnected (normal left inverted right x axis y axis)
[captain@HBDLAP7420 ~]$

[captain@HBDLAP7420 ~]$ sudo tail -f /var/log/messages
[sudo] password for captain:
Mar 21 10:54:31 HBDLAP7420 colord: Automatic metadata add icc-2eeff3f924cdccc1a3cdf6f32dea4e8d to xrandr-Samsung Electric Company-S27C450-HMCD100462
Mar 21 10:54:31 HBDLAP7420 colord: Automatic metadata add icc-1555cc1afbf2eb389d5e7c9736d1478f to xrandr-Samsung Electric Company-S27C450-HMCD100462
Mar 21 10:54:31 HBDLAP7420 colord: Automatic metadata add icc-ca7c2359c3803aa888a8abfb9b699e9d to xrandr-Samsung Electric Company-S27C450-HMCD100462
Mar 21 10:54:31 HBDLAP7420 colord: Automatic metadata add icc-c0f2c092037c424fa431217482fe2708 to xrandr-Samsung Electric Company-S27C450-HMCD100462
Mar 21 10:54:31 HBDLAP7420 colord: Device added: xrandr-Samsung Electric Company-S27C450-HMCD100462
Mar 21 10:54:32 HBDLAP7420 colord: device removed: xrandr-Samsung Electric Company-S27C450-HMCD100462
Mar 21 10:54:34 HBDLAP7420 colord: Automatic metadata add icc-b415c3a98e554b5fb918a2ca4e33e3a7 to xrandr-Samsung Electric Company-S27C450-1515733334
Mar 21 10:54:34 HBDLAP7420 colord: Automatic metadata add icc-1961a3a64e0b78cfa296c901bada1d1e to xrandr-Samsung Electric Company-S27C450-1515733334
Mar 21 10:54:34 HBDLAP7420 colord: Device added: xrandr-Samsung Electric Company-S27C450-1515733334

First i thought it is a hardware limitation but whis Windoof everything works as expected.
When i use the VGA and the Mini Display Port of the Laptop directly (without the Ultra Dock) the two monitors are also detected as two separate with 1920x1080.
Comment 1 Chris Wilson 2014-03-21 10:18:42 UTC
There are two aspects to this. You have a smart dock that combines the two monitors into one because the driver doesn't yet support MST.

*** This bug has been marked as a duplicate of bug 72795 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.