Bug 76858 - Dota 2 texture corruption
Summary: Dota 2 texture corruption
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 77449
  Show dependency treegraph
 
Reported: 2014-03-31 20:23 UTC by domagoj
Modified: 2017-02-06 12:34 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description domagoj 2014-03-31 20:23:50 UTC
texrure in game dota 2 is blinking 
upgraded Karnel 3.14.0-031400-generic on mint 16 and i have texure coruption blinking samthing 


(glxinfo | grep OpenG
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile 
OpenGL core profile version string: 3.1 (Core Profile) Mesa 10.2.0-devel
OpenGL core profile shading language version string: 1.40
OpenGL core profile context flags: (none)
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.2.0-devel
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:)

Kernel~3.14.0-031400-generic x86_64
Comment 1 Antti Koskipaa 2014-04-02 11:15:25 UTC
I need more information:
- Did you upgrade anything else at the same time, such as Mesa?
- Did you try the dithering workaround mentioned in bug 74700?
- Attach the screenshots that you emailed me to this bug.
Comment 2 domagoj 2014-04-02 14:54:57 UTC
i was on karnel 3.11.0-12-generic(game rune fine) after upadate to karnel 3.14 i was update video driver and mesa 
(glxinfo | grep OpenG
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile 
OpenGL core profile version string: 3.1 (Core Profile) Mesa 10.2.0-devel
OpenGL core profile shading language version string: 1.40
OpenGL core profile context flags: (none)
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.2.0-devel
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensionsGraphics:

Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller 
X.Org: 1.14.5 drivers: intel (unloaded: fbdev,vesa) Resolution: 1360x768@59.8hz 
GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 10.2.0-devel



and the game was white half texture like 2d i dont know just i cant find solution on forums and google 

http://imgur.com/5pCfzOn
http://imgur.com/1si6T86
http://imgur.com/UrBpTfy
http://imgur.com/IQc2Txl
yes i have almost same problem like in bug https://bugs.freedesktop.org/show_bug.cgi?id=74700 but i reed that and dont know solution for that ?
Comment 3 domagoj 2014-04-02 14:56:56 UTC
disabling GL_DITHER how tu disable that
Comment 4 Ian Romanick 2014-04-14 20:31:23 UTC
If changing the kernel affected the bug, then it is not the same issue as bug #74700.  That's why Matt asked you to report a new bug. :)

Yes, please upload a screen shot of the issue.  Without that, we won't have any idea what the problem is.

Thanks.
Comment 5 Eero Tamminen 2017-02-06 12:34:11 UTC
Required information still missing after ~2 years.

Among other changes, DOTA2 uses nowadays Source engine v2 instead of source engine v1 (against which this was reported).

-> Closing this as obsolete / WORKSFORME.  If there's a problem with a DOTA2 version that is currently available, please file a separate bug.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.