Bug 7735 - cairo doesn't support 8-bit truecolor visuals
cairo doesn't support 8-bit truecolor visuals
Status: RESOLVED FIXED
Product: cairo
Classification: Unclassified
Component: general
1.2.0
x86 (IA32) Linux (All)
: high blocker
Assigned To: Carl Worth
cairo-bugs mailing list
:
: 7918 7975 8036 8716 8719 8723 8828 8847 10068 10513 10750 10958 11263 12248 (view as bug list)
Depends on: 5027
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-02 08:02 UTC by Jeff Bowman
Modified: 2008-04-24 17:35 UTC (History)
20 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Bowman 2006-08-02 08:02:37 UTC
Error: Cairo does not yet support the requested image format:
        Depth: 8
        Alpha mask: 0x00000000
        Red   mask: 0x00000007
        Blue  mask: 0x00000038
        Green mask: 0x000000c0
Please file an enhacement request (quoting the above) at:
http://bugs.freedesktop.org/enter_bug.cgi?product=cairo
gnome-terminal: /home/dajobe/dev/debian/cairo/libcairo-1.2.0/src/cairo-image-
surface.c:144: _cairo_format_from_pixman_format: Assertion `NOT_REACHED' failed.
Comment 1 Carl Worth 2006-08-02 09:58:38 UTC
Please try the latest patch from bug 7294 and let us know how it works for your
case.

-Carl

PS. I'm quite curious as to what X server you are using that presents this 8-bit
TrueColor visual.
Comment 2 Christophe Wolfhugel 2006-08-05 06:54:41 UTC
Not speaking for Jeff, we have the same issue. The X server is a
Tarantella instance (several years old).

on number:    11.0
vendor string:    Santa Cruz Operation Inc.
vendor release number:    6000
maximum request size:  4194300 bytes
motion buffer size:  256
bitmap unit, bit order, padding:    32, LSBFirst, 32
image byte order:    LSBFirst
number of supported pixmap formats:    2
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 8, bits_per_pixel 8, scanline_pad 32
keycode range:    minimum 0, maximum 254
focus:  window 0x80000e, revert to Parent
number of extensions:    14
    BIG-REQUESTS
    DOUBLE-BUFFER
    GLX
    MIT-SUNDRY-NONSTANDARD
    Multi-Buffering
    NATIVE-WND
    RDP
    SCO-MISC
    SGI-GLX
    SHAPE
    SYNC
    XC-MISC
    XTEST
    XTTDEV
default screen number:    0
number of screens:    1

screen #0:
  dimensions:    1024x768 pixels (260x195 millimeters)
  resolution:    100x100 dots per inch
  depths (2):    1, 8
  root window id:    0x3a
  depth of root window:    8 planes
  number of colormaps:    minimum 1, maximum 1
  default colormap:    0x30
  default number of colormap cells:    256
  preallocated pixels:    black 0, white 255
  options:    backing-store YES, save-unders YES
  largest cursor:    1280x1024
  current input event mask:    0x400000
    PropertyChangeMask       
  number of visuals:    8
  default visual id:  0x31
  visual:
    visual id:    0x31
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x32
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x33
    class:    DirectColor
    depth:    8 planes
    available colormap entries:    8 per subfield
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x34
    class:    GrayScale
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x35
    class:    StaticColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x36
    class:    TrueColor
    depth:    8 planes
    available colormap entries:    8 per subfield
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x37
    class:    TrueColor
    depth:    8 planes
    available colormap entries:    8 per subfield
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x38
    class:    StaticGray
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
Comment 3 Jeff Bowman 2006-08-07 05:24:28 UTC
it was a vnc session which reported the error running xorg 7 xserver on the 
host machine (Debian testing)(In reply to comment #2)
Comment 4 bolo 2006-08-18 00:57:38 UTC
I have the same proplem with the same error in a X forwarding ssh connection
the only one difference in the output is

Depth: 24
Comment 5 Behdad Esfahbod 2006-08-18 09:55:52 UTC
Does this still happen with 1.2.2?
Comment 6 Behdad Esfahbod 2006-08-19 12:28:40 UTC
*** Bug 7918 has been marked as a duplicate of this bug. ***
Comment 7 Behdad Esfahbod 2006-08-24 11:45:28 UTC
*** Bug 7975 has been marked as a duplicate of this bug. ***
Comment 8 destroyedlolo 2006-08-25 15:15:35 UTC
(In reply to comment #5)
> Does this still happen with 1.2.2?

I'm running a SUN Ultra5 under solaris 8, with 8 bits screen and 1.2.2 give the
same error message :

Error: Cairo does not yet support the requested image format:
        Depth: 8
        Alpha mask: 0x00000000
        Red   mask: 0x00000000
        Green mask: 0x00000000
        Blue  mask: 0x00000000
Comment 9 Behdad Esfahbod 2006-08-29 10:10:54 UTC
*** Bug 8036 has been marked as a duplicate of this bug. ***
Comment 10 Carl Worth 2006-08-31 12:11:30 UTC
(In reply to comment #8)
> Error: Cairo does not yet support the requested image format:
>         Depth: 8
>         Alpha mask: 0x00000000
>         Red   mask: 0x00000000
>         Green mask: 0x00000000
>         Blue  mask: 0x00000000

That's actually a different bug. The all-zero masks above indicate an 8-bit
pseudocolor visual. It's true that cairo doesn't support that currently, but
that's what bug #4945 is all about.

This bug, however, is about 8-bit truecolor visuals. And it would be very
interesting to know if this bug has gone away with 1.2.2, (since the fix we did
for BGR X servers may very well have fixed 8-bit truecolor as well).

Please report either affirmative or negative results with 8-bit truecolor
visuals with cairo 1.2.2 or 1.2.4.

-Carl
Comment 11 Martin von Gagern 2006-09-05 08:08:35 UTC
(In reply to comment #10)
> Please report either affirmative or negative results with 8-bit truecolor
> visuals with cairo 1.2.2 or 1.2.4.

My dup report in bug 8036 can be reproduced using cairo 1.2.4, so it looks like
the problem persists. I can also reproduce the issue with rsvg-view from Gnome
librsvg, which is probably available on more systems out there than boinc_gui.
Comment 12 Jeff Bowman 2006-09-05 10:24:49 UTC
I saw the error in a vnc session, however, with cairo 1.2.4, I no longer see the
error.

(In reply to comment #10)
> 
> This bug, however, is about 8-bit truecolor visuals. And it would be very
> interesting to know if this bug has gone away with 1.2.2, (since the fix we did
> for BGR X servers may very well have fixed 8-bit truecolor as well).
> 
> Please report either affirmative or negative results with 8-bit truecolor
> visuals with cairo 1.2.2 or 1.2.4.
> 
> -Carl
> 
Comment 13 Peter Marquardt 2006-09-11 04:45:32 UTC
> Please report either affirmative or negative results with 8-bit truecolor
> visuals with cairo 1.2.2 or 1.2.4.

I'm still  having the same problem (with 1.2.4).

either via a VNC session from windows to linux or via ssh from my workstation
(dec alpha, digital unix) per ssh to a linuxbox.

Error: Cairo does not yet support the requested image format:
        Depth: 16
        Alpha mask: 0x00000000
        Red   mask: 0x0000001f
        Green mask: 0x000007e0
        Blue  mask: 0x0000f800
Please file an enhacement request (quoting the above) at:
http://bugs.freedesktop.org/enter_bug.cgi?product=cairo
gpe-todo: cairo-image-surface.c:155: _cairo_format_from_pixman_format: Assertion
`NOT_REACHED' failed.

One should consider that the X11 servers (either vnc or Xdec) are quite old.


xpdyinfo says (either local or ssh-remote):

---- Digital X Server ------- rrrrrrrrrrrrrip ---------------
vendor string:    DECWINDOWS Digital Equipment Corporation Digital UNIX V4.0
vendor release number:    1
maximum request size:  4194300 bytes
motion buffer size:  100
bitmap unit, bit order, padding:    32, LSBFirst, 32
image byte order:    LSBFirst
number of supported pixmap formats:    7
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 4, bits_per_pixel 8, scanline_pad 32
    depth 8, bits_per_pixel 8, scanline_pad 32
    depth 12, bits_per_pixel 32, scanline_pad 32
    depth 21, bits_per_pixel 32, scanline_pad 32
    depth 24, bits_per_pixel 32, scanline_pad 32
    depth 16, bits_per_pixel 16, scanline_pad 32
keycode range:    minimum 8, maximum 255
focus:  window 0x7c0000d, revert to Parent
number of extensions:    21
    BIG-REQUESTS
    DEC-PEER-GLX
    DEC-XTRAP
    DECStereo
    DOUBLE-BUFFER
    DPMS
    GLX
    Keyboard-Management-Extension
    MIT-SCREEN-SAVER
    MIT-SHM
    MIT-SUNDRY-NONSTANDARD
    Multi-Buffering
    SHAPE
    SYNC
    Shared-Memory Transport
    XC-MISC
    XIE
    XInputExtension
    XKEYBOARD
    XTEST
    XVideo
default screen number:    0
number of screens:    1
----------- rrrrrrrrrrrrrip ---------------

and here the other one:

---- vnc Xvnc version 3.3.2r3 ------- rrrrrrrrrrrrrip ---------------
name of display:    warthole:1.0
version number:    11.0
vendor string:    The Olivetti & Oracle Research Laboratory
vendor release number:    3323
maximum request size:  4194300 bytes
motion buffer size:  256
bitmap unit, bit order, padding:    32, LSBFirst, 32
image byte order:    LSBFirst
number of supported pixmap formats:    2
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 8, bits_per_pixel 8, scanline_pad 32
keycode range:    minimum 8, maximum 255
focus:  PointerRoot
number of extensions:    7
    BIG-REQUESTS
    MIT-SHM
    MIT-SUNDRY-NONSTANDARD
    SHAPE
    SYNC
    XC-MISC
    XTEST
default screen number:    0
number of screens:    1

screen #0:
  print screen:    no
  dimensions:    640x480 pixels (163x122 millimeters)
  resolution:    100x100 dots per inch
  depths (1):    8
  root window id:    0x25
  depth of root window:    8 planes
  number of colormaps:    minimum 1, maximum 1
  default colormap:    0x21
  default number of colormap cells:    8
  preallocated pixels:    black 0, white 255
  options:    backing-store YES, save-unders YES
  largest cursor:    640x480
  current input event mask:    0x0
  number of visuals:    1
  default visual id:  0x22
  visual:
    visual id:    0x22
    class:    TrueColor
    depth:    8 planes
    available colormap entries:    8 per subfield
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    8 bits


-------- rrrrrrrrrrrrrrrrrrrip ----------------

I don't know if this worked before, I started installing cairo from scratch
together with other gtk-stuff.

still diggin' ...

  cheers,
  	  Peter
	  
Comment 14 Behdad Esfahbod 2006-09-11 07:41:07 UTC
So, RGB16_655 and RGB8_332 formats here.
Comment 15 Carl Worth 2006-09-13 15:18:35 UTC
(In reply to comment #14)
> So, RGB16_655 and RGB8_332 formats here.

Yes. And there's an affirmative report (from Jeff Bowman in comment #12) that
his RGB_332 problem goes away with cairo 1.2.4. Meanwhile, comment #13 says that
an RGB16_655 problem persists in cairo 1.2.4.

I had expected that the code in 1.2.2 and 1.2.4 would be able to handle any
masks that could be thrown at it, so there's a bit more investigation needed here.

Thanks to all for following up,

-Carl
Comment 16 Peter Marquardt 2006-09-18 05:15:56 UTC
Well it does not go away in 1.2.5 (git from 15. sep 2006).

I'll attach 3 different "make ckeck" of cairo, one running on Xdec-Xserver, the
other running on Xorg-Xserver and one on Xnvc.

Whereas apps on Xorg work fine and apps on Xdec and Xvnc fail with:

Xdec:
Error: Cairo 1.2.5 does not yet support the requested image format:
        Depth: 16
        Alpha mask: 0x00000000
        Red   mask: 0x0000001f
        Green mask: 0x000007e0
        Blue  mask: 0x0000f800
Please file an enhancement request (quoting the above) at:
http://bugs.freedesktop.org/enter_bug.cgi?product=cairo
gpe-todo: cairo-image-surface.c:153: _cairo_format_from_pixman_format: Assertion
`NOT_REACHED' failed.
Aborted


and Xvnc:

Error: Cairo 1.2.5 does not yet support the requested image format:
        Depth: 8
        Alpha mask: 0x00000000
        Red   mask: 0x00000007
        Green mask: 0x00000038
        Blue  mask: 0x000000c0
Please file an enhancement request (quoting the above) at:
http://bugs.freedesktop.org/enter_bug.cgi?product=cairo
gpe-todo: cairo-image-surface.c:153: _cairo_format_from_pixman_format: Assertion
`NOT_REACHED' failed.



Comment 17 Peter Marquardt 2006-09-18 05:35:16 UTC
(In reply to comment #16)
> Well it does not go away in 1.2.5 (git from 15. sep 2006).
> 
> I'll attach 3 different "make ckeck" of cairo, one running on Xdec-Xserver, the
> other running on Xorg-Xserver and one on Xnvc.

Sorry I accidently attached the files to #5027 

https://bugs.freedesktop.org/show_bug.cgi?id=5027

(which luckily convers more or less the same issue)
Comment 18 Mark Hunting 2006-09-22 00:49:22 UTC
Same problem here, using Debian Etch, Cairo 1.2.4 and VNC (either 8 or 32 bits)

Error: Cairo does not yet support the requested image format:
        Depth: 32
        Alpha mask: 0x00000000
        Red   mask: 0xffe00000
        Green mask: 0x001ffc00
        Blue  mask: 0x000003ff
Please file an enhacement request (quoting the above) at:
http://bugs.freedesktop.org/enter_bug.cgi?product=cairo
soffice.bin:
/home/dajobe/dev/debian/cairo/cairo-1.2.4/src/cairo-image-surface.c:155:
_cairo_format_from_pixman_format: Assertion `NOT_REACHED' failed.
Comment 19 Carl Worth 2006-09-22 08:56:27 UTC
(In reply to comment #18)
> Same problem here, using Debian Etch, Cairo 1.2.4 and VNC (either 8 or 32 bits)
> 
> Error: Cairo does not yet support the requested image format:
>         Depth: 32
>         Alpha mask: 0x00000000
>         Red   mask: 0xffe00000
>         Green mask: 0x001ffc00
>         Blue  mask: 0x000003ff

So that's a 32-bit RGB format using 11, 11, and 10 bits per channel, (which is
something I don't recall seeing before). That doesn't fit under the current
"8-bit visuals" name for this bug, but it is possible that a single fix might
address both problems.

-Carl
Comment 20 Mark Hunting 2006-09-22 11:35:29 UTC
(In reply to comment #19)

> So that's a 32-bit RGB format using 11, 11, and 10 bits per channel, (which is
> something I don't recall seeing before). That doesn't fit under the current
> "8-bit visuals" name for this bug, but it is possible that a single fix might
> address both problems.
> 
> -Carl

You are right. I had this problem when running vncserver at 8 or 32 bits. I
found this bug and inserted mine a bit too fast I think. Running vncserver at 16
bits solved my problem by the way.
Comment 21 Behdad Esfahbod 2006-10-25 14:26:27 UTC
*** Bug 8716 has been marked as a duplicate of this bug. ***
Comment 22 Behdad Esfahbod 2006-10-25 14:26:42 UTC
*** Bug 8719 has been marked as a duplicate of this bug. ***
Comment 23 Behdad Esfahbod 2006-10-25 14:26:50 UTC
*** Bug 8723 has been marked as a duplicate of this bug. ***
Comment 24 Behdad Esfahbod 2006-10-30 08:10:18 UTC
*** Bug 8828 has been marked as a duplicate of this bug. ***
Comment 25 Behdad Esfahbod 2006-11-01 05:51:42 UTC
*** Bug 8847 has been marked as a duplicate of this bug. ***
Comment 26 Torsten Wolf 2007-03-15 02:47:37 UTC
I just encountered this bug with cairo 1.4.0:

Error: Cairo 1.4.0 does not yet support the requested image format:
        Depth: 8
        Alpha mask: 0x00000000
        Red   mask: 0x00000000
        Green mask: 0x00000000
        Blue  mask: 0x00000000

xdpyinfo output follows:

version number:    11.0
vendor string:    DECWINDOWS compatibility. Hummingbird Ltd.
vendor release number:    90017
maximum request size:  4194300 bytes
motion buffer size:  1
bitmap unit, bit order, padding:    8, MSBFirst, 32
image byte order:    MSBFirst
number of supported pixmap formats:    4
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 8, bits_per_pixel 8, scanline_pad 32
    depth 12, bits_per_pixel 12, scanline_pad 32
    depth 24, bits_per_pixel 32, scanline_pad 32
keycode range:    minimum 8, maximum 254
focus:  window 0x300000d, revert to PointerRoot
number of extensions:    14
    BIG-REQUESTS
    DOUBLE-BUFFER
    Extended-Visual-Information
    GLX
    HCL-DOS-Access
    HCLMISC
    HCLxperf
    LBX
    SECURITY
    SHAPE
    TOG-CUP
    XC-APPGROUP
    XC-MISC
    XInputExtension
default screen number:    0
number of screens:    1

screen #0:
  dimensions:    1600x1200 pixels (320x240 millimeters)
  resolution:    127x127 dots per inch
  depths (4):    1, 8, 12, 24
  root window id:    0x77
  depth of root window:    8 planes
  number of colormaps:    minimum 8183, maximum 8183
  default colormap:    0x20
  default number of colormap cells:    256
  preallocated pixels:    black 1, white 0
  options:    backing-store WHEN MAPPED, save-unders NO
  largest cursor:    32x32
  current input event mask:    0x780000
    SubstructureNotifyMask   SubstructureRedirectMask FocusChangeMask          
    PropertyChangeMask       
  number of visuals:    55
  default visual id:  0x21
  visual:
    visual id:    0x21
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x22
    class:    StaticGray
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x23
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x24
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x25
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x26
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x27
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x28
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x29
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x2a
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x2b
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x2c
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x2d
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x2e
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x2f
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x30
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x31
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x32
    class:    PseudoColor
    depth:    12 planes
    available colormap entries:    4096
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x33
    class:    PseudoColor
    depth:    12 planes
    available colormap entries:    4096
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x34
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x35
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x36
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x37
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x38
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x39
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x3a
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x3b
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x3c
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x3d
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x3e
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x3f
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x40
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x41
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x42
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x43
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x44
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x45
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x46
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x47
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x48
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x49
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x4a
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x4b
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x4c
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x4d
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x4e
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x4f
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x50
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x51
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x52
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x53
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x54
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x55
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x56
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x57
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
Comment 27 Carl Worth 2007-03-15 07:18:50 UTC
(In reply to comment #26)
> Error: Cairo 1.4.0 does not yet support the requested image format:
>         Depth: 8
>         Alpha mask: 0x00000000
>         Red   mask: 0x00000000
>         Green mask: 0x00000000
>         Blue  mask: 0x00000000

For what it's worth, the above visual is PseudoColor, not TrueColor. But that visual is also not supported in cairo yet, (see bug #4945).

And looking at your xdpyinfo output:

>   default visual id:  0x21
>   visual:
>     visual id:    0x21
>     class:    PseudoColor
>     depth:    8 planes

Here you can see that the default visual is 8-bit PseudoColor.

>     class:    TrueColor
>     depth:    24 planes

And here you can see that 24-bit TrueColor is also available (in several varieties). So if you can configure your X server to advertise one of these as the default visual, or if you can configure your applications to select one of these visuals, then you should be able to get things working without any change to cairo.

-Carl
Comment 28 Torsten Wolf 2007-03-15 22:53:49 UTC
It works exactly in the way you told me. Thanks a lot!
Comment 29 Behdad Esfahbod 2007-03-16 09:51:19 UTC
There is a bug filed against Gtk+ to make it refuse to choose a visual that is known not to work.
Comment 30 Behdad Esfahbod 2007-04-03 17:32:42 UTC
*** Bug 10068 has been marked as a duplicate of this bug. ***
Comment 31 Behdad Esfahbod 2007-04-24 16:54:02 UTC
*** Bug 10750 has been marked as a duplicate of this bug. ***
Comment 32 George Forman 2007-04-24 17:01:40 UTC
(In reply to comment #1)
> PS. I'm quite curious as to what X server you are using that presents this 8-bit
> TrueColor visual.


People often use 'vncserver -depth 8' to avoid shipping lots of bits around the network, e.g. remote connections.

Hope this one will get fixed.
Comment 33 Carl Worth 2007-06-08 17:02:57 UTC
*** Bug 10513 has been marked as a duplicate of this bug. ***
Comment 34 Kalle Vahlman 2007-07-12 02:33:39 UTC
*** Bug 10958 has been marked as a duplicate of this bug. ***
Comment 35 Kalle Vahlman 2007-07-12 05:09:10 UTC
*** Bug 11263 has been marked as a duplicate of this bug. ***
Comment 36 Behdad Esfahbod 2007-09-03 12:29:37 UTC
*** Bug 12248 has been marked as a duplicate of this bug. ***
Comment 37 Norman Ramsey 2007-10-07 04:46:43 UTC
This bug persists in Cairo 1.4.10 with the X server provided as part of the VNC package (vncserver):

Error: Cairo 1.4.10 does not yet support the requested image format:
        Depth: 8
        Alpha mask: 0x00000000
        Red   mask: 0x00000007
        Green mask: 0x00000038
        Blue  mask: 0x000000c0
Please file an enhancement request (quoting the above) at:
http://bugs.freedesktop.org/enter_bug.cgi?product=cairo
firefox-bin: /home/dajobe/dev/debian/cairo/libcairo-1.4.10/src/cairo-image-surface.c:199: _cairo_format_from_pixman_format: Assertion `NOT_REACHED' failed.
Comment 38 Michael R Head 2007-12-26 13:11:28 UTC
(In reply to comment #37)
> This bug persists in Cairo 1.4.10 with the X server provided as part of the VNC
> package (vncserver):

Started getting that recently with azureus under VNC with Debian's libcairo2 1.4.12-2
Comment 39 Charles Buckley 2008-01-13 04:05:09 UTC
I downloaded the source for cairo 1.4.12, and even applied the latest patch that I had seen on another freedesktop bug list (which I can't find at the moment).  

The error still comes up, with both 8-bit and 16-bit xserver connections.  24 bits works OK, but such connections consume bandwidth in a major way.
 
Comment 40 Charles Buckley 2008-01-13 04:35:48 UTC
(In reply to comment #39)
> I downloaded the source for cairo 1.4.12, and even applied the latest patch
> that I had seen on another freedesktop bug list (which I can't find at the
> moment).  
> The error still comes up, with both 8-bit and 16-bit xserver connections.  24
> bits works OK, but such connections consume bandwidth in a major way.

I looked it up -- the patch I applied was cairo-02-8bit-fix1.4.6.diff, posted in the protocol for bug 4945.  

No improvement.
Comment 41 Bruce Becker 2008-02-12 11:30:41 UTC
Firefox 3b2 executing on solaris 11 sun4u snv_46 sparc SUNW,Ultra-80

X display on solaris 9 sun4u sparc SUNW,Ultra-2 8-bit framebuffer -

Error: Cairo moz does not yet support the requested image format:
        Depth: 8
        Alpha mask: 0x00000000
        Red   mask: 0x00000000
        Green mask: 0x00000000
        Blue  mask: 0x00000000

(segmentation fault happened too, sigh)


should this be a new bug report?
Comment 42 Carl Worth 2008-03-20 17:28:04 UTC
This bug is now fixed in the cairo 1.5.14 snapshot and will appear in the imminent 1.6.0 release.

Please test and let me know how things go.

-Carl
Comment 43 Norman Ramsey 2008-04-24 17:21:57 UTC
 > http://bugs.freedesktop.org/show_bug.cgi?id=7735
 > 
 > --- Comment #42 from Carl Worth <cworth@cworth.org>  2008-03-20 17:28:04
 > PST --- This bug is now fixed in the cairo 1.5.14 snapshot and will appear
 > in the imminent 1.6.0 release.
 > 
 > Please test and let me know how things go.

I've just tested with Debian iceweasel 2.0.0.14-2 and the fix is excellent!
Not only to things work with VNC but the colors are actually better
than with the old version. 

Thank you for your good work!


Norman
Comment 44 Behdad Esfahbod 2008-04-24 17:35:02 UTC
(In reply to comment #43)
>  > http://bugs.freedesktop.org/show_bug.cgi?id=7735
>  > 
>  > --- Comment #42 from Carl Worth <cworth@cworth.org>  2008-03-20 17:28:04
>  > PST --- This bug is now fixed in the cairo 1.5.14 snapshot and will appear
>  > in the imminent 1.6.0 release.
>  > 
>  > Please test and let me know how things go.
> 
> I've just tested with Debian iceweasel 2.0.0.14-2 and the fix is excellent!
> Not only to things work with VNC but the colors are actually better
> than with the old version. 

Excellent!  Now, you should try my dithering work:

  http://lists.freedesktop.org/archives/cairo/2008-March/013602.html

Cheers,
behdad

> Thank you for your good work!
> 
> 
> Norman
>