Bug 79417 - r600-cayman: GPU lockup in Planetary Annihilation (PTE 66705) on HD6950
Summary: r600-cayman: GPU lockup in Planetary Annihilation (PTE 66705) on HD6950
Status: RESOLVED INVALID
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 77449
  Show dependency treegraph
 
Reported: 2014-05-29 15:32 UTC by sxx.public
Modified: 2019-07-04 00:48 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg output when GPU locked up (11.66 KB, text/plain)
2014-05-29 15:32 UTC, sxx.public
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sxx.public 2014-05-29 15:32:28 UTC
Created attachment 100117 [details]
dmesg output when GPU locked up

This report partially related to bug 68527, but It's have to be new task because since  yesterday's update game is using OpenGL 3.3 core profile which make it compatible with open source drivers. Game is tested and working on Intel HD4600 and LLVMPipe.

Unfrortunately running it on HD6950 with R600 still result in GPU lockup. As in old task one of problems is complicated sun shader, but even if I remove this one I still get GPU lockup and I have no idea what else might cause issue.

I made two traces using git version of APItrace, both traces takes when game running on Intel HD4600. First trace is with sun shader:
https://drive.google.com/file/d/0B5LwC3WbdQ3DWjFJaVRiNndVdk0/edit?usp=sharing
Second without sun shader:
https://drive.google.com/file/d/0B5LwC3WbdQ3DOC1JVFhFTHdObVE/edit?usp=sharing
Both traces lockup GPU and X when I try to replay them on HD6950.

Useful part of "dmesg" output attached to task too.

PS: My system info:
Ubuntu 14.04 with kernel 3.14 and Mesa from Oibaf PPA:
OpenGL Renderer: Gallium 0.4 on AMD CAYMAN
OpenGL Version: 3.3 (Core Profile) Mesa 10.3.0-devel (git-ecee4c4 trusty-oibaf-ppa)
Comment 1 sxx.public 2014-05-30 17:49:10 UTC
After <agd5f> and <zgreg> advice in IRC I tested trace with LLVM shader backend, without HyperZ and "nosb" option. Unfortunately it's did nothing and I still get GPU lockup.
Comment 2 russianneuromancer 2015-08-01 13:03:40 UTC
This issue is still reproducible with current Mesa?
Comment 3 Timothy Arceri 2019-07-04 00:48:59 UTC
No reply. Closing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.