Bug 80248 - Khronos conformance egl_image_external tests fail
Summary: Khronos conformance egl_image_external tests fail
Status: RESOLVED NOTABUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 89870 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-06-19 18:53 UTC by Anuj Phogat
Modified: 2015-04-15 02:44 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anuj Phogat 2014-06-19 18:53:39 UTC
ES2-CTS.gtf.GL2ExtensionTests.egl_image_external.TestTargetTextureValid and 
ES2-CTS.gtf.GL2ExtensionTests.egl_image_external.TestSimple fail due to mesa commit:

commit f5947c2bc72a630d1abd2a12221d8dafd3a24be4
Author: Topi Pohjolainen <topi.pohjolainen@intel.com>
Date:   Mon Nov 12 13:38:08 2012 +0200

    i965: enable image external sampling for imported dma-buffers
    
    Signed-off-by: Topi Pohjolainen <topi.pohjolainen@intel.com>
    Reviewed-by: Chad Versace <chad.versace@linux.intel.com>
Comment 1 Matt Turner 2014-08-11 02:31:21 UTC
(In reply to comment #0)
> ES2-CTS.gtf.GL2ExtensionTests.egl_image_external.TestTargetTextureValid and 
> ES2-CTS.gtf.GL2ExtensionTests.egl_image_external.TestSimple fail due to mesa
> commit:

I think you're just missing a patch against the test suite. That commit enabled the extension and is from 2012. The tests have certainly passed since then. I'm going to close as NOTABUG.
Comment 2 Ian Romanick 2014-08-13 20:51:44 UTC
The problem turned out to be that Meas wasn't built with GBM enabled.  If GBM is not enabled, I guess we can't actually do anything with this extension.  It seems like libEGL shouldn't advertise it.  Right?
Comment 3 Ian Romanick 2014-08-13 20:52:51 UTC
Actually... if Anuj submitted this bug in June, it probably was just the test suite missing patches.

He also ran into the other problem more recently.
Comment 4 Matt Turner 2014-08-13 21:00:38 UTC
Right, for posterity, Mesa needs to be built with --with-egl-platforms= with drm. E.g., --with-egl-platforms=x11,drm --enable-gbm
Comment 5 shuo.wang 2015-04-15 02:44:00 UTC
*** Bug 89870 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.