Bug 80876 - luxrays/slg4 hangs GPU (CEDAR)
Summary: luxrays/slg4 hangs GPU (CEDAR)
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 99553
  Show dependency treegraph
 
Reported: 2014-07-03 22:06 UTC by Aaron Watry
Modified: 2019-09-18 19:16 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
luxrays diff/patch to disable image support while reproducing bug. (877 bytes, text/plain)
2014-07-03 22:06 UTC, Aaron Watry
Details
Kernel source for luxrays (302.26 KB, text/plain)
2014-07-03 22:07 UTC, Aaron Watry
Details
dmesg from luxrays GPU hang/reset (82.33 KB, text/plain)
2014-07-03 22:08 UTC, Aaron Watry
Details
bitcode, assembly, and rest of stderr from slg4 run (826.20 KB, text/plain)
2014-07-03 22:59 UTC, Aaron Watry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Watry 2014-07-03 22:06:38 UTC
Created attachment 102222 [details]
luxrays diff/patch to disable image support while reproducing bug.

While working on getting the Luxrays slg4 program running (which is invoked as part of the luxmark CL-based raytracing benchmark), I encountered some GPU hangs on the evergreen card I'm using (CEDAR, Radeon 5400-series).

Hardware:
Core i7-2600k
16GB DDR3
Radeon 5400-series PCI express w/ dual 1080p monitors

Software:
Mesa: Git master
LLVM: 3.5svn
drm: fairly recent git
libclc: git master + a few extra patches to implement missing built-ins
luxrays: From http://src.luxrender.net/luxrays, with the attached patch.

Steps:
1) Checkout luxrays source from the mercurial repository
2) Apply patch to disable image support in the renderer
3) Build luxrays from source (cmake).
4) run bin/slg4
5) Watch the UI start to pop-up and the GPU reset.

dmesg, kernel source, llvm bitcode to be attached.  rlockup_*.c cs trace available as a 35MB gzipped C file (>300MB uncompressed).
Comment 1 Aaron Watry 2014-07-03 22:07:24 UTC
Created attachment 102223 [details]
Kernel source for luxrays
Comment 2 Aaron Watry 2014-07-03 22:08:54 UTC
Created attachment 102224 [details]
dmesg from luxrays GPU hang/reset
Comment 3 Aaron Watry 2014-07-03 22:31:47 UTC
Grumble..  I was just attempting to get the bitcode since I had lost my previous dump of that... and now for some reason the GPU's not locking and I'm instead getting an LLVM diagnostic handler and a segfault due to invalid reads (according to valgrind).

I'm pretty sure I'll be able to reproduce this, but part of my software stack needs to be rebuild first.
Comment 4 Aaron Watry 2014-07-03 22:59:14 UTC
Created attachment 102226 [details]
bitcode, assembly, and rest of stderr from slg4 run

This contains the llvm bitcode, R600 assembly, and the rest of the stdout as generated from:
R600_DUMP_SHADERS=1 RADEON_DUMP_SHADERS=1 R600_DEBUG=cs,compute,trace_cs bin/slg4 2> bitcode.ll
Comment 5 Aaron Watry 2014-07-03 23:16:22 UTC
The bitcode and hangs were all reproduced with luxrays commit 2099 (hg up -r 2099) and the image support disabling patch applied. Commit 2099 is the same as was used for the luxrender_v1.3.1 tag.
Comment 6 GitLab Migration User 2019-09-18 19:16:32 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/515.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.