Bug 8166 - mplayer -vo xv stutters on keyboard input, when -vo x11 doesn't
Summary: mplayer -vo xv stutters on keyboard input, when -vo x11 doesn't
Status: RESOLVED INVALID
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 6.9.0
Hardware: x86 (IA32) NetBSD
: high normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-07 02:23 UTC by George Michaelson
Modified: 2010-10-19 15:46 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.o.log of NetBSD host with problem in xv (37.51 KB, text/plain)
2006-09-07 02:24 UTC, George Michaelson
no flags Details
dmesg for the NetBSD host to confirm vga card etc (11.47 KB, text/plain)
2006-09-07 02:25 UTC, George Michaelson
no flags Details
X11 config file (3.28 KB, text/plain)
2006-09-07 02:26 UTC, George Michaelson
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description George Michaelson 2006-09-07 02:23:43 UTC
http://algebras.org/ggm/mvi_1447.avi is a movie of mplayer runnning, once under
-vo xv and once under -vo x11. when its run under -vo xv, keyboard input causes
the video output to stutter badly. in the example, its bi-stable between two
states of the OSD of mplayer. in worse cases, it has a 3-5 second freeze and
looses audio sync.

this doesn't happen under XFree86 built for NetBSD. It looks to be about the xv
aspects of the radeon driver on this platform. I can supply Xorg.0.log, dmesg,
and X11 conf as required.
Comment 1 George Michaelson 2006-09-07 02:24:56 UTC
Created attachment 6859 [details]
Xorg.o.log of NetBSD host with problem in xv
Comment 2 George Michaelson 2006-09-07 02:25:46 UTC
Created attachment 6860 [details]
dmesg for the NetBSD host to confirm vga card etc
Comment 3 George Michaelson 2006-09-07 02:26:10 UTC
Created attachment 6861 [details]
X11 config file
Comment 4 Michel Dänzer 2006-09-07 02:51:27 UTC
This could be bug 7431.
Comment 5 George Michaelson 2006-09-07 03:03:25 UTC
The behaviour is the same under XAA and EXA. I did send in an EXA enabled conf,
but I can reproduce this with XAA.

otherwise, yes I think it may be the same, or similar.

-George
Comment 6 Daniel Stone 2007-02-27 01:33:28 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 7 Alex Deucher 2008-12-02 23:40:03 UTC
does this still happen with a more recnet version of the radeon driver (6.9.0 or ati git master)?
Comment 8 Alex Deucher 2010-10-19 15:46:54 UTC
closing due to lack of feedback.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.