Bug 82759 - [HSW] very visible rendering errors from fast clear change
Summary: [HSW] very visible rendering errors from fast clear change
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium major
Assignee: Kristian Høgsberg
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 82891 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-18 09:56 UTC by Tapani Pälli
Modified: 2014-08-22 06:39 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
steam ui screenshot (29.87 KB, image/jpeg)
2014-08-18 09:57 UTC, Tapani Pälli
Details
dota loading screenshot (143.28 KB, image/jpeg)
2014-08-18 09:57 UTC, Tapani Pälli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tapani Pälli 2014-08-18 09:56:34 UTC
Steam UI and Dota2 loading screen have black tiles in them, attached screenshot tells more than words.

Tested this on HSW machine, 64bit Ubuntu 14.04 and 32bit Mesa (dota2 is 32bit)

Bisected to following commit:
--- 8< ---
commit 2f28a0dc23165123cf1e8b5942acad37878edd8a
Author: Kristian Høgsberg <krh@bitplanet.net>
Date:   Mon Jul 7 16:44:58 2014 -0700

    i965: Implement fast color clears using meta operations
    
    This patch uses the infrastructure put in place by previous patches
    to implement fast color clears and replicated color clears in terms of
    meta operations.
    
    This works all the way back to gen7 where fast clear was introduced and
    adds support for fast clear on gen8.  It replaces the blorp path
    completely and improves on a few cases.  Layered clears are now done
    using instanced rendering and multiple render-target clears use a
    MRT shader with rep16 writes.
    
    Signed-off-by: Kristian Høgsberg <krh@bitplanet.net>
    Acked-by: Kenneth Graunke <kenneth@whitecape.org>
Comment 1 Tapani Pälli 2014-08-18 09:57:08 UTC
Created attachment 104809 [details]
steam ui screenshot
Comment 2 Tapani Pälli 2014-08-18 09:57:24 UTC
Created attachment 104810 [details]
dota loading screenshot
Comment 3 Eero Tamminen 2014-08-18 10:53:04 UTC
Is also visible in Synmark's Batch* tests, so this can be trivially caught by its validation.  Besides the vertical stripes, there's also noise visible in some of the triangles, so there might be even couple of separate issues.

Happens only on HSW (GT3e), not on IVB or BYT.
Comment 4 Tapani Pälli 2014-08-18 12:04:16 UTC
We tried with Curro on HSW GT2 and did not reproduce the errors (using Synmark tests).
Comment 5 Eero Tamminen 2014-08-20 13:58:34 UTC
I'm not seeing issues listed in this bug anymore [1], but bug 82796 issue (with Synmark CPU<->GPU communication terrain tests) still remains.

[1] Maybe fixed by: e6a53533b7aa790f66b044f77deaac450aa39fde

Tapani, what about you, can this be set as fixed?
Comment 6 Tapani Pälli 2014-08-22 04:26:13 UTC
yes
Comment 7 Eero Tamminen 2014-08-22 06:39:59 UTC
*** Bug 82891 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.