Bug 82891 - [HSW_GT3e Bisected]Show "black vertical stripes" when running GpuTest v0.5_triangle_fullscreen
Summary: [HSW_GT3e Bisected]Show "black vertical stripes" when running GpuTest v0.5_tr...
Status: CLOSED DUPLICATE of bug 82759
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: high major
Assignee: Kristian Høgsberg
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-21 04:47 UTC by zhoujian
Modified: 2014-10-10 04:59 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
triangle.png (184.93 KB, image/png)
2014-08-21 04:49 UTC, zhoujian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zhoujian 2014-08-21 04:47:24 UTC
Platform:HSW_GT3e
 Libdrm:(master)libdrm-2.4.56-8-gd9ce09de12131fa8c5ff2d7c2dbd6b61d8a5fd14
 Mesa:(master)a4359bcaa599291ef1588376a419a0bcfbd02396
 Xserver:(master)xorg-server-1.15.99.902-121-g2f5cf9ff9a0f713b7e0386
 Xf86_video_intel:(master)2.99.914-60-gf5469681b620d9d6ccaf53e92ed31f931cb03b0d
 Cairo:(master)932548ef25864958ef966ffe83e7c945c3ff3cd4
 Libva:(master)acfcd5f0637a951d50c5112c7dfbd46f1d0dcdb3
 Libva_intel_driver:(master)f3f49f2f0e6b3669d9b09341a11cf0b96e138674
 Kernel:   (drm-intel-nightly)09fcefee6357c6b3a30016adc0e306496172d6b7
Bug detailed description:
------------------------------------
Show "black vertical stripes" when running GpuTest v0.5_triangle_fullscreen on HSW_GT3e,This problem both on gnome-session and RAW X,this issue doesn't exist on IVB/BDW/BYT,you can see triangle.png.
It's Mesa regression,bisected the result first bad commit is:
commit 2f28a0dc23165123cf1e8b5942acad37878edd8a
Author:     Kristian Høgsberg <krh@bitplanet.net>
AuthorDate: Mon Jul 7 16:44:58 2014 -0700
Commit:     Kristian Høgsberg <krh@bitplanet.net>
CommitDate: Fri Aug 15 11:25:47 2014 -0700
    i965: Implement fast color clears using meta operations
Reproduce steps:
---------------------------------------------
1. xinit&
2. ./GpuTest /test=triangle /width=1920 /height=1080 /fullscreen /benchmark /no_scorebox
Comment 1 zhoujian 2014-08-21 04:49:05 UTC
Created attachment 105001 [details]
triangle.png
Comment 2 Eero Tamminen 2014-08-21 13:42:56 UTC
I think this could be duplicate of bug 82759 (result looks exactly the same) and already fixed.
Comment 3 zhoujian 2014-08-22 01:42:50 UTC
Retest this issue,found this issue have disappeared,retest commit:git-d682ebe.
Comment 4 Eero Tamminen 2014-08-22 06:39:59 UTC

*** This bug has been marked as a duplicate of bug 82759 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.