Bug 82808 - [IVB/BYT-M/BDW] Unigine-Heaven4.0 on IVB/BYT-M/BDW performance is slower(↓2x) ) than HSW_GT3e.
Summary: [IVB/BYT-M/BDW] Unigine-Heaven4.0 on IVB/BYT-M/BDW performance is slower(↓2x)...
Status: VERIFIED NOTABUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium major
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-19 08:56 UTC by zhoujian
Modified: 2014-12-08 03:22 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
ivb_dmesg.log (40.02 KB, text/plain)
2014-08-19 08:58 UTC, zhoujian
Details
heaven4.0_strace_log (110.06 KB, application/octet-stream)
2014-08-19 09:02 UTC, zhoujian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zhoujian 2014-08-19 08:56:33 UTC
----------------------------------------------
Platform: IVB/BYT-M/HSW
Libdrm: (master)libdrm-2.4.56-8-gd9ce09de12131fa8c5ff2d7c2dbd6b61d8a5fd14
Mesa: (master)ce4d3f3104b01b6148ce7b1c7ecd354fd2f062c9
Xserver: (master)xorg-server-1.15.99.902-121-g2f5cf9ff9a0f713b7e038636484c77f113a5f10a
Xf86_video_intel: (master)2.99.914-55-gf8e632f396bf4b0473dca0516567d56a29954cf3
Cairo: (master)7736d08e22ffd7ab9968617164c7e027125b7755
Libva: (master)acfcd5f0637a951d50c5112c7dfbd46f1d0dcdb3
Libva_intel_driver: (master)82d2ed8d7da3619c0ea467c06604f5626fc0b901
Kernel: (drm-intel-nightly)186631131a9289dad22f51315d78b9b6ac5b425f

Bug detailed description:
----------------------------------------------
Unigine-Heaven4.0 on IVB/BYT-M/BDW very slower(↓2x) than HSW_GT3e, this issue doesn’t exist on Unigine-Heaven3.0, this is new case. Not found regression, you can see ivb_dmesg.log and heaven4.0_strace_log.

Reproduce steps:
---------------------------------------------
1.   xinit&
2.export MESA_GL_VERSION_OVERRIDE=3.2
  export MESA_GLSL_VERSION_OVERRIDE=150
  export LD_LIBRARY_PATH=bin/:$LD_LIBRARY_PATH
  export force_glsl_extensions_warn=true
3.vblank_mode=0 ./bin/heaven_x64 -video_app opengl -data_path ../ -sound_app null -engine_config ../data/heaven_4.0.cfg -system_script heaven/unigine.cpp -video_mode -1 -video_fullscreen 1 -extern_define PHORONIX -video_width 1920 -video_height 1080
Comment 1 zhoujian 2014-08-19 08:58:54 UTC
Created attachment 104874 [details]
ivb_dmesg.log
Comment 2 zhoujian 2014-08-19 09:02:32 UTC
Created attachment 104875 [details]
heaven4.0_strace_log
Comment 3 Eero Tamminen 2014-08-22 07:24:30 UTC
> Unigine-Heaven4.0 on IVB/BYT-M/BDW very slower(↓2x) than HSW_GT3e, this issue doesn’t exist on Unigine-Heaven3.0.

Heaven (v4) is memory BW bound and GT3e has more of that (with its 128MB L4) than IVB/BYT/BDW devices have have currently so Heaven being clearly faster on it is to be expeced.

Are you saying that Heaven v3 is same speed on GT3e as it's on BYT?  If it's system memory bandwidth bound (= memory accesses don't fit into L4), I can buy it being fairly same speed as on IVB & BDW as the devices we currently have, have same bandwidth.  However, if BYT is same speed, that is definitely wrong.
Comment 4 zhoujian 2014-09-01 05:27:42 UTC
(In reply to comment #3)
> > Unigine-Heaven4.0 on IVB/BYT-M/BDW very slower(↓2x) than HSW_GT3e, this issue doesn’t exist on Unigine-Heaven3.0.
> 
> Heaven (v4) is memory BW bound and GT3e has more of that (with its 128MB L4)
> than IVB/BYT/BDW devices have have currently so Heaven being clearly faster
> on it is to be expeced.
> 
> Are you saying that Heaven v3 is same speed on GT3e as it's on BYT?  If it's
> system memory bandwidth bound (= memory accesses don't fit into L4), I can
> buy it being fairly same speed as on IVB & BDW as the devices we currently
> have, have same bandwidth.  However, if BYT is same speed, that is
> definitely wrong.
I didn't mean that.Both of them are slower on IVB/BYT-M/BDW comparing with they are on HSW-GT3e. What I wanted to express is that Heaven v4 is too slow.
besides, Heaven v3 is faster than Heaven v4.
Comment 5 Eero Tamminen 2014-09-02 15:20:56 UTC
Heaven v4 is memory bandwidth bound.  With its L4, GT3e has more memory bandwidth than the other HW configurations you listed, so Heaven being faster there is to be expected.

As to Heaven 3 being faster than Heaven 4, besides being different versions of the demo, they also use a different version of the Unigine engine, so there can well be performance affecting differences in what they do.

Is there some other platform (like Windows/Intel or Mesa/Nvidia) where there isn't a performance difference between v3 and v4?  Does old v3 render correctly with Mesa (hard to say now with bug 82897, but before that issue came up)?
Comment 6 wendy.wang 2014-12-08 03:21:56 UTC
(In reply to Eero Tamminen from comment #5)
> Heaven v4 is memory bandwidth bound.  With its L4, GT3e has more memory
> bandwidth than the other HW configurations you listed, so Heaven being
> faster there is to be expected.
> 
> As to Heaven 3 being faster than Heaven 4, besides being different versions
> of the demo, they also use a different version of the Unigine engine, so
> there can well be performance affecting differences in what they do.
> 
> Is there some other platform (like Windows/Intel or Mesa/Nvidia) where there
> isn't a performance difference between v3 and v4?  Does old v3 render
> correctly with Mesa (hard to say now with bug 82897, but before that issue
> came up)?

Test on HSW-GT3e with Windows 8.1, Heaven 3 also faster than Heaven 4 by 52%.

Close this bug as not a bug.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.