Bug 82897 - force_glsl_extensions_warn=true breaks Unigine Sanctuary & Tropics demos when GL_ARB_gpu_shader5 exposed
Summary: force_glsl_extensions_warn=true breaks Unigine Sanctuary & Tropics demos when...
Status: RESOLVED WONTFIX
Alias: None
Product: Mesa
Classification: Unclassified
Component: glsl-compiler (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium major
Assignee: Chris Forbes
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 82900 91778 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-21 08:22 UTC by zhoujian
Modified: 2018-03-06 04:18 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments
GL errors from Sanctuary apitrace trace (3.72 KB, text/plain)
2014-08-22 07:31 UTC, Eero Tamminen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zhoujian 2014-08-21 08:22:38 UTC
Platform:IVB/HSW/BYT-M
Libdrm:(master)libdrm-2.4.56-8-gd9ce09de12131fa8c5ff2d7c2dbd6b61d8a5fd14
Mesa:(master)a1853eaea7fa5caf59b52567cc49f964ce5293ec
Xserver:(master)xorg-server-1.15.99.902-121-g2f5cf9ff9a0f713b7e0386
Xf86_video_intel:(master)2.99.914-60-gf5469681b620d9d6ccaf53e92ed31f931cb03b0d
Cairo:(master)932548ef25864958ef966ffe83e7c945c3ff3cd4
Libva:(master)acfcd5f0637a951d50c5112c7dfbd46f1d0dcdb3
Libva_intel_driver:(master)f3f49f2f0e6b3669d9b09341a11cf0b96e138674
Kernel:(drm-intel-nightly)49ceddc7b3b0e3f7eb21b9fb4c9b840cff630047

Bug detailed description:
----------------------------------------------
Unigine-demos performance improved 100%~400% on IVB/HSW/BYT-M,This issue both on gnome-session and Raw X,this issue doesn't exist on BDW.
It's Mesa regression,bisected the result show first bad commit is:
commit 4a3667993e8c3bace135791efbe2163a82bbfc56
Author:     Chris Forbes <chrisf@ijw.co.nz>
AuthorDate: Sun Aug 10 14:36:25 2014 +1200
Commit:     Chris Forbes <chrisf@ijw.co.nz>
CommitDate: Fri Aug 15 19:24:56 2014 +1200
    i965: Enable ARB_gpu_shader5 on Gen7

Reproduce steps:
---------------------------------------------
1. xinit&
2. export LD_LIBRARY_PATH=bin/:$LD_LIBRARY_PATH 
   export force_glsl_extensions_warn=true
   vblank_mode=0 ./bin/Sanctuary -video_app opengl -data_path ../ -sound_app null -system_script sanctuary/unigine.cpp -engine_config ../data/unigine.cfg -video_mode -1 -video_fullscreen 1 -extern_define PHORONIX -video_width 1920 -video_height 1080
Comment 1 Chris Forbes 2014-08-21 10:12:54 UTC
Why is this a bug?
Comment 2 Chris Forbes 2014-08-21 10:57:07 UTC
To clarify, are you seeing any change in the rendering as well, or is the performance just suspiciously better?
Comment 3 Kenneth Graunke 2014-08-21 17:11:08 UTC
The Unigine demos are using the force_glsl_extensions_warn driconf workaround, which now enables GL_ARB_gpu_shader5, turning 'sample' into a reserved word.  So a bunch of the shaders fail to compile.
Comment 4 Eero Tamminen 2014-08-22 06:49:16 UTC
*** Bug 82900 has been marked as a duplicate of this bug. ***
Comment 5 Eero Tamminen 2014-08-22 07:31:56 UTC
Created attachment 105083 [details]
GL errors from Sanctuary apitrace trace

Attached are first GL errors output from Sanctuary apitrace trace (in total, error log file was tens of MBs).
Comment 6 meng 2014-08-29 01:35:27 UTC
The issue also exists on mesa-10.3-rc1 testing.
------------------------------------------------
kernel: 3.16.1
Mesa:  (10.3)git-627d31d
Xf86_video_intel:2.99.914
Libdrm:libdrm-2.4.56
Libva: 1.3.1
vaapi-intel-driver: 1.3.2
Cairo: 1.12.16 
Xserver:xorg-server-1.16.0
Comment 7 Eero Tamminen 2014-09-03 13:13:49 UTC
This affects only Sanctuary & Tropics, Heaven and Valley seem to work fine.
Comment 8 Kenneth Graunke 2014-09-04 18:50:02 UTC
Yeah, the workarounds are only necessary for the older, discontinued, extremely non-compliant version of the Unigine engine.  The new Unigine engine used in Heaven and Valley is actually quite good, and doesn't need so many workarounds.

That's why I keep advocating for dropping Sanctuary and Tropics.  They're demos for an engine I haven't seen used anywhere except those demos, and you can't even buy it anymore.
Comment 9 Kaveh 2014-11-03 21:34:03 UTC
Since Unigine Sanctuary and Tropics are "broken" benchmarks, no bug that only shows up on these benchmarks will be considered P1 going forward. Heaven and Valley bugs, however, will be considered for P1 designation.
Comment 10 Kenneth Graunke 2015-08-29 20:31:45 UTC
*** Bug 91778 has been marked as a duplicate of this bug. ***
Comment 11 Timothy Arceri 2018-03-06 04:18:07 UTC
I think it's probably safe to close this as won't fix.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.