Bug 82846 - [BDW Bisected] Gpu hang when running Lightsmark v2008/Warsow v1.0/Xonotic v0.7/unigine-demos
Summary: [BDW Bisected] Gpu hang when running Lightsmark v2008/Warsow v1.0/Xonotic v0....
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: high critical
Assignee: Matt Turner
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 82929 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-20 06:44 UTC by zhoujian
Modified: 2014-08-25 05:25 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg.log (56.48 KB, text/plain)
2014-08-20 06:56 UTC, zhoujian
Details
Xorg.0.log (15.45 KB, text/plain)
2014-08-20 06:57 UTC, zhoujian
Details
output.log (449.71 KB, application/octet-stream)
2014-08-20 07:01 UTC, zhoujian
Details
hsw_gpuhang_log (397.63 KB, application/octet-stream)
2014-08-21 01:14 UTC, zhoujian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zhoujian 2014-08-20 06:44:04 UTC
Platform: BDW/HSW
Libdrm: (master)libdrm-2.4.56-8-gd9ce09de12131fa8c5ff2d7c2dbd6b61d8a5fd14
Mesa: (master)a4359bcaa599291ef1588376a419a0bcfbd02396
Xserver: (master)xorg-server-1.15.99.902-121-g2f5cf9ff9a0f713b7e038636484c77f113a5f10a
Xf86_video_intel:(master)2.99.914-60-gf5469681b620d9d6ccaf53e92ed31f931cb03b0d
Cairo: (master)932548ef25864958ef966ffe83e7c945c3ff3cd4
Libva: (master)acfcd5f0637a951d50c5112c7dfbd46f1d0dcdb3
Libva_intel_driver: (master)f3f49f2f0e6b3669d9b09341a11cf0b96e138674
Kernel: (drm-intel-nightly)git-2b6e6b

Bug detailed description:
----------------------------------------------
Gpu hang when running unigine-demos on BDW/HSW, this issue doesn’t exist on BYT/IVB.The problem exist both on gnome-sesssion and Raw X.

It is Mesa regression, bisected result show the first bad commit is:
commit 45eb06566830eb49551c27262cdd936bf42ec922
Author:     Matt Turner <mattst88@gmail.com>
AuthorDate: Sun Aug 17 00:45:27 2014 -0700
Commit:     Matt Turner <mattst88@gmail.com>
CommitDate: Mon Aug 18 18:18:50 2014 -0700
    i965: Enable instruction compaction on Gen8+.

Please see dmesg.log and output.log and Xorg.0.log

Reproduce steps:
---------------------------------------------
1. xinit& 
2. export LD_LIBRARY_PATH=bin/:$LD_LIBRARY_PATH 
export force_glsl_extensions_warn=true
vblank_mode=0 ./bin/Tropics -video_app opengl -data_path ../ -sound_app null -system_script tropics/unigine.cpp -engine_config ../data/unigine.cfg -video_mode -1 -video_fullscreen 1 -video_multisample 0 -extern_define PHORONIX -video_width 1920 -video_height 1080
Comment 1 zhoujian 2014-08-20 06:56:30 UTC
Created attachment 104938 [details]
dmesg.log
Comment 2 zhoujian 2014-08-20 06:57:40 UTC
Created attachment 104940 [details]
Xorg.0.log
Comment 3 zhoujian 2014-08-20 07:01:39 UTC
Created attachment 104941 [details]
output.log
Comment 4 Eero Tamminen 2014-08-20 10:11:04 UTC
(In reply to comment #0)
> Gpu hang when running unigine-demos on BDW/HSW, this issue doesn’t exist on
> BYT/IVB.The problem exist both on gnome-sesssion and Raw X.
> 
> It is Mesa regression, bisected result show the first bad commit is:
> commit 45eb06566830eb49551c27262cdd936bf42ec922
>     i965: Enable instruction compaction on Gen8+.

That commit affects only GEN8+.  Are you *really* sure it's cause of hangs also HSW?
Comment 5 zhoujian 2014-08-21 01:07:49 UTC
(In reply to comment #4)
> (In reply to comment #0)
> > Gpu hang when running unigine-demos on BDW/HSW, this issue doesn’t exist on
> > BYT/IVB.The problem exist both on gnome-sesssion and Raw X.
> > 
> > It is Mesa regression, bisected result show the first bad commit is:
> > commit 45eb06566830eb49551c27262cdd936bf42ec922
> >     i965: Enable instruction compaction on Gen8+.
> 
> That commit affects only GEN8+.  Are you *really* sure it's cause of hangs
> also HSW?

Yes,I'm sure,this is GPU Hang output log(hsw_gpuhang_log) on HSW.
Comment 6 zhoujian 2014-08-21 01:14:54 UTC
Created attachment 104996 [details]
hsw_gpuhang_log
Comment 7 Eero Tamminen 2014-08-21 13:38:57 UTC
(In reply to comment #5)
> Yes,I'm sure,this is GPU Hang output log(hsw_gpuhang_log) on HSW.

Does reverting that particular commit fix the hang on HSW?

(It should affect only GEN8+, so I think the commit responsible for HSW hang is another one, maybe related to same changes, but a different one.)
Comment 8 lu hua 2014-08-22 08:14:34 UTC
*** Bug 82929 has been marked as a duplicate of this bug. ***
Comment 9 Matt Turner 2014-08-22 16:27:51 UTC
Pushed a fix: http://cgit.freedesktop.org/mesa/mesa/commit/?id=d77f5603a5de26e66561ec003118bbfb1a07666b

Please confirm it fixes it for you.
Comment 10 zhoujian 2014-08-25 03:30:30 UTC
(In reply to comment #7)
> (In reply to comment #5)
> > Yes,I'm sure,this is GPU Hang output log(hsw_gpuhang_log) on HSW.
> 
> Does reverting that particular commit fix the hang on HSW?
> 
> (It should affect only GEN8+, so I think the commit responsible for HSW hang
> is another one, maybe related to same changes, but a different one.)

I retest it, this issue not reproduced on HSW.
BTW,on latest Raw X,also not found this issue.
Comment 11 zhoujian 2014-08-25 03:32:47 UTC
Verified it,the mesa commit is git-8d8a5eb.


bug/show.html.tmpl processed on Feb 26, 2017 at 07:46:07.
(provided by the Example extension).