Bug 82929 - [BDW Bisected]glxgears causes X hang
Summary: [BDW Bisected]glxgears causes X hang
Status: VERIFIED DUPLICATE of bug 82846
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: highest blocker
Assignee: Matt Turner
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-22 01:39 UTC by lu hua
Modified: 2014-08-26 01:56 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lu hua 2014-08-22 01:39:13 UTC
System Environment:
--------------------------
Platform: BDW
Libdrm:		(master)libdrm-2.4.56-8-gd9ce09de12131fa8c5ff2d7c2dbd6b61d8a5fd14
Mesa:		(master)a1853eaea7fa5caf59b52567cc49f964ce5293ec
Xserver:	(master)xorg-server-1.15.99.902-121-g2f5cf9ff9a0f713b7e038636484c77f113a5f10a
Xf86_video_intel:(master)2.99.914-60-gf5469681b620d9d6ccaf53e92ed31f931cb03b0d
Libva:		(master)acfcd5f0637a951d50c5112c7dfbd46f1d0dcdb3
Libva_intel_driver:(master)f3f49f2f0e6b3669d9b09341a11cf0b96e138674
Kernel:   (drm-intel-nightly)49ceddc7b3b0e3f7eb21b9fb4c9b840cff630047

Bug detailed description:
---------------------------
On BDW with mesa master branch, start X, then run glxgears, or run Piglit/ogles3conform/ogles2conform/ogles1conform case, X hang occurs. 
It works well on 10.2 branch.
Bisect is in process.

run glxgears
output:
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
intel_do_flush_locked failed: Input/output error

dmesg
[  298.895715] [drm] stuck on render ring
[  298.896666] [drm] GPU HANG: ecode 0:0x87949ff9, in X [4431], reason: Ring hung, action: reset
[  298.896668] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[  298.896669] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[  298.896671] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[  298.896672] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[  298.896673] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[  298.896756] [drm:i915_error_work_func] resetting chip
[  298.898723] [drm:init_status_page] render ring hws offset: 0x007fb000
[  298.898737] [drm:init_status_page] bsd ring hws offset: 0x0081d000
[  298.898746] [drm:init_status_page] blitter ring hws offset: 0x0083e000
[  298.898753] [drm:init_status_page] video enhancement ring hws offset: 0x0085f000
[  298.898788] [drm:ironlake_update_primary_plane] Writing base 00000000 00000000 0 0 7680
[  300.896739] [drm:intel_print_rc6_info] Enabling RC6 states: RC6 on, RC6p off, RC6pp off
[  304.898807] [drm] stuck on render ring
[  304.899776] [drm] GPU HANG: ecode 0:0xf3cffffe, in X [4431], reason: Ring hung, action: reset
[  304.899863] [drm:i915_error_work_func] resetting chip
[  304.901815] [drm:init_status_page] render ring hws offset: 0x007fb000
[  304.901829] [drm:init_status_page] bsd ring hws offset: 0x0081d000
[  304.901838] [drm:init_status_page] blitter ring hws offset: 0x0083e000
[  304.901846] [drm:init_status_page] video enhancement ring hws offset: 0x0085f000
[  304.901881] [drm:ironlake_update_primary_plane] Writing base 00000000 00000000 0 0 7680
[  306.899854] [drm:intel_print_rc6_info] Enabling RC6 states: RC6 on, RC6p off, RC6pp off

Reproduce steps:
---------------------------- 
1. xinit
2. glxgears
Comment 1 lu hua 2014-08-22 02:00:09 UTC
Bisect shows: 45eb06566830eb49551c27262cdd936bf42ec922 is the first bad commit
commit 45eb06566830eb49551c27262cdd936bf42ec922
Author:     Matt Turner <mattst88@gmail.com>
AuthorDate: Sun Aug 17 00:45:27 2014 -0700
Commit:     Matt Turner <mattst88@gmail.com>
CommitDate: Mon Aug 18 18:18:50 2014 -0700

    i965: Enable instruction compaction on Gen8+.

    Reviewed-by: Kenneth Graunke <kenneth@whitecape.org>
Comment 2 lu hua 2014-08-22 08:14:34 UTC

*** This bug has been marked as a duplicate of bug 82846 ***
Comment 3 lu hua 2014-08-26 01:56:54 UTC
Verified.Fixed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.