Bug 82900 - [IVB/HSW/BYT-M bisected]Show "white screen" when running unigine-demos
Summary: [IVB/HSW/BYT-M bisected]Show "white screen" when running unigine-demos
Status: CLOSED DUPLICATE of bug 82897
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: high major
Assignee: Chris Forbes
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-21 09:02 UTC by zhoujian
Modified: 2015-05-14 02:23 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
1.png (43.86 KB, text/plain)
2014-08-21 09:02 UTC, zhoujian
Details
1.png (43.86 KB, image/png)
2014-08-22 00:28 UTC, zhoujian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zhoujian 2014-08-21 09:02:28 UTC
Platform:IVB/HSW/BYT-M
Libdrm:(master)libdrm-2.4.56-8-gd9ce09de12131fa8c5ff2d7c2dbd6b61d8a5fd14
Mesa:(master)a1853eaea7fa5caf59b52567cc49f964ce5293ec
Xserver:(master)xorg-server-1.15.99.902-121-g2f5cf9ff9a0f713b7e0386
Xf86_video_intel:(master)2.99.914-60-gf5469681b620d9d6ccaf53e92ed31f931cb03b0d
Cairo:(master)932548ef25864958ef966ffe83e7c945c3ff3cd4
Libva:(master)acfcd5f0637a951d50c5112c7dfbd46f1d0dcdb3
Libva_intel_driver:(master)f3f49f2f0e6b3669d9b09341a11cf0b96e138674
Kernel:(drm-intel-nightly)49ceddc7b3b0e3f7eb21b9fb4c9b840cff630047

Bug detailed description:
----------------------------------------------
Show "white screen" when running unigine-demos on IVB/HSW/BYT-M,This issue both on gnome-session and Raw X,this issue doesn't exist on BDW.you can see 1.png.
It's Mesa regression,bisected the result show first bad commit is:
commit 4a3667993e8c3bace135791efbe2163a82bbfc56
Author:     Chris Forbes <chrisf@ijw.co.nz>
AuthorDate: Sun Aug 10 14:36:25 2014 +1200
Commit:     Chris Forbes <chrisf@ijw.co.nz>
CommitDate: Fri Aug 15 19:24:56 2014 +1200
    i965: Enable ARB_gpu_shader5 on Gen7

Reproduce steps:
---------------------------------------------
1. xinit&
2. export LD_LIBRARY_PATH=bin/:$LD_LIBRARY_PATH 
   export force_glsl_extensions_warn=true
   vblank_mode=0 ./bin/Sanctuary -video_app opengl -data_path ../ -sound_app null -system_script sanctuary/unigine.cpp -engine_config ../data/unigine.cfg -video_mode -1 -video_fullscreen 1 -extern_define PHORONIX -video_width 1920 -video_height 1080
Comment 1 zhoujian 2014-08-21 09:02:58 UTC
Created attachment 105021 [details]
1.png
Comment 2 zhoujian 2014-08-22 00:28:59 UTC
Created attachment 105068 [details]
1.png
Comment 3 Eero Tamminen 2014-08-22 06:49:16 UTC

*** This bug has been marked as a duplicate of bug 82897 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.